Results 1 to 9 of 9

Thread: Headphone sound only since 12.04 upgrade

  1. #1
    Join Date
    Sep 2009
    Location
    Greater Manchester UK
    Beans
    37
    Distro
    Ubuntu 11.04 Natty Narwhal

    Headphone sound only since 12.04 upgrade

    Since upgrading my laptop to Precise 12.04 , I can only get sound on my headphone socket despite the output being set to internal speakers . I have tried all the usual things and can only assume it is a bug in pulse audio . When I boot into Oneric 11.10 the speakers work fine . There is a reference to this problem on launchpad and suggests downloading different sound card drivers , but not sure how to do this . Beginner level replies please .

  2. #2
    Join Date
    Feb 2012
    Location
    Athens/Greece
    Beans
    Hidden!
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Headphone sound only since 12.04 upgrade

    Hi ,
    try to use alsamixer to see if something is muted.. open terminal and write
    Code:
    alsamixer
    next option is to install pavucontrol..
    Code:
    sudo apt-get install pavucontrol
    and tick your speakers from there .

  3. #3
    Join Date
    Sep 2009
    Location
    Greater Manchester UK
    Beans
    37
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Headphone sound only since 12.04 upgrade

    Thanks very much , I will give both ideas a try .

  4. #4
    Join Date
    Jul 2010
    Location
    /run/shm
    Beans
    822
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Headphone sound only since 12.04 upgrade

    Also make sure you set Analogue output in the Connector option in the Sound Settings.
    Quote Originally Posted by Linus Torvalds
    "Most good programmers do programming not because they expect to get paid or get adulation by the public, but because it is fun to program."

  5. #5
    Join Date
    Sep 2009
    Location
    Greater Manchester UK
    Beans
    37
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Headphone sound only since 12.04 upgrade

    I have tried all these suggestions ,and according to alsamixer and pavucontrol the speakers are working ,but still no sound . So , have bought a mini plug in speaker to connect to the headphone socket , works fine . Problem ( sort of ) solved .

  6. #6
    Join Date
    Jul 2010
    Location
    /run/shm
    Beans
    822
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Headphone sound only since 12.04 upgrade

    Question. Did you upgrade from 11.10 or did you reinstall 12.04 on top of 11.10? If the former, could you try burning a LiveCD/USB and check if sound works there? If it does, then there was an error during the upgrade or something else. If it doesn't then there was a regression and you should file a bug.
    Quote Originally Posted by Linus Torvalds
    "Most good programmers do programming not because they expect to get paid or get adulation by the public, but because it is fun to program."

  7. #7
    Join Date
    Nov 2009
    Beans
    4

    Re: Headphone sound only since 12.04 upgrade

    i am experiencing the same problem, tried everything that was suggested here. and to answer the latest question, fresh install. everything works except for the built-in speakers. i even installed it again because elsewhere i found that someone had this problem only after upgrading to the 3.2.0-24 kernel so i installed it with 3.2.0-23-generic. Nothing muted, i triple checked (alsamixer)
    Also i am not satisfied with OP's solution of carrying around laptop speakers. (since he didn't return for an answer i assume it was good enough for him)

  8. #8
    Join Date
    Apr 2012
    Beans
    Hidden!

    Re: Headphone sound only since 12.04 upgrade

    Are you running a 64bit system and the alsamixer display
    shows the chipset of VT1708 ??
    Craving anchovy, herring and squid pizza.....with clam sauce

  9. #9
    Join Date
    Dec 2010
    Location
    Cairo, Egypt
    Beans
    176
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Headphone sound only since 12.04 upgrade

    how bout changing the sound card option on pavu. maybe it point to the wrong card. just a suggestions

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •