Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Flash not working in 10.04, 12.04

  1. #1
    Join Date
    Sep 2008
    Beans
    13

    Flash not working in 10.04, 12.04

    AMD 3400+, 2GB RAM, GeForce FX5200 (AGP likely, but not 100% sure)

    Kubuntu 10.04 and 12.04 32b, no fancy repos. Mozilla Firefox.

    Used to run flash plugins fairly well, then all of a sudden stopped working in 12.04. Only shows a black rectangle in youtube.
    My guess: either X or flash got updated and broked.
    this was on 10.04, told the user to wait until 12.04 is out. So today upgraded.
    Found that even while I installed nvidia-173 it won't load as nvidia is still working on getting the 173to work with the new kernel API ( I wonder tho: why is 173 then released? In an LTS?).

    So right now it's nouveau.

    12.04: still no flash. Tried flashplugin-installer, tried adobe-flashplugin, tried purging this and uninstalling that and copying the .so manually to moz' plugin dir - nuthin.

    Cannot tell the culprit, have no idea where to look, what to try.

  2. #2
    Join Date
    Nov 2004
    Location
    Maine
    Beans
    1,830
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Flash not working in 10.04, 12.04

    have you installed ubuntu-restricted-addons and ubuntu-restricted-extras that should pull flash for you and works great here.

    if all else fails try firefox flash aid addon.
    Wireless script
    Dave
    Registered Linux User #462608
    Ubuntu-Mate 16.04

  3. #3
    Join Date
    Sep 2008
    Beans
    13

    Re: Flash not working in 10.04, 12.04

    Installed restricted packages: no go
    Installed flash aid: no go either.

    Should mention: running on nouveau as the 173 driver won't load.


    Out of options.

  4. #4
    Join Date
    Sep 2008
    Beans
    13

    Re: Flash not working in 10.04, 12.04

    Got it fixed... well.. sort of.
    I got an old flashplayer v10 from Adobe and copied that into the plugins dir.
    Not really the best solution but until Adobe can be arsed to make their friggin plugin work or html5 finally brings the bloody flash plugin to the death it deserves it will have to do.

    I checked again: that GeForce FX5200 is indeed an AGP board on a KT600 chipset. I wouldn't be surprised if that is part of the problem in terms of video drivers.
    After all, for reasons beyond me the system won't install the 173 driver and sticks to nouveau.

  5. #5
    Join Date
    Jul 2007
    Location
    Melbourne, Australia
    Beans
    3,475
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Flash not working in 10.04, 12.04

    Can't help with the nvidia driver, however to get the latest flash going on 12.04 64 bit; go here. Worked for me, when all else failed!
    Windows is the best virus detector on the market!
    Ubuntu attracts Human Beings - Windows attracts viruses and worms

  6. #6
    Join Date
    Sep 2008
    Beans
    13

    Re: Flash not working in 10.04, 12.04

    Well, that seems to tackle 64bit issues explicitly, doesnt it?

  7. #7
    Join Date
    Apr 2006
    Location
    Galax,Va. USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Flash not working in 10.04, 12.04

    Enjoy the temporary fix while you can. Adobe doesn't seem to believe that Linux is worth supporting any more in the future because it's too hard for their developers to deal with. That's just one of the reasons we need a good standard for web video. Not this Flash crap.
    Iguana

    Registered Linux User #490719

  8. #8
    Join Date
    Jan 2010
    Beans
    1

    Re: Flash not working in 10.04, 12.04

    Same problem here guys.

    AMD Athlon(tm) XP 2800+
    Nvidia FX5200
    Ubuntu 12.04

  9. #9
    Join Date
    Aug 2011
    Beans
    1

    Re: Flash not working in 10.04, 12.04

    Quote Originally Posted by DexterF View Post
    Got it fixed... well.. sort of.
    I got an old flashplayer v10 from Adobe and copied that into the plugins dir.
    Not really the best solution but until Adobe can be arsed to make their friggin plugin work or html5 finally brings the bloody flash plugin to the death it deserves it will have to do.

    I checked again: that GeForce FX5200 is indeed an AGP board on a KT600 chipset. I wouldn't be surprised if that is part of the problem in terms of video drivers.
    After all, for reasons beyond me the system won't install the 173 driver and sticks to nouveau.
    This did the trick for me! Thank you! I used (Released 2/28/2011) Flash Player 10.2.152.32 from http://helpx.adobe.com/flash-player/...-versions.html, flash is really smoothe again.

  10. #10
    Join Date
    Apr 2013
    Beans
    1

    Smile Re: Flash working again in 10.04, 12.04

    The version Flash Player 10.2.152.32 doesn't hold linux 32bits library.
    I found a good version on this wiki.
    The version 10.3.183.11 works well with my ubuntu 10.04LTS on AMD 2400+ and GeForce FX5200.
    Regards.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •