Results 1 to 6 of 6

Thread: High fps with guvcview but low fps with v4l

  1. #1
    Join Date
    Jun 2011
    Beans
    36

    High fps with guvcview but low fps with v4l

    Hello,

    I am having problems with my webcam, Microsoft LifeCam Cinema. In guvcview the camera is working perfectly (1280x720 30fps), but when using other (I guess v4l, but not sure) applications, I only get 10fps on 1280x720. For example when using v4l Control Panel and start a preview in MPlayer, it only gets 10fps.

    I'm on Ubuntu 10.10. Anyone any idea why this is, and more importantly how to fix this?

    Thanks in advanced!

  2. #2
    Join Date
    Oct 2009
    Location
    Reykjavk, sland
    Beans
    13,687
    Distro
    Xubuntu

    Re: High fps with guvcview but low fps with v4l

    My first recommendation is a fresh install of one of the 12.04 Buntus.

    10.10 is unsupported and contains, as you have experienced, obsolete packages.
    Bringing old hardware back to life. About problems due to upgrading.
    Please visit Quick Links -> Unanswered Posts.
    Don't use this space for a list of your hardware. It only creates false hits in the search engines.

  3. #3
    Join Date
    Jun 2011
    Beans
    36

    Re: High fps with guvcview but low fps with v4l

    I figured out it is a problem with my gstreamer. Somehow it only can handle 10fps yuv, except when you force it to do 30fps like this:

    gst-launch v4l2src device=/dev/video0 ! 'video/x-raw-yuv, width=1280, height=720,framerate=30/1' ! xvimagesink

    Problem is that I have no idea how to get this working in my c++/OpenCV program. Any ideas?

  4. #4
    Join Date
    Oct 2009
    Location
    Reykjavk, sland
    Beans
    13,687
    Distro
    Xubuntu

    Re: High fps with guvcview but low fps with v4l

    I have already posted my main idea, but you didn't respond to it.
    Bringing old hardware back to life. About problems due to upgrading.
    Please visit Quick Links -> Unanswered Posts.
    Don't use this space for a list of your hardware. It only creates false hits in the search engines.

  5. #5
    Join Date
    Jun 2011
    Beans
    36

    Re: High fps with guvcview but low fps with v4l

    Quote Originally Posted by mrgs View Post
    I have already posted my main idea, but you didn't respond to it.
    Sorry. I will try this today. Thank you for your reply

  6. #6
    Join Date
    Jun 2011
    Beans
    36

    Re: High fps with guvcview but low fps with v4l

    mrgs thanks again for your reply. I did a fresh install of Ubuntu 12.04, that did not directly did the trick, but did do something. The problem was that I was setting the camera to 1280x800 in my own program and to 1280x720 in other programs. In the 1280x800 mode, the camera can only output 10fps. Setting it to 1280x720 with the freshly installed Ubuntu 12.04 gave me 30 fps throughput!

    Thanks again

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •