Quote Originally Posted by adityeah View Post

Here's what I did:

added this line at the end of /etc/modprobe.d/alsa-base.conf:

options snd-hda-intel model=generic

That was all. I think I had tried it earlier too but somehow it was not working. Maybe I had tried too much.

But I think the problem was indeed that it was trying to use the ALC888 as ALC662 and that was not happening.

Thanks for the responses. Now I can stick to Ubuntu and try to get friendly with Unity
Perfect! This was one of the last things preventing my Ubuntu experience from being awesome. The stuttering sound was forcing me to listen to Pandora on my mobile device instead of being able to be plugged into my computer.

This also fixed a separate issue I was having with the volume. For some reason the volume was low enough that I had to boost it up above 100% in the sound manager which would distort the sound somewhat. Don't have to do that anymore either!

Here's the motherboard I was running my sound through:
randomdrake:~$ sudo dmidecode -t 2
# dmidecode 2.11
SMBIOS 2.6 present.

Handle 0x0002, DMI type 2, 15 bytes
Base Board Information
	Manufacturer: ASUSTeK Computer INC.
	Product Name: P8P67 LE
	Version: Rev X.0X
	Serial Number: 110119580001965
	Asset Tag: To be filled by O.E.M.
		Board is a hosting board
		Board is replaceable
	Location In Chassis: To be filled by O.E.M.
	Chassis Handle: 0x0003
	Type: Motherboard
	Contained Object Handles: 0
Thanks so much!