Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 47

Thread: Xscreensaver GLSLideshow Does Not See My Images

  1. #21
    Join Date
    Jan 2008
    Beans
    8

    Re: Xscreensaver GLSLideshow Does Not See My Images

    This appears to have worked for me as well.

    Ubuntu 12.04.1 LTS 64 bit.

  2. #22
    Join Date
    Oct 2005
    Location
    Columbus, OH
    Beans
    47

    Re: Xscreensaver GLSLideshow Does Not See My Images

    also worked in 12.10.

  3. #23
    Join Date
    Mar 2005
    Beans
    1,378

    Re: Xscreensaver GLSLideshow Does Not See My Images

    Quote Originally Posted by KestrellKestrell View Post
    I found a fix!
    Code:
    sudo apt-get install libwww-perl
    Again, all you Ubuntu experts out there, WTF?
    Thanks! this worked for me. A new install of 12.04 (keep existing home folder).

  4. #24
    Join Date
    Nov 2006
    Location
    Illinois
    Beans
    32
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Xscreensaver GLSLideshow Does Not See My Images

    Running sudo apt-get install libwww-perl did not help.
    Anybody got it working?
    ed@opengeolog.com
    They say I have a focus problem, I say that I master multifocus phenomena.

  5. #25
    Join Date
    Nov 2008
    Beans
    5

    Talking Re: Xscreensaver GLSLideshow Does Not See My Images

    Quote Originally Posted by eldiabolosk View Post
    Running sudo apt-get install libwww-perl did not help.
    Anybody got it working?

    I tried to run glslideshow from command line

    /usr/lib/xscreensaver/glslideshow

    I found that LWP::Simple perl module was not installed.
    The following code will install the perl module.

    $sudo cpan
    cpan> install LWP::Simple
    cpan> exit

    Refer to this link for more details.
    http://stackoverflow.com/questions/1...mple-pm-in-inc

  6. #26
    Join Date
    Jul 2010
    Beans
    100

    Re: Xscreensaver GLSLideshow Does Not See My Images

    Thanks for this answer worked for me.
    The annoying part is that I have installed xscreensaver on a whole bunch of computers, and they all worked fine, except this one!
    The hardware of all the computers has been very similar, ie all HP and all fairly new.

    Oh well it solved the problem which is the important thing.

  7. #27
    Join Date
    May 2012
    Beans
    11

    Re: Xscreensaver GLSLideshow Does Not See My Images

    Hello all, I'm sorry to bother you with this, but it seems none of the solutions found here working for me.
    Uninstalling and reinstalling xscreensaver and perl din'd work either.
    The only thing I can say is that GLslideshow used to work (picking up my set of photos) before I installed Eclipse and Node.js.
    I don't know if it's related to it, maybe this can give a hint to someone.
    Thank you for any idea.
    D

  8. #28
    Join Date
    May 2012
    Beans
    11

    Re: Xscreensaver GLSLideshow Does Not See My Images

    Hi all, here another thing I discovered.
    Running xscreensaver-demo from command line
    I get this:
    unable to write /tmp/.xscreensaver-getimage.cache: Permession denied
    Maybe it's related to the problem
    David

  9. #29
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Xscreensaver GLSLideshow Does Not See My Images

    Quote Originally Posted by dbaruzzini View Post
    Hi all, here another thing I discovered.
    Running xscreensaver-demo from command line
    I get this:
    unable to write /tmp/.xscreensaver-getimage.cache: Permession denied
    Maybe it's related to the problem
    David
    What are the permissions/ownership of that file:
    Code:
    ls -al /tmp/.xscreensaver-getimage.cache
    If it is not owned by your user account, you'll need to either delete the file or change the ownership.

    What version of ubuntu are you using? In 13.10, that file sits in my home directory, not /tmp.

  10. #30
    Join Date
    May 2012
    Beans
    11

    Re: Xscreensaver GLSLideshow Does Not See My Images

    Hi Toz, thank you for replying and sorry for not coming back to you earlier, pretty busy week.
    Sorry also for not putting any system specs.
    I'm running 12.04 with gnome shell 3.4.1 and the version of Xscreensaver is the 5.15 (installed via apt-get install).
    Back to the problem, the weird thing is that there is no /tmp/.xscreensaver-getimage.cache.
    In fact the message can be red as "I can't write this file I need".
    The weird thing is, as you say, that Xscreensaver should try to write the file in my home directory...wait, let me check...in fact the file is right there.

    So what have we got here is a script somewhere with a faulty address isn't it?
    What do you think?
    I mean, I've played around with some programming stuff, instaling thing I didn't understand.
    Maybe something has overwritten some system file telling some kind of script to point to /tmp instead of /home, I don't know it's a long shot.

    Anyway I'v got my ".xscreensaver-getimage.cache" file right where it belongs (/home) and my /tmp seems to work fine (only root can do things there)

    Thanks for any reply and sorry for my bad english and poor knowledge of anything.

    D

Page 3 of 5 FirstFirst 12345 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •