Page 3 of 3 FirstFirst 123
Results 21 to 23 of 23

Thread: Slow transfer between ubuntu 12.04 and network hdd

  1. #21
    Join Date
    Dec 2006
    Munich, Germany
    Ubuntu 12.04 Precise Pangolin

    Cool Re: Slow transfer between ubuntu 12.04 and network hdd

    I am having similar problems.

    I have Ubuntu 10.04, which shares file systems using Samba. My Windows 7 client is able to read files at only 1.5Mbps. A Windows-XP client Virtual Machine is able to read files at around 50Mbps (i.e. using Samba, but not using the network adaptor).

    I have a "Broadcom Corporation NetXtreme BCM5751 Gigabit Ethernet PCI Express (rev 21)", so not the low power version of the chip described in some of the posts above.
    If it ain't broke, don't fix it.

  2. #22
    Join Date
    Jan 2013
    DK - DE - ES - GB

    Re: Slow transfer between ubuntu 12.04 and network hdd

    Same problem with 12.04 and Samba getting files from a NAS.

    My laptop is with the newest i7 3840qm 2.8 GHz for mobile units, ssd & ordinary hd, r8168 eth. card and a lot of other fine stuff. The driver for the network card is the r8168-driver and not the r8169-driver which comes with a Ubuntu/kernel installation.

    Describing (and showing) the problem here also:

    Have tried to add the following two lines (placed under 'Misc', all 3 combinations) in /etc/samba/smb.conf:
    SO_RCVBUF=8192 SO_SNDBUF=8192
    socket options = TCP_NODELAY

    - First when I wrote them in ONE LINE, like this, it worked a little better:
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

    - The speed jumped from 1MB or less to around 3 MB. Nice, but still not anything like 1000Mb/s

    Checked eth0 with mii-tool and ethtool:

    mii-tool says half duplex and ethtool says full duplex.
    Tried to change the setting 'in' mii-tool, but that didn't change anything.
    Don't know why the different results and what to try at this point to manage these two different results.


    Here the formulation of the problem from the YouTube page:

    The NAS and the Ubuntu 12.04-laptop are connected to the same switch - and these three parts run a 1000 Mbit/s-network.

    The Ubuntu 10.04-PC is connected to the internet-routeren with a 100 Mbit/s-network - and this internet-routeren feeds also the switchen where the NAS and the Ubuntu 12.04-laptop is connected to.

    The NAS can deliver op to 100 MByte/s = 800 Mbit/s (losely calculated)
    The network of the switch can deliver 1000 Mbit/s = 125 MByte/s (losely calculated)
    The Ubuntu 12.04-laptop runs with 1000 Mbit/s and a test shows that it downloads from the NAS with around 8.0 MByte/s = 16 Mbit/s (losely calculated). (THIS SLOW SPEED IS A PROBLEM!)

    The network of the internet-router delivers 100 Mbit/s = 12.5 MByte/s (losely calculated)
    The Ubuntu 10.04-PC runs 100 Mbit/s and a test shows that it downloads from the NAS with around 4.7 MByte/s. (only half of the possible speed, but not the problem right here)

    As I was chatting on a IRC channel next to testing the download from the NAS I came on the idea to isolate the switch from the router - not that this interfered with the download between the NAS and the Ubuntu 12.04-laptop. The speed dropped to far under 1 MByte/s !!! even thou it is supposed to be between 50 MByte/s and 100 MByte/s !!! ...

    ... thus confirming the original test (from when the video was uploaded) described in the following:

    First I store from the Ubuntu 10.04-PC some bulky files around 14 GB on the LaCie. This runs with 9.3 MByte/s. This speed fits perfect into the capacity of the 100 Mbit/s ethernet card of this computer.

    When the files are completely transferede to the NAS server I go on with the next steps.

    From the Ubuntu 12.04-laptop (a brand new laptop by Okt. 2012 with all of the best) I now drag and drop the same files from the NAS server to the desktop. The transfer rate is now ONLY 1 - 2 MB/s !!! - What happens?... This is actually a computer with a 1.000 Mbit/s ethernet card!!! A card ten times faster than that on the other computer.

    NO COMES THE FUNNY PART: While the Ubuntu 12.04-laptop is fetching the data from the NAS, I now start to fetch another big bulky file from the same NAS to the desktop on same computer. When these two cuncurrent transfers are running from the same NAS to the same computer, then the transfer rate jumps to what ist expected: around 50 - 100 MByte/s. ... Thats weird!

    As soon as the second transfer stops, the speed of the first transfer drops to 1 - 2 MByte/s again.

    Crazy stuff! - What happens?... Is it Lacie, Ubuntu or Samba?...


    Came on the idea to try a sftp session to the NAS from the 12.04-machine. Speed is around 4.7 MB/s.

    Could this exclude Samba as reason?... Is it more in eth0/TCP somewhere the problem lies?.... Are there any configuration-files for the network-card or TCP somewhere?....


    Using testparm didn't reveal anything interesting, as far as I can see:

    laila@laila:~$ testparm
    Load smb config files from /etc/samba/smb.conf
    rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
    Processing section "[printers]"
    Processing section "[print$]"
    Loaded services file OK.
    ERROR: lock directory /var/run/samba does not exist
    ERROR: pid directory /var/run/samba does not exist
    Server role: ROLE_STANDALONE
    Press enter to see a dump of your service definitions
        server string = %h server (Samba, Ubuntu)
        map to guest = Bad User
        obey pam restrictions = Yes
        pam password change = Yes
        passwd program = /usr/bin/passwd %u
        passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
        unix password sync = Yes
        syslog = 0
        log file = /var/log/samba/log.%m
        max log size = 1000
        dns proxy = No
        usershare allow guests = Yes
        panic action = /usr/share/samba/panic-action %d
        idmap config * : backend = tdb
        comment = All Printers
        path = /var/spool/samba
        create mask = 0700
        printable = Yes
        print ok = Yes
        browseable = No
        comment = Printer Drivers
        path = /var/lib/samba/printers

  3. #23
    Join Date
    Feb 2010
    Ubuntu 9.10 Karmic Koala

    Re: Slow transfer between ubuntu 12.04 and network hdd

    I noticed that If I transfer one file the speed is not great but is acceptable (6.5Mb/s) but if I start a new transfer the speed drops to less than half the previous rate AND NEVER REGAINS original speed if the second file finishes or is stopped.

Page 3 of 3 FirstFirst 123

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts