Results 1 to 2 of 2

Thread: MAAS on VMware ESX 4

  1. #1
    Join Date
    Jan 2012

    MAAS on VMware ESX 4

    I would like to run a 3 node MAAS on one of my ESX servers, mainly for software development purposes against OpenStack.

    I was installing MAAS. I have one main server running the MAAS. I then added two nodes and the nodes shutdown themselves. I then clicked Accept and Commission.

    I then manually powered on the two nodes in vSphere. However, the two nodes won't PXE boot. I'm fairly certain that VMs can PXE boot, but I can't tell why they aren't working. Of course, maybe this is not even a supported configuration. I'm also no expert on how PXE boot works.

    Finally, I tried to run "ubuntu-import-isos" indicatd here: But it says command not found.

    I have a DHCP server in my environment, but I can't let MAAS take that over. I suppose what I could do is set up a new subnet just for this testing environment.

  2. #2
    Join Date
    Jan 2012

    Re: MAAS on VMware ESX 4

    EDIT: So I isolated MAAS on its own network 10.10.10.X and this seemed to have fixed it. DON'T FORGET TO RUN sudo maas-import-isos!!!
    Last edited by amarcionek; May 14th, 2012 at 05:53 PM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts