Results 1 to 9 of 9

Thread: Cannot Update UBUNTU 12.04

  1. #1
    Join Date
    May 2012
    Beans
    4

    Cannot Update UBUNTU 12.04

    When I run the update manager, and check for updates I get:
    Failed to download repository information
    Check your internet Connection
    W:Failed to fetch http://ppa.launchpad.net/psyke83/ppa...source/Sources 404 Not Found
    , W:Failed to fetch http://ppa.launchpad.net/psyke83/ppa...-i386/Packages 404 Not Found
    , E:Some index files failed to download. They have been ignored, or old ones used instead.



  2. #2
    Join Date
    Jun 2011
    Location
    United Kingdom
    Beans
    Hidden!
    Distro
    Lubuntu Development Release

    Re: Cannot Update UBUNTU 12.04

    That won't do anything to official updates...but you've added a PPA that either doesn't exist, or doesn't have packages for your version of *buntu. EDIT: that package (pulse-audio equaliser?) only has packages for up to Lucid. (10.04).

    If it bothers you, can we see the output of:

    Code:
    ls /etc/apt/source.list.d
    from a terminal, then we can remove it. Thanks!

  3. #3
    Join Date
    Aug 2009
    Location
    Under the stairs.
    Beans
    1,408
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Cannot Update UBUNTU 12.04

    That PPA is for the equalizer not available in 12.04...yet. Just remove it from your sources.
    Dell Inspiron 1764 Laptop, Intel CoreTM i5 520M), 4GB Shared Dual Channel DDR3 at 1066MHz, 512MB ATI Mobility RadeonTM HD4330 Integrated Intel HD.

  4. #4
    Join Date
    May 2012
    Beans
    4

    Re: Cannot Update UBUNTU 12.04

    I have these two files in /etc/apt/source.list.d/

    psyke83-ppa-precise.list
    psyke83-ppa-precise.list.save

    Both the files have these lines

    deb http://ppa.launchpad.net/psyke83/ppa/ubuntu precise main
    deb-src http://ppa.launchpad.net/psyke83/ppa/ubuntu precise main

    which one to remove?

  5. #5
    Join Date
    Feb 2011
    Location
    Somewhere...
    Beans
    1,559
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Cannot Update UBUNTU 12.04

    Quote Originally Posted by mukulshukla1992 View Post
    I have these two files in /etc/apt/source.list.d/

    psyke83-ppa-precise.list
    psyke83-ppa-precise.list.save

    Both the files have these lines

    deb http://ppa.launchpad.net/psyke83/ppa/ubuntu precise main
    deb-src http://ppa.launchpad.net/psyke83/ppa/ubuntu precise main

    which one to remove?
    both.

  6. #6
    Join Date
    May 2012
    Beans
    4

    Re: Cannot Update UBUNTU 12.04

    Quote Originally Posted by zombifier25 View Post
    both.
    Sorry to bother you again.. but both the files or both the lines.?

    Do I delete both the files.?

    Or Do i delete both the lines and keep both files empty..?

    or just delete those lines from one file.?

  7. #7
    Join Date
    May 2012
    Beans
    4

    Re: Cannot Update UBUNTU 12.04

    Thank you, I deleted both the lines from both files!

  8. #8
    Join Date
    Jun 2011
    Location
    United Kingdom
    Beans
    Hidden!
    Distro
    Lubuntu Development Release

    Re: Cannot Update UBUNTU 12.04

    You can delete both the files safely now, as they serve no purpose. But they're not harming anything sitting there.

  9. #9
    Join Date
    Jul 2008
    Location
    Raleigh, NC
    Beans
    7
    Distro
    Ubuntu

    Re: Cannot Update UBUNTU 12.04

    Quote Originally Posted by mukulshukla1992 View Post
    Sorry to bother you again.. but both the files or both the lines.?
    Given that it's two months later, you've probably resolved this problem one way or the other, but let me explain for any Googlers who may have this problem.

    The short answer is: the lines.

    Longer answer: you need to understand how the repository system works. Briefly, to install a package on your system, you have two options:

    1. Exactly analogous to how one might install it in Windows or OS X, you acquire (download, USB, etc.) a .deb file, and double click it.
    2. You add a repository that contains the package you want, and then install the package /through the Ubuntu Software Center/.


    The second option is generally The Better Option (TM) because then the Ubuntu Software Center will automatically discover and install any updates. (As opposed to the program informing you that you need to download an update, or you have having a terribly out of date version in 2 months time.)

    In your case, the issue is likely that you recently updated to Ubuntu 12.04, but the repository to which you'd linked in a previous version of Ubuntu has not been updated to handle Precise. Thus, your error.

    To add a repository, you need only one thing: to add its web-accessible URL (e.g. 'http://...') into a file in /etc/apt/. Whether you do this by hand (through the command line, gedit, etc.) or through the graphical interface that is the Ubuntu Software Center is up to you, but each repository added amounts to a single line in one of the files in /etc/apt/.

    So, to fix your error, you want to remove the offending repositories, and that means removing any references (lines) to them in /etc/apt/.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •