Page 7 of 10 FirstFirst ... 56789 ... LastLast
Results 61 to 70 of 99

Thread: Ubuntu 12.04 LTS Suspend not working FIX

  1. #61
    Join Date
    Jul 2007
    Beans
    17

    Re: Ubuntu 12.04 LTS Suspend not working FIX

    Neither script worked for me.

    Toshiba Satellite L505 / Ubuntu 12.04 AMD64 / kernel 3.5.0-37-generic

    Thanks for the effort anyway!

  2. #62
    Join Date
    Aug 2013
    Beans
    1

    Re: Ubuntu 12.04 LTS Suspend not working FIX

    OH MY GOSH life saver for a really old laptop that needs to save battery but had to be turned off if was put in suspence. THANK YOU!!!!!

  3. #63
    Join Date
    Jul 2007
    Beans
    17

    Re: Ubuntu 12.04 LTS Suspend not working FIX

    My system: Toshiba Satellite L505.

    Running Ubuntu 10.04: The problem had appeared at some point but then disappeared probably after some kernel upgrade or other (don't really remember)

    Running Ubuntu 12.04: After a recent fresh install no problem with suspend. After I had installed gnome-session-fallback no problem either. I then went and installed gnome-shell, kubuntu-desktop, plus a bunch of other packages. At some point during tweaking (?), the system could no longer suspend. None of the above solutions worked for me, neither did tuxonice.
    I then deleted a bunch of config (dot) files from my home directory and did yet another fresh install. Then I just installed gnome-session-fallback. The problem was solved! I did a kernel upgrade (now using 3.5.0.37) and still no problem (I am running the gnome-classic session with compiz). I didn't have to touch my BIOS, nor my kernel.

    I have now installed a lot of other packages I needed, but no additional desktop environments, since I realized that it most probably was neither a kernel nor a hardware problem.

    There seems to be no universal solution so, just in case, I have backed up my sources, PPAs and my installed packages, so that I would be ready for a quick reinstall should the problem arise anew. Fortunately, with proper backups, Linux offers the possibility to restore our system within 1-2 hours, should the need arise.

  4. #64
    Join Date
    Aug 2013
    Beans
    1

    Re: Ubuntu 12.04 LTS Suspend not working FIX

    I have tried both fixes and no fix as of yet. Computer is a Desktop with Asus Motherboard P5B. Nothing to special.
    I did get the Hibernation to work but not suspend. After the computer suspend it does shut down but when trying to come back out of suspend the keyboard flashes.

  5. #65
    Join Date
    Jul 2007
    Beans
    17

    Re: Ubuntu 12.04 LTS Suspend not working FIX

    Guys, no promises, but I think I may be on to something. I will need you to verify this, though.

    After a clean install of Ubuntu 12.04 on my Toshiba Satellite, suspend/resume was working just fine. Actually, I spent a whole week suspending/resuming my laptop by closing/opening its lid and I didn't have to reboot once. But suddenly (I don't know how) the same problem occurred again!

    I tried removing the latest packages I had previously installed (using kernel 3.5.0-37): NOTHING
    I tried dist-upgrading the kernel (to 3.5.0-39): NOTHING
    I even tried with a kernel I had compiled for my own CPU (from 3.5.7-16): NOTHING

    Taking inspiration from this solution, I checked to see if I have acpi-support installed on my system. I did. But I also observed on the Software Center description page that:
    This program is run from acpi_fakekey
    So, I opened a terminal, issued
    Code:
    acpi_fakekey
    and closed my lid. Then I opened it again and... SUCCESS! My session resumed!
    Then I closed my lid again and... NO RESUME.

    Then I made several tests with three different kernel versions. The results: each time I issued a acpi_fakekey command BEFORE closing the lid I could suspend/resume.

    So, I suspect that the acpi_fakekey command needs to be inserted at the beginning of the suspend sequence, and/or at the end of the resume sequence.

    However, this needs verification. Could you see if this is reproducible?

    [EDIT: Moved to new thread here]
    Last edited by thanuntu; September 1st, 2013 at 07:49 AM.

  6. #66
    Join Date
    Dec 2010
    Beans
    21

    Re: Ubuntu 12.04 LTS Suspend not working FIX

    Seems not actual anymore...? On Ubuntu 12.4 /3.5.0-40-generic -it does not function.

  7. #67
    Join Date
    Oct 2013
    Beans
    1

    Re: Ubuntu 12.04 LTS Suspend not working FIX

    Working on my ubuntu 12.04!! Thanks a lot!!

  8. #68
    Join Date
    Dec 2009
    Location
    Russian Federation
    Beans
    5

    Re: Ubuntu 12.04 LTS Suspend not working FIX

    At first I thought it was working, but now I understand that the laptop does not react on lid closure
    Last edited by -=gr!n=-; January 30th, 2014 at 06:24 PM.

  9. #69
    Join Date
    Aug 2009
    Location
    Near the beach SE USA
    Beans
    Hidden!

    Re: Ubuntu 12.04 LTS Suspend not working FIX

    I had this same problem a while back but it was because my BIOS was reset. It was reset to S1 sleep mode. This greyed out Suspend but made Hibernate available and working well.
    By changing this setting in BIOS to S3 my Suspend was back and Hibernate disappeared.

    Just my 2 cents.
    Check Java Version | Install Java via WEB UPD8 PPA
    Creating a Custom Maintenance Free GRUB2 Screen Community Wiki
    Intel Core2 Quad CPU Q9550 @ 2.84Ghz. 4.0GB DDR2 RAM, NVIDIA Geforce 9800 GT

  10. #70
    Join Date
    Jan 2014
    Beans
    9

    Re: Ubuntu 12.04 LTS Suspend not working FIX

    It does not work for me, it does nto go in suspend anymore manually. How can I disable that script.

Page 7 of 10 FirstFirst ... 56789 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •