Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Automatic login is disabled but still does not ask for a password on login

  1. #1
    Join Date
    Jul 2011
    Location
    Philippines
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Exclamation Automatic login is disabled but still does not ask for a password on login

    Hello Ubuntu users.
    Ubuntu 12.04

    I have enabled the automatic login and set the password to None this morning so that my sister can use the computer using my account (administrator).

    When I came back, I turned off the automatic login and change my password as well.

    I also created a new user account for my sister to use and set it without a password but not to automatic login so that the login screen will still be displayed prompting the user which account to use on that session.

    When I rebooted my computer, the login screen was displayed which is okay since I turned off the automatic login. I tried to click on the newly created user account and I was able to login without password and that should also be right. I log out of that user account and the login screen again appeared with the user accounts to choose from.

    Here's the problem. When I clicked on my user account, it didn't prompt for a password. I am sure and made sure that I change my password and the automatic login was turned off but still it does (do) not prompt for a password.

    I've rebooted 5 times already and the same thing happens.
    Any ideas? I really need for Ubuntu to prompt for a password on my user account (administrator).
    Last edited by Prescilla; May 11th, 2012 at 02:02 PM. Reason: grammar and spelling

  2. #2
    Join Date
    Jan 2011
    Beans
    193

    Re: Automatic login is disabled but still does not ask for a password on login

    Are you shure you did not make a mistake? I tested what you did.
    Automatic login, works fine
    Ask for password again, works fine, but I had to set a passwd. ( maybe I forgot one )

    Now I have a question, why it is not done just with the passwd- and shadow- file.
    Quite silly.
    When you kick the x from the passwd field in the passwdfile it just does its job as for ages.

    If I was you I checked the passwd file contains the x in the passwd field, indicating to use the shadow file.
    The shadow file contains the real (MD5 ? ) passwd
    Last edited by kuifje09; May 11th, 2012 at 05:40 PM. Reason: Added hint

  3. #3
    Join Date
    Jul 2011
    Location
    Philippines
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Automatic login is disabled but still does not ask for a password on login

    The automatic login is not the problem.
    I turned it off and Ubuntu displays the login page prompting which user account to use. So it is working.

    The problem is that when I click my user account, it does not ask/prompt for a password.
    I am sure that I set up a password. In fact if I install anything via the software center or do a sudo it prompts for a password and my password works.

    What I want is for Ubuntu to prompt a password on login. Which it should because automatic login is turned and I did setup a password. And yes the passwd file contains x.

  4. #4
    Join Date
    Jul 2011
    Location
    Philippines
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Automatic login is disabled but still does not ask for a password on login

    Up

  5. #5
    Join Date
    Jan 2011
    Beans
    193

    Re: Automatic login is disabled but still does not ask for a password on login

    Okay, I see, but sorry I cannot help you further. I do not use the pictograms to login as I do understand you are using ?
    I have to type the name and paswd... Not the fancy MSwindows behavior.
    I think you bump upon a bug ...

    Maybe switch the user interface on login will help at least for logging in once, then go back and see if the problem has gone ?

  6. #6
    Join Date
    Apr 2011
    Location
    Santiago (Dominican Rep)
    Beans
    311
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Automatic login is disabled but still does not ask for a password on login

    Same problem. I have tried different ways to get a password prompt again, but nothing worked.
    Desktop: P-IV 3.2gHz, RAM= 1.5GB, Disk=80GB+500GB, LCD=22", Bought 2012 $90
    File Server: P-III 650mHz, RAM = 384MB, Disks 240 + 300GB, Bought 2005 $60
    File Server HP Vectra VL8i SFF, 2 cables connected: Ethernet and Power

  7. #7
    Join Date
    Apr 2006
    Location
    Dallas, TX
    Beans
    1,359
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Automatic login is disabled but still does not ask for a password on login

    Can you post the contents of /etc/lightdm/lightdm.conf ?

    Have you guys tried what kuifje09 suggested about turning off the users list in lightdm?

    Here is a how-to:

    http://www.tejasbarot.com/2012/04/25...angolin-linux/

    It suggests vi, but of course you can always use your editor of choice. After a reboot, it should ask for a username, see if it requires a password now. If so, you can keep it like that if you want. Or if you prefer the users list, try reversing the process and then try again. If it still doesn't work, maybe you've indeed stumbled upon a bug??

  8. #8
    Join Date
    Jul 2011
    Location
    Philippines
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Automatic login is disabled but still does not ask for a password on login

    thank you for the response.
    i wasn' t able to solve this problem but i reinstalled ubuntu and so it is now working.

  9. #9
    Join Date
    Nov 2008
    Beans
    4

    Re: Automatic login is disabled but still does not ask for a password on login

    Damn, I hit the same problem and was hoping this thread to show a solution. Reinstalling Ubuntu is too extreme (it's not the Windows world).

    Nobody can suggest a fix?

  10. #10
    Join Date
    Nov 2008
    Beans
    4

    Re: Automatic login is disabled but still does not ask for a password on login

    Found a solution here: http://askubuntu.com/questions/10001...n-with-lightdm

    The user got placed in the nologinpasswd group. I had to remove it from there using:
    Code:
    sudo gpasswd -d myusername nopasswdlogin
    This is a bug that Ubuntu should fix. I'm using 12.04.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •