Results 1 to 10 of 10

Thread: Very slow wifi speeds with RNX-N150PCe

  1. #1
    Join Date
    Jun 2014
    Beans
    5

    Question Very slow wifi speeds with RNX-N150PCe

    I've used http://www.newegg.com/Product/Produc...82E16833166047 on a Windows PC for quite some time without much of a problem, but network speed are very slow on Ubuntu 14.04. I've tried looking up how to install the ath9k driver, but I've had no luck so far. Here is the output from the 3 commands I see all in post I've looked at.

    lspci

    Code:
    00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890 PCI to PCI bridge (external gfx0 port B) (rev 02)
    00:02.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890 PCI to PCI bridge (PCI express gpp port B)
    00:09.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890 PCI to PCI bridge (PCI express gpp port H)
    00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 SATA Controller [IDE mode] (rev 40)
    00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
    00:12.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
    00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
    00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
    00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 SMBus Controller (rev 42)
    00:14.1 IDE interface: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 IDE Controller (rev 40)
    00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) (rev 40)
    00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 LPC host controller (rev 40)
    00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 PCI to PCI Bridge (rev 40)
    00:14.5 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
    00:15.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB700/SB800/SB900 PCI to PCI bridge (PCIE port 0)
    00:15.3 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB900 PCI to PCI bridge (PCIE port 3)
    00:16.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
    00:16.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
    00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 0
    00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 1
    00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 2
    00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 3
    00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 4
    00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 5
    01:00.0 VGA compatible controller: NVIDIA Corporation GK107 [GeForce GT 640] (rev a1)
    01:00.1 Audio device: NVIDIA Corporation GK107 HDMI Audio Controller (rev a1)
    02:00.0 USB controller: Etron Technology, Inc. EJ168 USB 3.0 Host Controller (rev 01)
    04:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)
    05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
    iwconfig

    Code:
    eth0      no wireless extensions.
    
    lo        no wireless extensions.
    
    
    wlan0     IEEE 802.11bgn  ESSID:"my very own network"  
              Mode:Managed  Frequency:2.437 GHz  Access Point: 10:6F:3F:28:98:28   
              Bit Rate=19.5 Mb/s   Tx-Power=20 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
              Link Quality=25/70  Signal level=-85 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:30  Invalid misc:183   Missed beacon:0


    rfkill list

    Code:
    0: phy0: Wireless LAN 
       Soft blocked: no
        Hard blocked: no

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,521
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Very slow wifi speeds with RNX-N150PCe

    I don't think the driver is your problem; I think this is:
    wlan0 IEEE 802.11bgn ESSID:"my very own network"
    Mode:Managed Frequency:2.437 GHz Access Point: 10:6F:3F:28:98:28
    Bit Rate=19.5 Mb/s Tx-Power=20 dBm
    Retry long limit:7 RTS thr:off Fragment thr:off
    Power Management:off
    Link Quality=25/70 Signal level=-85 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:30 Invalid misc:183 Missed beacon:0
    Do you feel that is accurate? How far are you from the router? Can you adjust how the router sits to try to get better signal strength?

    Please check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, I have better luck with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. After making these changes, reboot the router.

    Next, I recommend that your regulatory domain be set explicitly. Check yours:
    Code:
    sudo iw reg get
    If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:
    Code:
    sudo iw reg set IS
    Of course, substitute your country code if not Iceland. Set it permanently:
    Code:
    gksudo gedit /etc/default/crda
    Use nano or kate or vim if you don't have the text editor gedit.

    Change the last line to read:
    Code:
    REGDOMAIN=IS
    Proofread carefully, save and close gedit.

    Next, I'd set IPv6 to Ignore in Network Manager: http://docs.fedoraproject.org/en-US/...pv6-ignore.png This example is for ethernet, but you want wireless.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #3
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    6,566
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Very slow wifi speeds with RNX-N150PCe

    Additionally, you may want to disable the hardware encryption of the driver:

    Code:
    echo "options ath9k nohwcrypt=1" | sudo tee -a /etc/modprobe.d/ath9k.conf
    sudo modprobe -rfv ath9k
    sudo modprobe -v ath9k

  4. #4
    Join Date
    Jun 2014
    Beans
    5

    Re: Very slow wifi speeds with RNX-N150PCe

    I don't think I'm going to be able to try this tonight (school work), but I definitely will tomorrow. My wifi is NOT encrypted, so does disabling hardware encryption make a difference?
    Last edited by lezed1; June 11th, 2014 at 05:23 AM. Reason: forgot a word (that change meaning greatly)

  5. #5
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    6,566
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Very slow wifi speeds with RNX-N150PCe

    No, software encryption (WEP/WPA/WPA2) is not affected by this

  6. #6
    Join Date
    Jun 2014
    Beans
    5

    Re: Very slow wifi speeds with RNX-N150PCe

    I tried both suggestions, but my download speed is this less than half of what it is on Windows. My ping however is as good/better. Any other ideas?

  7. #7
    Join Date
    Jun 2014
    Beans
    5

    Re: Very slow wifi speeds with RNX-N150PCe

    Oops, I clicked reply twice.
    Last edited by lezed1; June 12th, 2014 at 05:18 PM. Reason: 'oops' has two 'o' 's.

  8. #8
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    6,566
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Very slow wifi speeds with RNX-N150PCe

    Try the Google-Public-Nameservers:
    Code:
    echo -e "nameserver 8.8.8.8\nnameserver 8.8.4.4" | sudo tee /etc/resolv.conf
    sudo service network-manager restart

  9. #9
    Join Date
    Jun 2014
    Beans
    5

    Re: Very slow wifi speeds with RNX-N150PCe

    I'm assuming that you didn't mean for the double n in "nnameserver"

    Edit: I now get that it's \n and nameserver.

  10. #10
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    6,566
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Very slow wifi speeds with RNX-N150PCe

    I did! "\n" means "new line"

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •