Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Menu bar visible in fullscreen wine programs

  1. #11
    Join Date
    Aug 2009
    Beans
    1,419

    Re: Menu bar visible in fullscreen wine programs

    Try the following.

    Install the Compiz-Config Settings Manager.

    Code:
    sudo apt-get install compizconfig-settings-manager
    Run it by typing CCSM in the Dash.

    In the section entitled "Workarounds" (in the "Utility" section) make sure that "Legacy Fullscreen Support" is checked. I can't guarantee it will work, but it can't hurt.
    If you are asking about a problem with your system, make sure to give details about your setup. OTHERWISE, NO ONE CAN HELP YOU.

  2. #12
    Join Date
    Oct 2012
    Beans
    3

    Re: Menu bar visible in fullscreen wine programs

    Well, this changed exactly nothing. At least in this particular case.

  3. #13
    Join Date
    Jul 2012
    Beans
    27

    Re: Menu bar visible in fullscreen wine programs

    Quote Originally Posted by MIC132 View Post
    Well, this changed exactly nothing. At least in this particular case.
    Did you recheck "allow the window manager to control the windows" in the wine settings?

  4. #14
    Join Date
    Oct 2012
    Beans
    3

    Re: Menu bar visible in fullscreen wine programs

    At first I didn't, but now that you said that I tried, and effects are interesting. The game isn't "active" at the beginning but after a few alt-tabs and a bit of clicking I somehow gained control. Now to figure this out..

    Edit:
    Checking "automatically capture mouse in fullscreen (...)" makes it so that after I start it I have to click once and it works!
    Last edited by MIC132; October 20th, 2012 at 09:20 AM.

  5. #15
    Join Date
    Sep 2007
    Location
    UK
    Beans
    109
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Menu bar visible in fullscreen wine programs

    I had this issue before upgrading to 12.10. Enabling the compiz legacy fullscreen support and/or disabling the WINE config setting to Allow The Window Manager To Control The windows fixed it. However, after the update (once I got everything working) it no longer seems to fix it. The strange thing is, if I run winecfg it loads the screen (I was emulating a full desktop) over the top of the Unity launcher and top bar fine, but when I load the program (WoW) it gets displaced down and to the left. Uninstalling WINE 1.5 and isntalling WINE 1.4 fixed this - for anyone else getting this problem.

  6. #16
    Join Date
    Dec 2012
    Beans
    2

    Re: Menu bar visible in fullscreen wine programs [WORKS]

    Quote Originally Posted by monkeyking009 View Post
    Go into wine configuration (winecfg) and disable "allow the window manager to control the windows" under the graphics tab. This should remove the unity launcher and panel in full screen mode.
    Thanks man, that is the solution.

  7. #17
    Join Date
    May 2013
    Beans
    1

    Re: Menu bar visible in fullscreen wine programs

    If some applications work better with the "allow the window manager to control the windows" (winecfg) box ticked, but others work better with it unticked, you could just change the application specific settings. That way, you can configure which applications have which winecfg settings. I found this link helpful: https://help.ubuntu.com/community/Wine#Changing_application_specific_settings

    It reads:
    Changing application specific settings

    Type this command into your terminal: winecfg
    1. Click on Add Application...
    2. Navigate to where the .exe is and choose that program
    3. The dropdown at the bottom allows you to choose which version of Windows Wine should emulate. Also, any changes to the Libraries and Graphics tabs will only affect the chosen application in the Applications tab.


    Hope this helps.

  8. #18
    Join Date
    Feb 2011
    Beans
    22

    Re: Menu bar visible in fullscreen wine programs

    Quote Originally Posted by monkeyking009 View Post
    Go into wine configuration (winecfg) and disable "allow the window manager to control the windows" under the graphics tab. This should remove the unity launcher and panel in full screen mode.
    Thank you very much. I've been using OpenBox all this time to play games, but your way is much easier.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •