Results 1 to 4 of 4

Thread: Samsung Galaxy Nexus Mounting Problems 12.04 64bit

  1. #1
    Join Date
    Apr 2012

    Samsung Galaxy Nexus Mounting Problems 12.04 64bit

    I am running 12.04 64bit and no matter what I do or what method I try things lock up when I try to mount my Galaxy Nexus filesystem.

    When issuing a mount any attemp at say 'ls' of a directory the mount is in will freeze the 'ls'.

    ie: ls /media/GalaxyNexus

    just freezes.

    Its not until I UNPLUG the phone that it unfreezes and thinks its mounted.

    11.10 worked fine. Any ideas?

  2. #2
    Join Date
    Jan 2005

    Re: Samsung Galaxy Nexus Mounting Problems 12.04 64bit

    Yes. This is a problem with the 64-bit mtpfs package having a bug. The version of the package available in the repos has this bug.

    I downloaded the source code from the maintainer's website, compiled and installed it. After that, I'm able to access my filesystem again. I did need to install the following in order for ./configure to work:

    libid3-tools (I don't believe this was a requirement, but I made sure it was installed anyway)

    Of course, I already had build-essential installed. If you don't have that installed, you'll need to apt-get install that as well.

    Once those dependencies were installed, I did a make && sudo make install, and re-plugged my Nexus back into my box. *bamf!* everything worked again. =)

    Hope this helps!

    Last edited by xyverz; September 2nd, 2012 at 12:24 AM.

  3. #3
    Join Date
    Aug 2006
    Perth Western Australia

    Re: Samsung Galaxy Nexus Mounting Problems 12.04 64bit

    I haven't had much luck with mtpfs at all. I followed your hint xyverz and compiled and installed mtpfs from however I still couldn't cd or ls any files on my galaxy nexus.

    So I had a look around and found go-mtpfs
    I downloaded the latest 64bit precompiled binary from and it has been working great.
    To install on my box I did the following in a terminal:
    sudo mv go-mtpfs.eb0de182.x86_64 /usr/bin/go-mtpfs
    sudo chown root.root /usr/bin/go-mtpfs
    sudo chmod 755 /usr/bin/go-mtpfs
    sudo mkdir -p /media/nexus
    sudo chmod 777 /media/nexus
    echo "alias mount-nexus='go-mtpfs /media/nexus &'">> ~/.bashrc
    echo "alias umount-nexus='fusermount -u /media/nexus'">> ~/.bashrc
    Then once that is done to mount your nexus just type in a terminal:
    and to umount type:
    You will then be able to see all of your files under /media/nexus

    I also had some issues with the nexus automounting however I disabled this by intalling dconf-tools and following this:

    BTW I'm running Linux Mint 13 Cinnamon Edition x64.

    Hope that helps!

  4. #4
    Join Date
    Oct 2011
    ZZ9 Plural Z Alpha

    Re: Samsung Galaxy Nexus Mounting Problems 12.04 64bit

    I'm having trouble with maloo's method above- all goes great but it won't mount, and gives me the following error in the terminal (a minute or so after running "mount-phone")-

    cortman@gwaihir:~$ PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
    LIBMTP libusb: Attempt to reset device
    LIBMTP PANIC: failed to open session on second attempt
    2012/10/10 12:25:01 open: open returned nil
    Anyone have any ideas?
    Last edited by cortman; October 10th, 2012 at 06:35 PM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts