Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Stuttering sound since upgrade to Lubuntu 12.04

  1. #1
    Join Date
    May 2012
    Beans
    4

    Exclamation Stuttering sound since upgrade to Lubuntu 12.04

    Hello,

    I've been using Lubuntu 11.10 on a Dell Latitude D520 and have experienced no special sound problems.

    However, since upgrading to 12.04, after several minutes of using the computer the sound becomes stuttered. I'm mostly listening to YouTube and Pandora via Google Chrome though it affects also playing on Audacious.

    Restarting the browser does not solve it, only restarting the computer.

    Has anyone encountered a similar problem?
    Are there any suggestions how this might be solved?

    Thanks in advanced.

  2. #2
    Join Date
    Jul 2011
    Location
    The Great Ocean
    Beans
    Hidden!
    Distro
    Lubuntu

    Re: Stuttering sound since upgrade to Lubuntu 12.04

    try the livecd, see if it stutters in that case

  3. #3
    Join Date
    Oct 2007
    Location
    Chennai, India
    Beans
    3,804
    Distro
    Ubuntu Development Release

    Re: Stuttering sound since upgrade to Lubuntu 12.04

    Quote Originally Posted by Zogzog View Post
    Restarting the browser does not solve it, only restarting the computer.

    As a first step for troubleshooting, see if just restarting Pulseaudio fixes it, rather than restarting the entire computer.

    To restart pulse, from a Terminal ("Dash Home"->"Terminal"), use the command
    Code:
    sudo service pulseaudio restart
    #or, if no sudo access#
    pulseaudio --kill && pulseaudio --start
    If restarting pulseaudio fixes the sound, please post your pulse config files from /etc/pulse/ for further troubleshooting.
    Cheers,PRShah
    Make your own: Ubuntu, Kubuntu, Xubuntu, Mythbuntu All-in-One Live DVD
    "I never make mistakes; I thought I did, once.. but I was wrong."

  4. #4
    Join Date
    Jan 2007
    Location
    North Carolina, USA
    Beans
    540
    Distro
    Ubuntu

    Re: Stuttering sound since upgrade to Lubuntu 12.04

    You're lucky it ever worked. The audio has been defective for me since they implemented pulseaudio 3 years ago or so.

  5. #5
    Join Date
    May 2012
    Beans
    4

    Re: Stuttering sound since upgrade to Lubuntu 12.04

    Thank you very much.
    Restarting the pulse service seems to have worked.
    Posting my pulse config files for further troubleshooting. Please let me know if more information is needed.

    client.conf:

    ; default-sink =
    ; default-source =
    ; default-server =
    ; default-dbus-server =

    ; autospawn = yes
    ; daemon-binary = /usr/bin/pulseaudio
    ; extra-arguments = --log-target=syslog

    ; cookie-file =

    ; enable-shm = yes
    ; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB

    ; auto-connect-localhost = no
    ; auto-connect-display = no

    daemon.conf:


    ; daemonize = no
    ; fail = yes
    ; allow-module-loading = yes
    ; allow-exit = yes
    ; use-pid-file = yes
    ; system-instance = no
    ; local-server-type = user
    ; enable-shm = yes
    ; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB
    ; lock-memory = no
    ; cpu-limit = no

    ; high-priority = yes
    ; nice-level = -11

    ; realtime-scheduling = yes
    ; realtime-priority = 5

    ; exit-idle-time = 20
    ; scache-idle-time = 20

    ; dl-search-path = (depends on architecture)

    ; load-default-script-file = yes
    ; default-script-file = /etc/pulse/default.pa

    ; log-target = auto
    ; log-level = notice
    ; log-meta = no
    ; log-time = no
    ; log-backtrace = 0

    resample-method = speex-float-1
    ; enable-remixing = yes
    ; enable-lfe-remixing = no

    flat-volumes = no

    ; rlimit-fsize = -1
    ; rlimit-data = -1
    ; rlimit-stack = -1
    ; rlimit-core = -1
    ; rlimit-as = -1
    ; rlimit-rss = -1
    ; rlimit-nproc = -1
    ; rlimit-nofile = 256
    ; rlimit-memlock = -1
    ; rlimit-locks = -1
    ; rlimit-sigpending = -1
    ; rlimit-msgqueue = -1
    ; rlimit-nice = 31
    ; rlimit-rtprio = 9
    ; rlimit-rttime = 1000000

    ; default-sample-format = s16le
    ; default-sample-rate = 44100
    ; default-sample-channels = 2
    ; default-channel-map = front-left,front-right

    default-fragments = 8
    default-fragment-size-msec = 10

    ; enable-deferred-volume = yes
    deferred-volume-safety-margin-usec = 1
    ; deferred-volume-extra-delay-usec = 0

  6. #6
    Join Date
    Oct 2007
    Location
    Chennai, India
    Beans
    3,804
    Distro
    Ubuntu Development Release

    Re: Stuttering sound since upgrade to Lubuntu 12.04

    Quote Originally Posted by Zogzog View Post
    Restarting the pulse service seems to have worked.
    Your pulse config files seem to be untouched defaults, so no issues there, I think. (unless you can recall some changes you had made earlier to these files, which the upgrade overwrote/replaced).

    Please also post your /etc/pulse/*.pa files (default.pa, system.pa)
    Cheers,PRShah
    Make your own: Ubuntu, Kubuntu, Xubuntu, Mythbuntu All-in-One Live DVD
    "I never make mistakes; I thought I did, once.. but I was wrong."

  7. #7
    Join Date
    May 2012
    Beans
    4

    Re: Stuttering sound since upgrade to Lubuntu 12.04

    You are right PRShah, I did not make any changes to these files (at least not that I know of).
    Posting my .pa files

    default.pa:

    .nofail

    ### Load something into the sample cache
    #load-sample-lazy x11-bell /usr/share/sounds/gtk-events/activate.wav
    #load-sample-lazy pulse-hotplug /usr/share/sounds/startup3.wav
    #load-sample-lazy pulse-coldplug /usr/share/sounds/startup3.wav
    #load-sample-lazy pulse-access /usr/share/sounds/generic.wav

    .fail

    ### Automatically restore the volume of streams and devices
    load-module module-device-restore
    load-module module-stream-restore
    load-module module-card-restore

    ### Automatically augment property information from .desktop files
    ### stored in /usr/share/application
    load-module module-augment-properties

    ### Load audio drivers statically
    ### (it's probably better to not load these drivers manually, but instead
    ### use module-udev-detect -- see below -- for doing this automatically)
    #load-module module-alsa-sink
    #load-module module-alsa-source device=hw:1,0
    #load-module module-oss device="/dev/dsp" sink_name=output source_name=input
    #load-module module-oss-mmap device="/dev/dsp" sink_name=output source_name=input
    #load-module module-null-sink
    #load-module module-pipe-sink

    ### Automatically load driver modules depending on the hardware available
    .ifexists module-udev-detect.so
    load-module module-udev-detect
    .else
    ### Use the static hardware detection module (for systems that lack udev/hal support)
    load-module module-detect
    .endif

    ### Automatically connect sink and source if JACK server is present
    .ifexists module-jackdbus-detect.so
    .nofail
    load-module module-jackdbus-detect
    .fail
    .endif

    ### Automatically load driver modules for Bluetooth hardware
    .ifexists module-bluetooth-discover.so
    load-module module-bluetooth-discover
    .endif

    ### Load several protocols
    .ifexists module-esound-protocol-unix.so
    load-module module-esound-protocol-unix
    .endif
    load-module module-native-protocol-unix

    ### Network access (may be configured with paprefs, so leave this commented
    ### here if you plan to use paprefs)
    #load-module module-esound-protocol-tcp
    #load-module module-native-protocol-tcp
    #load-module module-zeroconf-publish

    ### Load the RTP receiver module (also configured via paprefs, see above)
    #load-module module-rtp-recv

    ### Load the RTP sender module (also configured via paprefs, see above)
    #load-module module-null-sink sink_name=rtp format=s16be channels=2 rate=44100 sink_properties="device.description='RTP Multicast Sink'"
    #load-module module-rtp-send source=rtp.monitor

    ### Load additional modules from GConf settings. This can be configured with the paprefs tool.
    ### Please keep in mind that the modules configured by paprefs might conflict with manually
    ### loaded modules.
    .ifexists module-gconf.so
    .nofail
    load-module module-gconf
    .fail
    .endif

    ### Automatically restore the default sink/source when changed by the user
    ### during runtime
    ### NOTE: This should be loaded as early as possible so that subsequent modules
    ### that look up the default sink/source get the right value
    load-module module-default-device-restore

    ### Automatically move streams to the default sink if the sink they are
    ### connected to dies, similar for sources
    load-module module-rescue-streams

    ### Make sure we always have a sink around, even if it is a null sink.
    load-module module-always-sink

    ### Honour intended role device property
    load-module module-intended-roles

    ### Automatically suspend sinks/sources that become idle for too long
    load-module module-suspend-on-idle

    ### If autoexit on idle is enabled we want to make sure we only quit
    ### when no local session needs us anymore.
    .ifexists module-console-kit.so
    load-module module-console-kit
    .endif

    ### Enable positioned event sounds
    load-module module-position-event-sounds

    ### Cork music streams when a phone stream is active
    #load-module module-cork-music-on-phone

    ### Modules to allow autoloading of filters (such as echo cancellation)
    ### on demand. module-filter-heuristics tries to determine what filters
    ### make sense, and module-filter-apply does the heavy-lifting of
    ### loading modules and rerouting streams.
    load-module module-filter-heuristics
    load-module module-filter-apply

    ### Load DBus protocol
    #.ifexists module-dbus-protocol.so
    #load-module module-dbus-protocol
    #.endif

    # X11 modules should not be started from default.pa so that one daemon
    # can be shared by multiple sessions.

    ### Load X11 bell module
    #load-module module-x11-bell sample=bell-windowing-system

    ### Register ourselves in the X11 session manager
    #load-module module-x11-xsmp

    ### Publish connection data in the X11 root window
    #.ifexists module-x11-publish.so
    #.nofail
    #load-module module-x11-publish
    #.fail
    #.endif

    load-module module-switch-on-port-available

    ### Make some devices default
    #set-default-sink output
    #set-default-source input

    system.pa:

    #!/usr/bin/pulseaudio -nF
    #
    # This file is part of PulseAudio.
    #
    # PulseAudio is free software; you can redistribute it and/or modify it
    # under the terms of the GNU Lesser General Public License as published by
    # the Free Software Foundation; either version 2 of the License, or
    # (at your option) any later version.
    #
    # PulseAudio is distributed in the hope that it will be useful, but
    # WITHOUT ANY WARRANTY; without even the implied warranty of
    # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
    # General Public License for more details.
    #
    # You should have received a copy of the GNU Lesser General Public License
    # along with PulseAudio; if not, write to the Free Software Foundation,
    # Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.

    # This startup script is used only if PulseAudio is started in system
    # mode.

    ### Automatically load driver modules depending on the hardware available
    .ifexists module-udev-detect.so
    load-module module-udev-detect
    .else
    ### Use the static hardware detection module (for systems that lack udev/hal support)
    load-module module-detect
    .endif

    ### Load several protocols
    .ifexists module-esound-protocol-unix.so
    load-module module-esound-protocol-unix
    .endif
    load-module module-native-protocol-unix

    ### Automatically restore the volume of streams and devices
    load-module module-stream-restore
    load-module module-device-restore

    ### Automatically restore the default sink/source when changed by the user
    ### during runtime
    ### NOTE: This should be loaded as early as possible so that subsequent modules
    ### that look up the default sink/source get the right value
    load-module module-default-device-restore

    .ifexists module-dbus-protocol.so
    ### If you want to allow TCP connections, set access to "remote" or "local,remote".
    load-module module-dbus-protocol access=local
    .endif

    ### Automatically move streams to the default sink if the sink they are
    ### connected to dies, similar for sources
    load-module module-rescue-streams

    ### Make sure we always have a sink around, even if it is a null sink.
    load-module module-always-sink

    ### Automatically suspend sinks/sources that become idle for too long
    load-module module-suspend-on-idle

    ### Enable positioned event sounds
    load-module module-position-event-sounds

  8. #8
    Join Date
    Apr 2006
    Beans
    16

    Re: Stuttering sound since upgrade to Lubuntu 12.04

    I've been struggling with an issue like this in Ubuntu 12.04. I didn't have the problem from the very beginning, so I had to assume it was either recent software upgrade or something I did.

    I think it was something I did: I have wired and wireless networking, and I've played with wireless just for testing purposes. It would appear I left it enabled. Disabling Wireless on my HP laptop stopped the sound stuttering.

    My problem seemed to be gstreamer related - smplayer worked fine with wireless enabled, but rhythmbox and clementine didn't.

    Anyway, I just thought I would share my experience.

    You might want to try the suggestions at https://wiki.archlinux.org/index.php...s_or_crackling if wireless is not the problem in your case.

  9. #9
    Join Date
    Oct 2007
    Location
    Chennai, India
    Beans
    3,804
    Distro
    Ubuntu Development Release

    Re: Stuttering sound since upgrade to Lubuntu 12.04

    Quote Originally Posted by Zogzog View Post
    Posting my .pa files
    Well, your .pa files are also unchanged.

    there may be something in the local config (~/.pulse) that is causing the issue. To check, you can do the following:
    Code:
    mv ~/.pulse ~/dotpulse
    sudo service pulseaudio restart
    This will create a fresh local config. Please check if the issue persists. If sound totally stops working, you can restore the original config with
    Code:
    rm -rf ~/.pulse
    mv ~/dotpulse ~/.pulse
    sudo service pulseaudio restart
    If you still get stuttering with a fresh local config, please check for error indications in the debug log
    Code:
    dmesg|grep -E -i pulse\|snd
    Please post back with your results.
    Cheers,PRShah
    Make your own: Ubuntu, Kubuntu, Xubuntu, Mythbuntu All-in-One Live DVD
    "I never make mistakes; I thought I did, once.. but I was wrong."

  10. #10
    Join Date
    May 2012
    Beans
    1

    Re: Stuttering sound since upgrade to Lubuntu 12.04

    I have had this same problem, after reading this forum post I did some quick troubleshooting on my own and found a solution that seems persistent.


    in client.conf:

    ; extra-arguments = --log-target=syslog --resample-method=ffmpeg

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •