Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Unusable system after 12.04 upgrade: no mouse, broken window manager(?)

  1. #1
    Join Date
    May 2007
    Beans
    14

    Angry Unusable system after 12.04 upgrade: no mouse, broken window manager(?)

    I upgraded to 12.04 overnight last night, and apart from it prompting me to let it restart services, it went fine and prompted me to restart. Upon restart, it boots to the login screen but...

    - Low resolution (640x480?)
    - Various icons are red error-y Xs
    - The mouse cursor doesn't respond

    I can type my password and log in, but...

    - Still low resolution
    - The dock on the left is there but the buttons are blank
    - The mouse still doesn't work
    - I can get the "start menu" or whatever it's called to pop up by keyboard, and use it to launch Terminal, but it doesn't respond to keystrokes and has no window chrome.

    Same results in the rescue mode. I hadn't made any huge changes to the 11.10 installation as far as I know, and it ran fine on my laptop (a Latitude D620). Help!

  2. #2
    Join Date
    Nov 2004
    Location
    Maine
    Beans
    2,364
    Distro
    Ubuntu

    Re: Unusable system after 12.04 upgrade: no mouse, broken window manager(?)

    What video card are you using?
    Wireless script
    Dave
    Registered Linux User #462608
    Morse Code an early Digital Mode.

  3. #3
    Join Date
    Dec 2006
    Location
    N. Virginia, USA
    Beans
    505
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Unusable system after 12.04 upgrade: no mouse, broken window manager(?)

    See this thread for the probable solution if you have an nVidia GeForce 6, 7, or 8800 card.
    Linux User #448337
    Gigabyte EP45-UD3L MB, Q9650 Core 2 Quad @ 3.3 GHz (OC), 8 GB OCZ Platinum DDR2 SDRAM, EVGA GeForce 8800 GTS w/640MB, 40 GB Intel SSD, 2.0 TB x2 SATA RAID1, Ubuntu 17.04 x86_64

  4. #4
    Join Date
    May 2007
    Beans
    14

    Re: Unusable system after 12.04 upgrade: no mouse, broken window manager(?)

    Oh, no idea. It's whatever integrated thing the D620 has. Er, Intel something or other.

    The specs say it's either a GMA 950 or a Quadro NVS 110M. I'm almost positive it's the GMA but I don't know.

    Edit: XP says "945GM Express Chipset Family."
    Last edited by BungaDunga; May 2nd, 2012 at 10:20 PM.

  5. #5
    Join Date
    Dec 2006
    Location
    N. Virginia, USA
    Beans
    505
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Unusable system after 12.04 upgrade: no mouse, broken window manager(?)

    Can you successfully run Ubuntu 2D mode at login?
    Linux User #448337
    Gigabyte EP45-UD3L MB, Q9650 Core 2 Quad @ 3.3 GHz (OC), 8 GB OCZ Platinum DDR2 SDRAM, EVGA GeForce 8800 GTS w/640MB, 40 GB Intel SSD, 2.0 TB x2 SATA RAID1, Ubuntu 17.04 x86_64

  6. #6
    Join Date
    May 2007
    Beans
    14

    Re: Unusable system after 12.04 upgrade: no mouse, broken window manager(?)

    This is a good question. I don't know if I can pick it without a mouse cursor; I'll give it a try.

  7. #7
    Join Date
    Nov 2004
    Location
    Maine
    Beans
    2,364
    Distro
    Ubuntu

    Re: Unusable system after 12.04 upgrade: no mouse, broken window manager(?)

    Quote Originally Posted by BungaDunga View Post
    This is a good question. I don't know if I can pick it without a mouse cursor; I'll give it a try.
    if it's the intel gma 950 try what this page suggests:

    http://www.jacoblog.net/2011/10/29/u...river-problem/
    Wireless script
    Dave
    Registered Linux User #462608
    Morse Code an early Digital Mode.

  8. #8
    Join Date
    May 2007
    Beans
    14

    Re: Unusable system after 12.04 upgrade: no mouse, broken window manager(?)

    Quote Originally Posted by kc1di View Post
    if it's the intel gma 950 try what this page suggests:

    http://www.jacoblog.net/2011/10/29/u...river-problem/
    No luck putting that thing in by hand in GRUB (haven't tried editing the file).

    2D mode behaves more or less the same.

    I tried booting an old kernel from grub and the mouse worked but the keyboard didn't, at least not past the login screen. I coaxed it into starting Firefox, but it had no window chrome.

  9. #9
    Join Date
    May 2012
    Beans
    2

    Unhappy Re: Unusable system after 12.04 upgrade: no mouse, broken window manager(?)

    Hi, I am seeing the same thing after upgrading from Oneiric to Precise. I thought it might be because of This Bug. I have an ATI video card and was running the proprietary drivers.

    I am able to log in and use super key to pull up search. No icons show up on unity. Search will open any program, but nothing works. Can't type in the terminal, I can't select anything with the keyboard. The mouse doesn't work. Alt+F2 will bring up the run dialog, but enter a program name and nothing happens. Ctrl+Alt+F1, etc produces a blank screen.
    Same as OP describes, except my screen resolution is still normal.
    Hoping someone can make sense of it. Thanks for any help.
    Last edited by wolfseyn; May 5th, 2012 at 03:42 AM. Reason: 'cause I wanted to add more.

  10. #10
    Join Date
    Oct 2007
    Beans
    12

    Angry Re: Unusable system after 12.04 upgrade: no mouse, broken window manager(?)

    I am experiencing the same issue after upgrading from 11.10 to 12.04 on my Dell Inspiron Netbook.

    *I am also able to log in and use super key to pull up search. No icons show up on unity.

    *Also search will open any program, but nothing works. Can't type in the terminal and I can't select anything with the keyboard.

    *The mouse doesn't work.

    Windows just says the the video card is built in Mobile Intel 4 series.
    Ubuntu 11.10 worked awesome. ....I shouldn't have upgraded.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •