Results 1 to 7 of 7

Thread: Eclipse updates not working

  1. #1
    Join Date
    Jun 2009
    Beans
    37

    Eclipse updates not working

    I installed eclipse and I went to "Check for Updates." After I completed the wizard it was installing some updates but it failed:
    Code:
    An error occurred while uninstalling
    session context was:(profile=PlatformProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Uninstall, operand=[R]org.eclipse.platform_root 3.7.2.dist-9nF7UHagFqn9pElwWhC90gLz-soEuSGYmtSeiRH --> null, action=org.eclipse.equinox.internal.p2.touchpoint.natives.actions.CleanupzipAction).
    Backup of file /usr/lib/eclipse/.eclipseproduct failed.
    File that was copied to backup could not be deleted: /usr/lib/eclipse/.eclipseproduct
    So I go to try it as root. Now the update sites are different and it can't find any updates.
    Here are the sites running as root:
    Here are the sites running as a normal user:It seems there are two problems here, first that updating as a normal user doesn't work and second that the list of update sites enabled by default are different for the root user and a normal user. Eclipse says it is version 3.7.2.
    By the way, what is the difference between these update sites? Why isn't there just one for each version of Eclipse?

  2. #2
    Join Date
    Mar 2012
    Beans
    308

    Re: Eclipse updates not working

    Normal users can't modify the program files of Eclipse, thus updating the core components does not work, because they are owned by root. These updates should be managed by Ubuntu.

    If you run eclipse as normal user and install plugins via the Eclipse Marketplace or from a websites, they will get saved in your HOME folder (together with user-specific program settings including a separate update site list). These plugins can be easily updated by using the eclipse update routine.

    Alternative method:
    Download the tar.gz package from the Eclipse website and extract it in your HOME folder. This allows updating of all components without root privileges.

    Eclipse 3.6 = Helios
    Eclipse 3.7 = Indigo
    GNU/Linux

  3. #3
    Join Date
    Jun 2009
    Beans
    37

    Re: Eclipse updates not working

    That's fine and all but the problem remains. I, as a normal user, can't update eclipse because of that error I quoted and root has strange update sites. Thanks for the reply by the way.

  4. #4
    Join Date
    May 2012
    Beans
    1

    Talking Re: Eclipse updates not working

    So why doesn't eclipse running as root have any update repositories listed for Indigo, only Helios?

    Maybe the newer updates would fix the problem with the Help index

  5. #5
    Join Date
    Aug 2011
    Beans
    15
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Eclipse updates not working

    Hey I'm having these troubles too. I was developing for android and I wanted to debug on my phone (which I have done before with no problems) but the sdk was not recognizing it. I had it working on 11.10 but then updated to 12.04 and haven't had any success debugging from my phone, not sure if this was the source of the problem. I tried to get updates for eclipse and that's when I got the same error in the original post.

    Any thoughts?

    P.S. Has anyone been able to debug from their android phone on 12.04?

    Thanks

  6. #6
    Join Date
    Oct 2011
    Beans
    2

    Re: Eclipse updates not working

    I encountered the error while installing Google app engine. Having read this thread, I started eclipse as root user, and copied the same site address into the "work with" bar. It worked and now it is working fine even when run as a normal user.
    If the repositories are not listed while running as root just copy the address of update sites an paste it into "work with" bar while running as root.

  7. #7
    Join Date
    Oct 2012
    Beans
    1

    Smile Re: Eclipse updates not working

    I have the same problem, I add the nomal user mode update sites (http://download.eclipse.org/releases/indigo/
    and http://download.eclipse.org/releases...o/201202240900) in root mode
    site list, and update ok.
    Thank you!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •