Results 1 to 5 of 5

Thread: 12.04 Compiz non-functional on Screen-1

  1. #1
    Join Date
    Mar 2007
    Beans
    9

    12.04 Compiz non-functional on Screen-1

    Looking for a bit of help on a subject that is very similar to others' issues with dual or triple monitor setups using Gnome and Compiz.


    I have a 12.04 system, fresh installed, configured and working with *3* monitors, but only 2 screens. That is, card0 has Monitor0 and Monitor1 attached and is using TwinView (:0.0). (Windows span both monitors) Monitor2 is attached to card1 and is its own X Screen. (:0.1)

    When not running compiz, I see metacity managing windows on both screens properly. However, when I start compiz (or let Compiz auto-start via Gnome-session) the second screen loses all windows decorations and becomes un-manageable.

    Running compiz --display :0.1 --replace does not solve the problem either.


    Side note: This is not the nautilus bug as I've rebuilt nautilus from source with the patch to solve that bug. Also, the issue I describe above occurs when I run the Xfce4 session as well.


    One final note: I run Cairo-Dock on both screens. On Screen0 it starts normally and transparency is working properly. However, on Screen1 cairo-dock runs as if Compositing is not enabled. This would seem directly related to compiz working on this screen as compositing is a requirement.

    What data can I provide to get some help with this issue? Or, has someone already worked through this?

  2. #2
    Join Date
    Mar 2007
    Beans
    9

    Re: 12.04 Compiz non-functional on Screen-1

    Ill the following additional info in the event someone knows what the heck I can do to resolve this:


    dlight@dlight:/tmp$ /usr/lib/nux/unity_support_test -p
    OpenGL vendor string: NVIDIA Corporation
    OpenGL renderer string: GeForce 7600 GT/PCIe/SSE2
    OpenGL version string: 2.1.2 NVIDIA 295.40

    Not software rendered: yes
    Not blacklisted: yes
    GLX fbconfig: yes
    GLX texture from pixmap: yes
    GL npot or rect textures: yes
    GL vertex program: yes
    GL fragment program: yes
    GL vertex buffer object: yes
    GL framebuffer object: yes
    GL version is 1.4+: yes

    Unity 3D supported: yes

    dlight@dlight:/tmp$ /usr/lib/nux/unity_support_test -d :0.1 -p
    OpenGL vendor string: NVIDIA Corporation
    OpenGL renderer string: GeForce 9500 GT/PCIe/SSE2
    OpenGL version string: 3.3.0 NVIDIA 295.40

    Not software rendered: yes
    Not blacklisted: yes
    GLX fbconfig: yes
    GLX texture from pixmap: yes
    GL npot or rect textures: yes
    GL vertex program: yes
    GL fragment program: yes
    GL vertex buffer object: yes
    GL framebuffer object: yes
    GL version is 1.4+: yes

    Unity 3D supported: yes



    Xorg.conf:



    Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0" 1600 0
    Screen 1 "Screen1" LeftOf "Screen0"
    Option "Xinerama" "0"
    EndSection

    Section "Files"
    EndSection

    Section "ServerFlags"
    Option "Xinerama" "0"
    EndSection



    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "DELL 1908FP"
    HorizSync 30.0 - 81.0
    VertRefresh 56.0 - 76.0
    Option "DPMS"
    EndSection

    Section "Monitor"
    Identifier "Monitor1"
    VendorName "Unknown"
    ModelName "DELL 2007FP"
    HorizSync 30.0 - 83.0
    VertRefresh 56.0 - 76.0
    EndSection

    Section "Monitor"
    Identifier "Monitor2"
    VendorName "Unknown"
    ModelName "DELL 1908FP"
    HorizSync 30.0 - 81.0
    VertRefresh 56.0 - 76.0
    EndSection

    Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce 7600 GT"
    BusID "PCI:7:0:0"
    EndSection

    Section "Device"
    Identifier "Device1"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce 9500 GT"
    BusID "PCI:13:0:0"
    EndSection

    Section "Device"
    Identifier "Device2"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce 7600 GT"
    BusID "PCI:7:0:0"
    Screen 1
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "TwinView" "1"
    Option "TwinViewXineramaInfoOrder" "DFP-0"
    Option "metamodes" "DFP-0: 1280x1024 +0+0, DFP-1: nvidia-auto-select +1280+0"
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection

    Section "Screen"

    # Removed Option "metamodes" "DFP-1: 1280x1024 +0+0"
    Identifier "Screen1"
    Device "Device1"
    Monitor "Monitor1"
    DefaultDepth 24
    Option "TwinView" "0"
    Option "metamodes" "1600x1200 +0+0"
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection

    Section "Screen"
    Identifier "Screen2"
    Device "Device2"
    Monitor "Monitor2"
    DefaultDepth 24
    Option "TwinView" "1"
    Option "metamodes" "DFP-1: nvidia-auto-select +0+0"
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection

    Section "Extensions"
    Option "Composite" "Enable"
    EndSection

  3. #3
    Join Date
    Sep 2010
    Beans
    78

    Re: 12.04 Compiz non-functional on Screen-1

    Exactly same problem with xubuntu.

    I tried earlier, solution was to run compiz separately on both desktops. I think this is not a good solution, since now you have two compiz-programs running and taking resources?

    If I remember correctly following were the correct lines to use:
    On first display:
    Code:
    DISPLAY=:0.0 compiz --replace
    Second display:
    Code:
    DISPLAY=:0.1 compiz --replace
    I had to put both of these to one file that runs panels, etc at startup, (and some windows manager I think). Do not remember the file name, and location is different in Ubuntu and Xubuntu.

    Also the file was VERY hard to get to work. Many commands that had to be in right order, and I had to change the number of command in top of the file, or they did not get executed. It might had been a .xml-file, not sure.

    Other solution was to add "compiz --replace" to the startup programs, which started it on desktop 0.0, and set the command for second 0.1 monitor compiz to that "i Don't remember which"-file. Exactly same thing with cairo-dock.

    Annoying O_o

    Also in ubuntu my twin monitors won't even work (Nvidia EN8400GS), Xubuntu and Kubuntu --> no problem, works out of the box. That was the second biggest reason reason I changed away from ubuntu, unity was the first. Xubuntu seems to be a good replacement so far, very much like ubuntu 10.04, Kubuntu was weird O_o

    Most of the guides seems to work with other ubuntu-variants also.

    Now I am trying this method to autostart compiz (can not get it to autostart at all currently) --> http://ubuntuforums.org/showthread.p...ghlight=compiz

    But can not find the correct location for that script (That guide is for older ubuntu)

  4. #4
    Join Date
    Sep 2010
    Beans
    78

    Re: 12.04 Compiz non-functional on Screen-1

    Now it starts to both desktops, but it still starts to compiz-programs.

    There is option in compiz-settings-manager that you can put settings for screen 0 or screen 1, but it does not work. Now you start compiz-settings-manage on monitor you want to change settings.

    Remember there is no window borders, move, or change size of window activated, you have to do it manually first. So it might seem that there is no compiz running even when there is.

    I did this: (going to copy paste some from that link)

    Create the compiz_start.sh file in /usr/local/bin directory:

    Code:
    Code:
    gksudo gedit /usr/local/bin/compiz_start.sh
    Code should be (sleep 5 means it will pause for 5 seconds before executing that command):

    Code:
    Code:
    #!/bin/bash
        #
        # Start compiz-fusion with compiz --replace
        #
    
        sleep 5
        DISPLAY=:0.0 compiz --replace -c emerald &
        DISPLAY=:0.1 compiz --replace -c emerald &
    Save and close file.

    Change the file permission:

    Code:
    sudo chmod a+x /usr/local/bin/compiz_start.sh
    And add the compiz_start.sh script to startup: Navigate to System->Preferences->Session,
    Create new startup, and point the command to /usr/local/bin/compiz_start.sh

    Log out and back in, that should start both. IF there is some error try put "sleep 1" in between commands, so they will not be executed at the same time.

    I bet there MUST be some setting in compiz that will autostart it to all the monitors, there is no need to start two instances. At the mean time I do not know how. I will try to update here if I found out.

    Also, when I put on two instances of compiz I randomly get empty menus like these --> http://kuvaton.com/k/YUen.jpg

    Sorry for the "screenshot" but Xubuntu will not let me screenshot while menu is open.
    If I click again, it will be visible.

    I have absolutely NO idea what does "
    "-c emerald &" mean or do

  5. #5
    Join Date
    Sep 2010
    Beans
    78

    Re: 12.04 Compiz non-functional on Screen-1

    I can get rid of empty menus by enabling "animations" in compiz settings.

    But then the menus flicker.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •