Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: How do I disable auto maximizing windows

  1. #1
    Join Date
    Jul 2007
    Beans
    30

    How do I disable auto maximizing windows

    I just upgraded to Ubuntu 12.04 (w/ Gnome 3.4.1) and found a new "feature." If I move a window such that it touches the upper dash, the window automatically maximizes to full screen. This is a royal pain. How can I disable this "feature?" I looked at gconf-editor and did not see an option to disable this, but perhaps it has some obscure name such that I did not recognize it.

  2. #2
    Join Date
    Jun 2007
    Beans
    16,920

    Re: How do I disable auto maximizing windows

    Depends on what session you are running.
    In gnome-shell it appears to be both a mutter option, path in dconf-editor (install dconf-tools) -
    org.gnome.mutter edge-tiling
    And a shell option -
    org.gnome.shell.overrides edge-tiling

    So make sure it's disabled in both, should be in mutter by default so the shell option is the likely one
    Code:
    gsettings set org.gnome.shell.overrides edge-tiling false
    In unity 3d it's the grid compiz plugin, I always disable it. Probably easier to do in ccsm though you could also do in gconf-editor, prefer ccsm here (compizconfig-settings-manager

    Either way it will cause compiz to to 'reload' & things may freeze up for several seconds. If not returning then force a logout & all should be ok. (Ctrl+Alt+Delete or Ctrl+Alt+Print+k

    (- myself if doing in ccsm would 1st. disable the unity plugin , make the change, wait a few seconds if need be & then re-enable unity.
    Last edited by mc4man; May 2nd, 2012 at 03:32 PM.

  3. #3
    Join Date
    Jul 2007
    Beans
    30

    Re: How do I disable auto maximizing windows

    Thank you. Installed Compiz, deselected Grid - worked fine.

  4. #4
    Join Date
    Jun 2006
    Beans
    66

    Re: How do I disable auto maximizing windows

    thank you mc4man!!

    I'm running the rather unpopular gnome3 shell, I hate this edge tiling thing, and nothing worked, was driving me crazy.

    looks like the setting

    > org.gnome.shell.overrides edge-tiling

    overrides the mutter setting, so it should work regardless.

  5. #5
    Join Date
    Jul 2007
    Beans
    30

    Re: How do I disable auto maximizing windows

    While I am very appreciative of mc4man's quick and easy soluition to this annoyance, I am concerned that, before posting to this forum I attempted to solve the problem on my own. I found no reference to it on any help page or manual. This is dangerously close to operating with MS Windows. How are us mere mortals supposed to find out and address these kinds of issues?

    And Compiz was not much help either. I knew to deselect Grid from mc4man's directions, but without his input I would have no idea what Grid does or why it should be deselected.
    Last edited by gerryl; May 8th, 2012 at 07:09 PM.

  6. #6
    Join Date
    Jul 2011
    Beans
    7
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: How do I disable auto maximizing windows

    I agree with the above poster. Why do people love this new interface so much? There may be a way to use it properly but I haven't found it. For instance, I often forget if i'm supposed to type ccsm or something else. If there was a menu I could search through it, but with the current method I'm supposed to always search by typing keywords? I guess I'd be appreciative if anybody could point to a beginner's guide to working with Unity.

  7. #7
    Join Date
    Jun 2010
    Location
    Sussex
    Beans
    70
    Distro
    Kubuntu 13.10 Saucy Salamander

    Re: How do I disable auto maximizing windows

    To find applications, open the dash and there are some options on the right hand side or at the bottom (I forget which) that allow you to select different groups, such as games, office and so on.

  8. #8
    Join Date
    May 2010
    Location
    South Gloucestershire, UK
    Beans
    2,924
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: How do I disable auto maximizing windows

    Quote Originally Posted by spikn View Post
    If there was a menu I could search through it, but with the current method I'm supposed to always search by typing keywords? I guess I'd be appreciative if anybody could point to a beginner's guide to working with Unity.
    The official guide for 12.04 can be found at https://help.ubuntu.com/12.04/ubuntu-help/index.html, for other releases see https://help.ubuntu.com/.

  9. #9
    Join Date
    Jun 2006
    Location
    Brisbane Australia
    Beans
    713

    Re: How do I disable auto maximizing windows

    Quote Originally Posted by gerryl View Post
    I just upgraded to Ubuntu 12.04 (w/ Gnome 3.4.1) and found a new "feature." If I move a window such that it touches the upper dash, the window automatically maximizes to full screen.
    It's not a "new" feature. Has been in Ubuntu since 11.04, i.e. this is the third release with it. Like all this stuff, it is a good idea once you get used to it.

  10. #10
    Join Date
    Dec 2008
    Beans
    17

    Re: How do I disable auto maximizing windows

    In 12.04 there is another new automaximize feature in gnome shell which always starts a application maximized if the window was larger than a certain value on close, does anyone know how to disable this?

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •