Results 1 to 6 of 6

Thread: Evolution won't restore from backup

  1. #1
    Join Date
    Jan 2012
    Beans
    248

    Evolution won't restore from backup

    Hi all

    I have upgraded from 11.10 to 12.04 and have installed evolution [3.2.3], as I had in 11.10.
    I backed up my mail to a tar.gz file before I upgraded. Now I have upgraded and installed evolution, I went to restore Evolution data, but it won't restore as it says it is an invalid backup file???
    I tested the archive:
    Code:
    glenn@acer:~/Evolution Backup$ gunzip -t evolution-backup.tar.gz
    glenn@acer:~/Evolution Backup$ 
    
    and tested the file inside with:
    
    glenn@acer:~/gunzip -c evolution-backup.tar.gz | tar tf evolution-backup.tar.gz
    and it came back with no errors?

    What can I do about this? anything?

  2. #2
    Join Date
    Jan 2012
    Beans
    248

    Re: Evolution won't restore from backup

    Anyone at all..?

  3. #3
    Join Date
    Jan 2012
    Beans
    248

    Re: Evolution won't restore from backup

    Bump

  4. #4
    Join Date
    Feb 2010
    Beans
    446
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Evolution won't restore from backup

    Hi there.

    I think you may be able to restore from your tar.gz by extracting it & copying the relevant files (inbox & the like) over by hand, if you see what I mean.

    I had a similar issue a while back & if I recall correctly that's how I worked around it. (I went back to 10.10 from 11.04 for a time & it was the 11.04 backup that wouldn't restore into 10.10)

    I've since migrated to Thunderbird
    Last edited by verymadpip; April 30th, 2012 at 03:58 PM. Reason: addition

  5. #5
    Join Date
    Jul 2007
    Location
    UK
    Beans
    17,056
    Distro
    Ubuntu Development Release

    Re: Evolution won't restore from backup

    Quote Originally Posted by Senior_Buckethead View Post
    Hi all

    I have upgraded from 11.10 to 12.04 and have installed evolution [3.2.3], as I had in 11.10.
    I backed up my mail to a tar.gz file before I upgraded. Now I have upgraded and installed evolution, I went to restore Evolution data, but it won't restore as it says it is an invalid backup file???
    I tested the archive:
    Code:
    glenn@acer:~/Evolution Backup$ gunzip -t evolution-backup.tar.gz
    glenn@acer:~/Evolution Backup$ 
    
    and tested the file inside with:
    
    glenn@acer:~/gunzip -c evolution-backup.tar.gz | tar tf evolution-backup.tar.gz
    and it came back with no errors?

    What can I do about this? anything?
    I know this may sound weird but try copying the tar to your Desktop. Then try the restore.

  6. #6
    Join Date
    Jan 2012
    Beans
    248

    Re: Evolution won't restore from backup

    Thanks Philinux,

    did as you suggested, Evolution still spitting the dummy saying the evolution-backup.tar.gz file is invalid.
    I found an old backup I made a month ago and stored on my Seagate External. It backed up no problems, just loose a month of mail.
    Can't fathom that, an older backup, made by the same program, works, when a new backup, ditto the same, doesn't.

    Its almost a problem you'd find with windows.

    Glenn.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •