Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 34

Thread: 12.04 running DNSMASQ by default

  1. #21
    Join Date
    Dec 2005
    Location
    N.C.
    Beans
    4,796
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 12.04 running DNSMASQ by default

    I was wondering about DNSMASQ being enabled by default with dd-wrt on my WRT310N v2 router. I mainly installed dd-wrt due to the WPS vulnerability of the linksys firmware, which the linksys site says any firmware upgrade to correct the vulnerability is TBD for my router.
    I realise this would probably best be posted in the dd-wrt forum, but my question is would it present any problems to set DNSMASQ to "disable"?

  2. #22
    Join Date
    Oct 2009
    Beans
    Hidden!
    Distro
    Ubuntu 22.04 Jammy Jellyfish

    Re: 12.04 running DNSMASQ by default

    Quote Originally Posted by confused57 View Post
    I was wondering about DNSMASQ being enabled by default with dd-wrt on my WRT310N v2 router. I mainly installed dd-wrt due to the WPS vulnerability of the linksys firmware, which the linksys site says any firmware upgrade to correct the vulnerability is TBD for my router.
    I realise this would probably best be posted in the dd-wrt forum, but my question is would it present any problems to set DNSMASQ to "disable"?
    If you are using dnsmasq on your router, it has nothing to do with dnsmasq being run on the client (pc).

    On DD-WRT routers dnsmasq is used for dhcp and local dns resolution and shouldn't be disabled.
    Come to #ubuntuforums! We have cookies! | Basic Ubuntu Security Guide

    Tomorrow's an illusion and yesterday's a dream, today is a solution...

  3. #23
    Join Date
    Dec 2005
    Location
    N.C.
    Beans
    4,796
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 12.04 running DNSMASQ by default

    Quote Originally Posted by CharlesA View Post
    If you are using dnsmasq on your router, it has nothing to do with dnsmasq being run on the client (pc).

    On DD-WRT routers dnsmasq is used for dhcp and local dns resolution and shouldn't be disabled.
    Thanks, I'll leave it enabled. I've read that dnsmasq is responsible for dd-wrt assigning random ip numbers, instead of sequentially as the linksys firmware does. I believe I can assign a static ip address, using its mac, to the Ubuntu computer with the printer attached that I use over my local network. I was mainly concerned with any security issues, thanks again.

  4. #24
    Join Date
    Dec 2010
    Beans
    7

    Re: 12.04 running DNSMASQ by default

    This setup seems to conflict with rdnssd. Maybe RDNSS/DNSSL (RFC6106) should also be implemented in NetworkManager, so we no longer need rdnssd?

    It would also be nice if dnsmasq would become a DNSSEC validator, than we can do DANE.

    BTW; dnsmasq has a little bug. It doesn't quite understand the OPT record. I described it here:

    http://www.sidnlabs.nl/laatste-beric...thuis-routers/
    (but that is in Dutch)

    To go short: dnsmasq is counting down the TTL and erroneously also does that in the OPT record, thus overwriting the Z-field, turning the MBZ (must-be-zero) value of 'dig' into something other than... zero.


    --
    Marco
    Last edited by mdavids; May 14th, 2012 at 10:22 PM.

  5. #25
    Join Date
    Aug 2009
    Beans
    112

    Re: 12.04 running DNSMASQ by default

    Great!
    dnsmasq has kept me from using 12.04 as clients on my ldap network. Strange results with dnsmasq. Like bad dns response, then if you ping by address the same dns request, the following dns resolution is correct.... silly.

  6. #26
    Join Date
    Oct 2009
    Beans
    Hidden!
    Distro
    Ubuntu 22.04 Jammy Jellyfish

    Re: 12.04 running DNSMASQ by default

    Quote Originally Posted by lisanels47 View Post
    Great!
    dnsmasq has kept me from using 12.04 as clients on my ldap network. Strange results with dnsmasq. Like bad dns response, then if you ping by address the same dns request, the following dns resolution is correct.... silly.
    At least you can disable it.
    Come to #ubuntuforums! We have cookies! | Basic Ubuntu Security Guide

    Tomorrow's an illusion and yesterday's a dream, today is a solution...

  7. #27
    Join Date
    Aug 2009
    Beans
    112

    Re: 12.04 running DNSMASQ by default

    Personally, I just don't need dnsmasq running. So by commenting out the line mentioned AND removing the package resolvconf, things work fine. Now I can once again do a 'cat /etc/resolv.conf' and verify my dhcp settings.

  8. #28
    Join Date
    Oct 2009
    Beans
    Hidden!
    Distro
    Ubuntu 22.04 Jammy Jellyfish

    Re: 12.04 running DNSMASQ by default

    Quote Originally Posted by lisanels47 View Post
    Personally, I just don't need dnsmasq running. So by commenting out the line mentioned AND removing the package resolvconf, things work fine. Now I can once again do a 'cat /etc/resolv.conf' and verify my dhcp settings.
    You don't even need to remove the resolvconf package - commenting out dns=dnsmasq is sufficient.
    Come to #ubuntuforums! We have cookies! | Basic Ubuntu Security Guide

    Tomorrow's an illusion and yesterday's a dream, today is a solution...

  9. #29
    Join Date
    Mar 2012
    Beans
    6

    Re: 12.04 running DNSMASQ by default

    Quote Originally Posted by CharlesA View Post
    You don't even need to remove the resolvconf package - commenting out dns=dnsmasq is sufficient.
    That's not true I too tried to only comment out dns=dnsmasq and it didn't work. I then removed it totally still, didn't work. It wasn't until I removed the resolvconf package that it worked. So, I don't think commenting out dns=dnsmasq alone works in ALL cases.

  10. #30
    Join Date
    May 2008
    Location
    SoCal
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: 12.04 running DNSMASQ by default

    Quote Originally Posted by DanteDarkKnightDante View Post
    That's not true I too tried to only comment out dns=dnsmasq and it didn't work. I then removed it totally still, didn't work. It wasn't until I removed the resolvconf package that it worked. So, I don't think commenting out dns=dnsmasq alone works in ALL cases.
    You do have to either check resolvconf and maybe even configure it. You can just comment out the dns=dnsmasq in MOST cases. If resolvconf has not been configured correctly, then you will have to configure it or as you say, remove it and configure /etc/resolv.conf.

    I'm running 12.04 with no Network_manager, but with resolvconf.
    -BAB1

Page 3 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •