I'll answer my own question since I upgraded my HP tablet PC to Pecise yesterday evening.

I see in the Unity plug-in in CCSM (compiz configuration settings manager) that the default selection is to always show the bar although there is an auto-hide option.

However in Unity 2-D auto-hide is apparently the default.

So if you are in Unity you need to un-select auto-hide and select show. For Unity 2-D I don't yet know how you are suppose to change the settings. Maybe a key value somewhere.

In 2-D I see your problem. But for me it occurs when I rotate back to laptop. The launchbar auto-hides and probing for it is finicky, but I am able to get it to pop back out, barely.