Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Nouveau Driver Vsync

  1. #1
    Join Date
    May 2005
    Location
    United States
    Beans
    232
    Distro
    Ubuntu 12.04 Precise Pangolin

    Nouveau Driver Vsync

    I usually run the proprietary NVIDIA driver on my machines, but when I upgraded one of my machines to 12.04 I decided to see how the Nouveau driver has come along. Performance seems good. I have it running two 1920x1080 screens of a Geforce 210 1gb and effects and desktop use seems very smooth. The one issue I have with this config is tearing. Compiz vsync is enabled, but tearing persists. I haven't been able to find much on Google other than people experiencing similar issues.

    Does anyone have a clean, simple method to enable vsync with the Nouveau driver, or a link to a good how-to? Thanks for any help you guys can provide.

  2. #2
    Join Date
    Jun 2007
    Beans
    17,114

    Re: Nouveau Driver Vsync

    I use nvidia but I believe you do as posted in this bug description, I'll copy here & link the report, suggest you check.
    Apparently you need to add an xorg.conf section, if there is no /etc/X11/xorg.conf then create one

    *just use what's in the "code box"*

    USERS OF THE NOUVEAU DRIVER:

    If you are using the "nouveau" driver for NVIDIA chips, you will need to enable Sync To VBlank support in the driver options because nouveau has it disabled by default. You can do this by editing /etc/X11/xorg.conf and adding:

    # For nouveau only:
    Code:
    Section "Device"
     Identifier "My Graphics"
     Option "GLXVBlank" "on"
    EndSection
    https://bugs.launchpad.net/ubuntu/+s...ty/+bug/880707

  3. #3
    Join Date
    May 2005
    Location
    United States
    Beans
    232
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Nouveau Driver Vsync

    Works great, thanks. I figured there was an xorg.conf setting, I just didn't know what it was. I also think I looked at that bug report, but must have breezed right passed that part as I was messing with this way too late at night.

  4. #4
    Join Date
    Jan 2008
    Beans
    8
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Nouveau Driver Vsync

    Hi, same problem here. Can someone post your xorg.conf? I need a reference to start.

    First I didn't have an xorg.conf so I created it and added

    Code:
    Section "Device"
     Identifier "My Graphics"
     Option "GLXVBlank" "on"
    EndSection
    Nothing happen

    Thank you in advance!!

  5. #5
    Join Date
    May 2005
    Location
    United States
    Beans
    232
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Nouveau Driver Vsync

    Make sure your xorg.conf file is located in your /etc/X11 folder. You will also have to reboot for these changes to take effect. Finally, make sure vsync is enabled in your window manager settings. For Unity, it would be in the Compiz settings.

  6. #6
    Join Date
    Jan 2008
    Beans
    8
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Nouveau Driver Vsync

    Quote Originally Posted by lakerssuperman View Post
    Make sure your xorg.conf file is located in your /etc/X11 folder. You will also have to reboot for these changes to take effect. Finally, make sure vsync is enabled in your window manager settings. For Unity, it would be in the Compiz settings.
    Ok thank you for the answer!

    So I have to reboot the system completely, no just the X?
    I'm using gnome shell now.

  7. #7
    Join Date
    May 2005
    Location
    United States
    Beans
    232
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Nouveau Driver Vsync

    1) Restarting X should do the job, but since you don't have vsync yet I would just reboot the whole system and see what you get.

    2) I'm also running Gnome Shell and it has vsync enabled by default.

    3) I usually just reboot my system if I make any changes to the xorg.conf file.

  8. #8
    Join Date
    Jan 2008
    Beans
    8
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Nouveau Driver Vsync

    Quote Originally Posted by lakerssuperman View Post
    1) Restarting X should do the job, but since you don't have vsync yet I would just reboot the whole system and see what you get.

    2) I'm also running Gnome Shell and it has vsync enabled by default.

    3) I usually just reboot my system if I make any changes to the xorg.conf file.
    Didn't work . Is not a big problem anyway...

    thank you 8)

  9. #9
    Join Date
    May 2005
    Location
    United States
    Beans
    232
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Nouveau Driver Vsync

    One last thing you might try is to place the following lines in your /etc/environment

    CLUTTER_PAINT=disable-clipped-redraws:disable-culling
    CLUTTER_VBLANK=True

    They force Gnome Shell vsync and other vsync related tweaks to be enabled.

  10. #10
    Join Date
    Jan 2008
    Beans
    8
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Nouveau Driver Vsync

    Quote Originally Posted by lakerssuperman View Post
    One last thing you might try is to place the following lines in your /etc/environment

    CLUTTER_PAINT=disable-clipped-redraws:disable-culling
    CLUTTER_VBLANK=True

    They force Gnome Shell vsync and other vsync related tweaks to be enabled.

    Hey, sorry for the delay XD. For the moment seems like is working! but maybe is just my perception ¬¬. Tested on Gnome-Shell and Cinnamon .

    BTW, I installed the proprietary beta and stable drivers for N-vidia, they have a lot of bugs with the 6xx series. So for now I recommend the Nouveau drivers XD, even with compiz (Unity) better performance than proprietary drivers.

    Thank you very much for your help. Gracias)
    Last edited by danielcaraj; May 25th, 2012 at 04:07 PM.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •