Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: 10.04 Atheros AR9485 168c:0032 Wireless not working

  1. #1
    Join Date
    Apr 2012
    Beans
    4

    10.04 Atheros AR9485 168c:0032 Wireless not working

    Ok so I bought a new laptop, Asus x53e and it has an Atheros AR9485 198c:0032 wireless chipset on it and I can't seem to get it to work. The wifi light wont turn on, it doesn't show up under ifconfig or iwconfig and when I tried going to the Hardware Drivers it didn't show anything. I managed to get my lan working fine which I'm happy about, but I really need my wireless! Please if you have any suggestions I'm willing to try anything at this point!

    oh and i tried doing ndiswrapper, but no matter what i tried i couldn't seem to get the windows driver .inf file no matter where i looked. the other driver i noticed though was an atheros AR8185 driver and i got it to work which i'm assuming that is for my lan hhaha

  2. #2
    Join Date
    Sep 2008
    Location
    Colorado
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: 10.04 Atheros AR9485 168c:0032 Wireless not working

    One quick thought:
    Does your keyboard have an Fn key on the bottom left corner of the keyboard (probably next to the Ctrl key)? Plus, does one of your F1 through F12 keys have an antenna on it? If so, depress the Fn key and then depress the F? key to turn the WiFi on.

    Some Laptops have a hardware key (linked to the Fn key) to turn on WiFi and the software doesn't pick it up. On my Zareason mini, the WiFi hardware key fails to stay on after shut down, reboot or log out. Since the Fn key is not recognized by software, it needs to be manually turned on.

    Good Luck & hope this helps. If not, then hopefully another member will help with solutions.
    "All change is not growth, as all movement is not forward."
    Ellen Glasgow

  3. #3
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,737
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: 10.04 Atheros AR9485 168c:0032 Wireless not working

    Please open a terminal and run and post the results of these commands:
    Code:
    lsmod | grep -e ath -e ndis
    rfkill list all
    The pipe symbol | is on the right side of my US keyboard on the same key with \. Thanks.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  4. #4
    Join Date
    Apr 2012
    Beans
    4

    Re: 10.04 Atheros AR9485 168c:0032 Wireless not working

    it is the fn + f2 which works with windows but not on linux.

    i typed both of those in terminal but i received no output :/

  5. #5
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,737
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: 10.04 Atheros AR9485 168c:0032 Wireless not working

    Please try this:
    Code:
    sudo su
    modprobe ath9k
    echo "168c 0032" >> /sys/bus/pci/drivers/ath9k/new_id
    iwconfig
    exit
    Is your wireless working? If so, we'll need to tweak a file to make it persistent.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  6. #6
    Join Date
    Apr 2012
    Beans
    4

    Re: 10.04 Atheros AR9485 168c:0032 Wireless not working

    did everything you said, then when i did iwconfig it says

    lo no wireless extensions

    eth0 no wireless extensions


    still no luck

  7. #7
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,737
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: 10.04 Atheros AR9485 168c:0032 Wireless not working

    Let's try it a bit differently:
    Code:
    sudo su
    modprobe ath9k
    echo "168C 0032" > /sys/bus/pci/drivers/ath9k/new_id
    iwconfig
    exit
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  8. #8
    Join Date
    Apr 2012
    Beans
    4

    Re: 10.04 Atheros AR9485 168c:0032 Wireless not working

    same thing

  9. #9
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,737
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: 10.04 Atheros AR9485 168c:0032 Wireless not working

    Let's see:
    Code:
    lspci -nn | grep 0280
    lsmod | grep asus
    Thanks.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  10. #10
    Join Date
    Sep 2012
    Beans
    2

    Re: 10.04 Atheros AR9485 168c:0032 Wireless not working

    Hi and thanks for a solution, the line of commands below makes my Wifi works, until I reboot.

    sudo su
    modprobe ath9k
    echo "168c 0032" >> /sys/bus/pci/drivers/ath9k/new_id
    iwconfig
    exit
    Could someone please help me make these permanent, I don't even know what to begin to search for.

    Best regards,
    Peter

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •