Results 1 to 1 of 1

Thread: Epson Network Printer Does Not Work with 12.04

  1. #1
    Join Date
    Sep 2011

    Epson Network Printer Does Not Work with 12.04

    I was running 11.. with wubi and my Epson NX430 worked fine, set up was a breeze. In 12.04 I go through the printer set up procedure with no errors. Instead of the test page it prints a horizontal line on many sheets of paper. Below are things I tried to fix it.

    - deleted and re-added the printer
    - changed from recommended to other Epson models
    - tried other options

    Each time I get the same results. I need network printing since I am using the printer for another laptop and tablet.


    I found the following linux drivers for the nx430. Any ideas if one of these will work?

    File name File size epson-inkjet-printer-201105w-1.0.0-1lsb3.2.i486.rpm1.58 MB
    epson-inkjet-printer-201105w_1.0.0-1lsb3.2_i386.deb1.58 MB
    epson-inkjet-printer-201105w-1.0.0-1lsb3.2.x86_64.rpm1.59 MB
    epson-inkjet-printer-201105w_1.0.0-1lsb3.2_amd64.deb1.58 MB
    epson-inkjet-printer-201105w-1.0.0-1lsb3.2.src.rpm2.04 MB

    I downloaded the files from avasys via Firefox and one of had a default action to use with installer. I selected that option. Software started and installed the epson nx430 driver(s) and the printer now works!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!

    Here is the avasys link
    Last edited by barrytesta; April 27th, 2012 at 10:34 PM. Reason: found possible printer drivers,solved,added avasys link

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts