Quote Originally Posted by AnotherMuggle View Post
This post is to draw everything into once place. Partly to help people looking for this patch and partly so I can keep better track myself lol.

I have attached all the patch files that I have done for Ubuntu 12.04 to this post and will remove from elsewhere a link here (I think I can do that). All these patches are the same, the only difference is the version number, so that it doesn't cause any problems when installing against a different kernel version.

Once the patch is installed it can be left alone, no need to do anything when you get a kernel installed as it is updated automatically.

I have been using this patch myself and have had no issues with it. Many people have contacted me or posted on this thread confirming it works on other laptops but it was put together specifically for the HP Mini 210...you may find success on other laptops too

When using the commands below replace <VERSION> with the relevant version number you are trying to installed, for example for version 3.2.0-24, use psmouse-3.2.0-24-generic-pae

Code:
To install the patch:

1. Download the attached file to your computers desktop
2. sudo apt-get install dkms build-essential
3. cd ~/Desktop
4. tar jxvf psmouse-<VERSION>-generic-pae.tar.bz2
5. sudo mv psmouse-<VERSION>-generic-pae /usr/src
6. cd /usr/src
7. sudo chmod -R a+rx psmouse-<VERSION>-generic-pae
8. sudo dkms add -m psmouse -v <VERSION>-generic-pae
9. sudo dkms build -m psmouse -v <VERSION>-generic-pae
10. sudo dkms install -m psmouse -v <VERSION>-generic-pae
11. sudo modprobe -r psmouse
12. sudo modprobe psmouse
13. sudo dkms status
The output of the last command should look similar to this (with no errors):
Code:
"psmouse, 3.2.0-24-generic-pae, 3.2.0-24-generic-pae, i686: installed"
No need to restart the computer as the driver is now loaded and the mouse should be working, including the hardware right button.

Code:
To uninstall the patch:

1. sudo dkms uninstall -m psmouse -v <VERSION>-generic-pae
2. sudo dkms remove -m psmouse -v <VERSION>-generic-pae --all

this method works like a charm.. thumbs up