Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Broadcom STA Wifi used to work on 11.10

  1. #1
    Join Date
    Jun 2009
    Beans
    36

    Broadcom STA Wifi used to work on 11.10

    Just installed 12.04 and no wifi.

    Settings => Settings Manager => Additional Drivers =>

    ================================================== =
    Broadcom STA proprietary wireless driver
    Tested by the Ubuntu developers
    Licence: Proprietary
    This package contains Broadcom 802.11 Linux STA wireless driverfor use with Broadcom's BCM4311-, BCM4312-, BCM4313-, BCM4321-,BCM4322-, BCM43224-, and BCM43225-, BCM43227- and BCM43228-basedhardware.

    This driver is activated and currently in use.
    ================================================== =

    This driver may well be activated, but it certainly isn't in use!

    Clicking on the up/down arrow thingy on the top panel reveals:
    Wired network
    Wired connection 1
    Disconnect
    VPN Connnections
    Enable networking
    Connection information
    Edit connections

    Nothing there about wifi...

    ... Is it me? (btw, it worked 100% under Xubuntu 11.10)

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,001
    Distro
    Ubuntu 16.10 Yakkety Yak

    Re: Broadcom STA Wifi used to work on 11.10

    Oh, boy! The fun begins! Please open a terminal and show us:
    Code:
    lspci -nn | grep 0280
    lsmod | grep -e b43 -e wl
    The pipe symbol | is on the right side of my US keyboard on the same key with \. Thanks.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #3
    Join Date
    Jun 2009
    Beans
    36

    Re: Broadcom STA Wifi used to work on 11.10

    Hi Chili, thank you but no, no to your 'The fun begins'. That started yonks ago!

    Usually if it's not broken then you haven't tweaked enough ... but in this instance it's a brand new install..
    I've been using the daily builds for some time and everything was going swimmingly until today's release (escape?) when it all went pear shaped.

    Here's the output you asked for:
    Code:
    martyn@laptop:~$ lspci -nn | grep 0280
    05:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 01)
    martyn@laptop:~$ 
    martyn@laptop:~$ lsmod | grep -e b43 -e wl
    wl                   2646601  0 
    lib80211               14040  1 wl
    martyn@laptop:~$
    Does this give you the info you were after?

    Thanks in advance for any help or advice!

  4. #4
    Join Date
    Jan 2008
    Location
    Pittsburgh, PA
    Beans
    15
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Broadcom STA Wifi used to work on 11.10

    Having the same issue on stock Ubuntu 12.04 64-bit, freshly installed.

    Here's the results of the commands:

    Code:
    $ lspci -nn | grep 0280
    30:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11a/b/g [14e4:4312] (rev 01)
    $ lsmod | grep -e b43 -e wl
    wl                  2568210  0
    lib80211              14381  1 wl

  5. #5
    Join Date
    Jan 2008
    Location
    Pittsburgh, PA
    Beans
    15
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Broadcom STA Wifi used to work on 11.10

    Code:
    sudo modprobe b43
    Did the trick for me. Any reason why this isn't starting up on its own?

  6. #6
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,001
    Distro
    Ubuntu 16.10 Yakkety Yak

    Re: Broadcom STA Wifi used to work on 11.10

    The fun begins because rumor has it that Additional Drivers misidentifies the correct driver for some Broadcom cards and installs the incorrect one. I believe you are my first case!

    Please do:
    Code:
    sudo apt-get install linux-firmware-nonfree
    sudo modprobe -r wl
    sudo modprobe b43
    If it works as expected, we'll need additional steps to make it permanent.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  7. #7
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,001
    Distro
    Ubuntu 16.10 Yakkety Yak

    Re: Broadcom STA Wifi used to work on 11.10

    Quote Originally Posted by justin.waters View Post
    Code:
    sudo modprobe b43
    Did the trick for me. Any reason why this isn't starting up on its own?
    Please try what I suggested above and let me know.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  8. #8
    Join Date
    Jan 2008
    Location
    Pittsburgh, PA
    Beans
    15
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Broadcom STA Wifi used to work on 11.10

    Quote Originally Posted by chili555 View Post
    The fun begins because rumor has it that Additional Drivers misidentifies the correct driver for some Broadcom cards and installs the incorrect one. I believe you are my first case!

    Please do:
    Code:
    sudo apt-get install linux-firmware-nonfree
    sudo modprobe -r wl
    sudo modprobe b43
    If it works as expected, we'll need additional steps to make it permanent.
    Yup, works for me. I tried it the first time with the firmware-b43-installer package, and it also works.

  9. #9
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,001
    Distro
    Ubuntu 16.10 Yakkety Yak

    Re: Broadcom STA Wifi used to work on 11.10

    Quote Originally Posted by justin.waters View Post
    Yup, works for me. I tried it the first time with the firmware-b43-installer package, and it also works.
    Excellent! Please do:
    Code:
    sudo apt-get remove --purge bcmwl-kernel-source
    Look around in /etc/modprobe.d and make sure the purge did not leave any blacklist of b43; if so, remove it:
    Code:
    sudo rm /etc/modprobe.d/whatyoufound
    Reboot and enjoy.

    @Kronalias--

    Verify before you try this fix, please.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  10. #10
    Join Date
    Apr 2012
    Beans
    53

    Re: Broadcom STA Wifi used to work on 11.10

    Same problem when upgrading from 11.10. After reboot I had to use LAN and then update manager showed error. Then "apt-get install -f" as it said and it removed almost everything including kernel files. Well, home folder was still on it's place and did backup personal files to usb-stick. Then fresh install. Install ready and rebooting to OS - no wlan and restricted driver didin't work. Then googled and found this, and it is for BCM4311
    Code:
    sudo apt-get install b43-fwcutter firmware-b43-installer
    And it worked. You may optionally try this first, it removes all broadcom stuff from your system: sudo ap((read_before_copy_paste)t-get purge broadcom-sta-common broadcom-sta-source bcmwl-kernel-source

    Now system functions perfectly! Maybe they should update install disk what comes to broadcom chips.
    Last edited by 1204; April 26th, 2012 at 11:37 PM.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •