Page 4 of 6 FirstFirst ... 23456 LastLast
Results 31 to 40 of 54

Thread: Ubuntu 12.04 Slow Wireless

  1. #31
    Join Date
    Dec 2007
    Beans
    6

    Re: Ubuntu 12.04 Slow Wireless

    Thanks Wildmanne39, I think you might have solved the problem for me too.. I tried that method to disable n configuration and so far so good, wifi is much more responsive.

  2. #32
    Join Date
    Oct 2009
    Beans
    28

    Re: Ubuntu 12.04 Slow Wireless

    Quote Originally Posted by vDub2000 View Post
    Tried it... says ERROR: Module iwlwifi does not exist in /proc/modules
    This works perfectly for me.
    I am running Ubuntu 12.04 on Dell XPS 15 L502X with Intel Centrino Wireless (driver is iwlwifi and wifi security is WEP).

    http://askubuntu.com/questions/81156...ino-wirel?rq=1

  3. #33
    Join Date
    Apr 2013
    Beans
    9

    Re: Ubuntu 12.04 Slow Wireless

    I am having the same problem and couldnt solve it...

    Please, help me to fix it! :)


    my computer datas:

    leo@leo-note:~$ cat /etc/lsb-release; uname -a
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=12.04
    DISTRIB_CODENAME=precise
    DISTRIB_DESCRIPTION="Ubuntu 12.04.2 LTS"
    Linux leo-note 3.2.0-39-generic-pae #62-Ubuntu SMP Wed Feb 27 22:25:11 UTC 2013 i686 i686 i386 GNU/Linux


    leo@leo-note:~$ lspci -nnk | grep -iA2 net
    07:00.0 Network controller [0280]: Atheros Communications Inc. AR9485 Wireless Network Adapter [168c:0032] (rev 01)
    Subsystem: Foxconn International, Inc. Device [105b:e044]
    Kernel driver in use: ath9k
    --
    09:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 07)
    Subsystem: Sony Corporation Device [104d:90ab]
    Kernel driver in use: r8169

    leo@leo-note:~$ lsusb
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 001 Device 004: ID 04f2:b32f Chicony Electronics Co., Ltd
    leo@leo-note:~$

    leo@leo-note:~$ iwconfig
    lo no wireless extensions.

    wlan0 IEEE 802.11bgn ESSID:"apartamento33"
    Mode:Managed Frequency:2.437 GHz Access Point: 00:1D:D2:4D:B9:A0
    Bit Rate=39 Mb/s Tx-Power=16 dBm
    Retry long limit:7 RTS thr:off Fragment thr:off
    Power Management:off
    Link Quality=56/70 Signal level=-54 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:209 Invalid misc:1 Missed beacon:0

    eth0 no wireless extensions.


    leo@leo-note:~$ rfkill list all
    0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    2: sony-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    3: sony-bluetooth: Bluetooth
    Soft blocked: yes
    Hard blocked: no
    leo@leo-note:~$

    leo@leo-note:~$ lsmod
    Module Size Used by
    rfcomm 38139 0
    bnep 17830 2
    parport_pc 32114 0
    ppdev 12849 0
    binfmt_misc 17292 1
    vesafb 13516 1
    joydev 17393 0
    snd_hda_codec_hdmi 31775 1
    snd_hda_codec_realtek 174313 1
    snd_seq_midi 13132 0
    snd_rawmidi 25424 1 snd_seq_midi
    snd_seq_midi_event 14475 1 snd_seq_midi
    snd_seq 51592 2 snd_seq_midi,snd_seq_midi_event
    uvcvideo 67203 0
    videodev 86588 1 uvcvideo
    ath3k 12825 0
    btusb 17948 0
    bluetooth 158479 12 rfcomm,bnep,ath3k,btusb
    psmouse 86520 0
    serio_raw 13027 0
    snd_seq_device 14172 3 snd_seq_midi,snd_rawmidi,snd_seq
    snd_hda_intel 32719 5
    snd_hda_codec 109562 3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_i ntel
    snd_hwdep 13276 1 snd_hda_codec
    arc4 12473 2
    snd_pcm 80916 3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
    sony_laptop 39681 0
    ath9k 117356 0
    mac80211 436493 1 ath9k
    fglrx 2909978 155
    snd_timer 28931 2 snd_seq,snd_pcm
    snd 62218 20 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_rawmi di,snd_seq,snd_seq_device,snd_hda_intel,snd_hda_co dec,snd_hwdep,snd_pcm,snd_timer
    video 19115 0
    ath9k_common 13781 1 ath9k
    ath9k_hw 391626 2 ath9k,ath9k_common
    ath 19387 3 ath9k,ath9k_common,ath9k_hw
    cfg80211 178877 3 ath9k,mac80211,ath
    mac_hid 13077 0
    soundcore 14635 1 snd
    snd_page_alloc 14108 2 snd_hda_intel,snd_pcm
    mei 36570 0
    rts_pstor 353252 0
    lp 17455 0
    parport 40930 3 parport_pc,ppdev,lp
    r8169 56368 0
    leo@leo-note:~$


    leo@leo-note:~$ nm-tool

    NetworkManager Tool

    State: connected (global)

    - Device: eth0 -----------------------------------------------------------------
    Type: Wired
    Driver: r8169
    State: unavailable
    Default: no
    HW Address: 30:F9:ED:DC:63:13

    Capabilities:
    Carrier Detect: yes

    Wired Properties
    Carrier: off


    - Device: wlan0 [apartamento33] -----------------------------------------------
    Type: 802.11 WiFi
    Driver: ath9k
    State: connected
    Default: yes
    HW Address: 84:4B:F5:DC:BB:A5

    Capabilities:
    Speed: 52 Mb/s

    Wireless Properties
    WEP Encryption: yes
    WPA Encryption: yes
    WPA2 Encryption: yes

    Wireless Access Points (* = current AP)
    minero_m: Infra, E8:6D:52:B2:21:D4, Freq 2462 MHz, Rate 54 Mb/s, Strength 35 WPA WPA2
    Cris: Infra, 64:87:D7:F5:E1:E6, Freq 2452 MHz, Rate 54 Mb/s, Strength 30 WPA2
    Lazar2: Infra, F8:D1:11:33:95:AE, Freq 2412 MHz, Rate 54 Mb/s, Strength 24 WPA WPA2
    DN4-NET: Infra, F4:EC:38:AE:CD:1C, Freq 2427 MHz, Rate 54 Mb/s, Strength 24 WPA2
    netvirtuaapt24: Infra, E8:6D:52:94:6E:1C, Freq 2462 MHz, Rate 54 Mb/s, Strength 20 WPA
    Cristal House: Infra, 98:FC:11:C1:9E:3E, Freq 2437 MHz, Rate 54 Mb/s, Strength 19 WPA WPA2
    Didi: Infra, 94:0C:6D:AE:92:9A, Freq 2427 MHz, Rate 54 Mb/s, Strength 15 WPA WPA2
    TW 41: Infra, 1C:7E:E5:FF:BE:A0, Freq 2437 MHz, Rate 54 Mb/s, Strength 15 WPA WPA2
    Apto1202: Infra, 00:1D:0F:F5:85:E2, Freq 2437 MHz, Rate 54 Mb/s, Strength 67 WEP
    Almir: Infra, 00:23:CD:D7:6F:BC, Freq 2437 MHz, Rate 54 Mb/s, Strength 29 WEP
    NET-VIRTUA-WIFI: Infra, C4:0A:CB:69:68:40, Freq 2412 MHz, Rate 54 Mb/s, Strength 24
    *apartamento33: Infra, 00:1D:D2:4D:B9:A0, Freq 2437 MHz, Rate 54 Mb/s, Strength 66 WPA2
    Privado: Infra, 00:1C:DF:98:DB:54, Freq 2412 MHz, Rate 54 Mb/s, Strength 20 WPA WPA2
    Cacau: Infra, 98:FC:11:CE:BB:DA, Freq 2437 MHz, Rate 54 Mb/s, Strength 22 WPA WPA2
    Embratel-Wi-Fi: Infra, B8:BE:BF:3B:91:A1, Freq 2412 MHz, Rate 54 Mb/s, Strength 22

    IPv4 Settings:
    Address: 192.168.0.4
    Prefix: 24 (255.255.255.0)
    Gateway: 192.168.0.1

    DNS: 201.6.2.85
    DNS: 201.6.2.175


    Quote Originally Posted by Wild Man View Post
    Hi, most people have not gotten that driver to work at all I believe, please post the output of:
    Code:
    cat /etc/lsb-release; uname -a
    lspci -nnk | grep -iA2 net
    lsusb
    iwconfig
    rfkill list all
    lsmod
    nm-tool
    here by clicking on new reply and click # and paste the information between the brackets.
    Thank you

  4. #34
    Join Date
    Jun 2010
    Beans
    79

    Re: Ubuntu 12.04 Slow Wireless

    Dunno if it's relevant, but I'm using a RT3090 network card, and ever since I used it, I had very slow speed if using the laptop on battery power. Last month or two, it's ben fine though, I assume an update fixed that?

  5. #35
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    21,868
    Distro
    Ubuntu Gnome Development Release

    Re: Ubuntu 12.04 Slow Wireless

    Hi, please do:
    Code:
    echo "options ath9k nohwcrypt=1" | sudo tee /etc/modprobe.d/ath9k.conf
    sudo modprobe -rfv ath9k
    sudo modprobe -v ath9k
    Change your wireless settings in network manager to match the screenshots.
    Thanks
    Attached Images Attached Images

  6. #36
    Join Date
    Apr 2013
    Beans
    9

    Re: Ubuntu 12.04 Slow Wireless

    I did this and the connection got worst

    Any other idea?

    thankssss


    Quote Originally Posted by Wild Man View Post
    Hi, please do:
    Code:
    echo "options ath9k nohwcrypt=1" | sudo tee /etc/modprobe.d/ath9k.conf
    sudo modprobe -rfv ath9k
    sudo modprobe -v ath9k
    Change your wireless settings in network manager to match the screenshots.
    Thanks

  7. #37
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    21,868
    Distro
    Ubuntu Gnome Development Release

    Re: Ubuntu 12.04 Slow Wireless

    Hi, it does not help that there are so many networks next to yours, please set your channel to 1 or 11.

    Post the contents of:
    Code:
    gksudo gedit /etc/modprobe.d/ath9k.conf
    Please post screenshots of your wireless settings like I did in my previous post so we can make sure they are the same.
    Thanks

  8. #38
    Join Date
    Apr 2013
    Beans
    9

    Re: Ubuntu 12.04 Slow Wireless

    when I type the code it appears:
    "options ath9k nohwcrypt=1"

    I changed the channel to 11...

    I am trying to send the printscreens but the connection really doesnt help.. I cant upload them

    The wifi connection is istill really bad... I can understand why in windows it is ok...



    Quote Originally Posted by Wild Man View Post
    Hi, it does not help that there are so many networks next to yours, please set your channel to 1 or 11.

    Post the contents of:
    Code:
    gksudo gedit /etc/modprobe.d/ath9k.conf
    Please post screenshots of your wireless settings like I did in my previous post so we can make sure they are the same.
    Thanks

  9. #39
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    21,868
    Distro
    Ubuntu Gnome Development Release

    Re: Ubuntu 12.04 Slow Wireless

    Hi, you can try what I posted in this thread.
    http://ubuntuforums.org/showthread.php?t=2133296&page=2 Post 16.
    and read the following posts because you will still likely need the other settings as well.
    Thanks

  10. #40
    Join Date
    Apr 2013
    Beans
    9

    Re: Ubuntu 12.04 Slow Wireless

    I'll try it but what others settings are u talking about? thanks!!!!!


    Quote Originally Posted by Wild Man View Post
    Hi, you can try what I posted in this thread.
    http://ubuntuforums.org/showthread.php?t=2133296&page=2 Post 16.
    and read the following posts because you will still likely need the other settings as well.
    Thanks

Page 4 of 6 FirstFirst ... 23456 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •