Results 1 to 2 of 2

Thread: 11.10 - Problems making CGAL demos - libQtOpenGL

  1. #1
    Join Date
    Apr 2012
    Beans
    1

    Question 11.10 - Problems making CGAL demos - libQtOpenGL

    Hi Forum!

    I have installed the CGAL (http://www.cgal.org/) from ppa, on Ubuntu 11.10, gnome 3, xubuntu, 64 bit, running on intel 1155.

    Getting the CGAL examples and demos to run involves running cmake and make. I've made some progress making the examples by installing various libs cmake was flagging up.

    No luck with the demos though. Regarding dependence on libQtOpenGL, apparently the CGAL cmake mechanism switches between the QT3 and QT4 version depending on what's available, so I've tried to install only the QT4 bits so as not to confuse it.

    I have installed :

    libqglviewer-dev-common
    libqglviewer-qt4-dev
    libqglviewer-qt4-2

    and NOT installed :

    libqglviewer2
    libqglviewer-dev
    libqglviewer-qt3-dev
    libqglviewer-qt3-2

    From the naming, it looked as if I should maybe install libqglviewer2 and libqglviewer-dev, but the descriptions seems to indicate they are there for transition to QT3 (from QT2 ? ), but maybe I'm misunderstanding those.
    What I find confusing, while the description would indicate I should have libqglviewer-dev-common , there is some mention of QT3 in there. But there doesn't seem to be another dev-common lib with reference to QT4.
    I've used Synaptic to install those.

    Anyway, when running make I get :

    make[2]: *** No rule to make target `/usr/lib/libQtOpenGL.so', needed by `AABB_tree/AABB_demo'. Stop.
    make[1]: *** [AABB_tree/CMakeFiles/AABB_demo.dir/all] Error 2
    make: *** [all] Error 2

    This happens for all of the demos, they all seem to need libQtOpenGL.

    Did I install the wrong bits?

    my version for the libs is 2.3.4-4ubuntu1
    Last edited by stupormundi; April 22nd, 2012 at 08:04 PM.

  2. #2
    Join Date
    Feb 2008
    Beans
    5,027
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: 11.10 - Problems making CGAL demos - libQtOpenGL

    Quote Originally Posted by stupormundi View Post
    I have installed the CGAL (http://www.cgal.org/) from ppa, on Ubuntu 11.10, gnome 3, xubuntu, 64 bit, running on intel 1155.
    Could you clarify, please? CGAL is in the Ubuntu Software Center, is that where you installed it from? Generally, items in the software center install all needed dependencies. I would have expected it to be version 3.8-1.

    Are you using XFCE or Gnome 3?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •