Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 26

Thread: Dell 1545 Wireless Won't Connect

  1. #11
    Join Date
    Apr 2012
    Beans
    32

    Re: Dell 1545 Wireless Won't Connect

    I followed what GrandpaLeaman linked and in the end when i went to system > administration > additional drivers and selected the b43 driver it ran and tried to install and in the end i got SystemError: installArchives() failed

    Still can't get wireless working

  2. #12
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    6,577
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Dell 1545 Wireless Won't Connect

    Please check now:

    Code:
    iwconfig
    lsmod
    sudo iwlist scan
    dmesg | egrep 'b43|wl'
    rfkill list

  3. #13
    Join Date
    Apr 2012
    Beans
    32

    Re: Dell 1545 Wireless Won't Connect

    george@george-Satellite-A305:/$ iwconfig
    lo no wireless extensions.

    eth2 no wireless extensions.

    wlan1 IEEE 802.11bg ESSIDff/any
    Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
    Retry long limit:7 RTS thrff Fragment thrff
    Power Managementff

    vmnet1 no wireless extensions.

    vmnet8 no wireless extensions.

    george@george-Satellite-A305:/$ lsmod
    Module Size Used by
    binfmt_misc 6599 1
    vmnet 42813 13
    vsock 39716 0
    vmci 67840 1 vsock
    vmmon 61066 0
    parport_pc 26058 0
    ppdev 5556 0
    snd_hda_codec_idt 54951 1
    arc4 1165 2
    joydev 8767 0
    b43 168681 0
    snd_hda_intel 22235 2
    snd_hda_codec 87552 2 snd_hda_codec_idt,snd_hda_intel
    snd_hwdep 5040 1 snd_hda_codec
    snd_pcm 71475 2 snd_hda_intel,snd_hda_codec
    snd_seq_midi 4588 0
    snd_rawmidi 17783 1 snd_seq_midi
    snd_seq_midi_event 6047 1 snd_seq_midi
    i915 296139 4
    snd_seq 47174 2 snd_seq_midi,snd_seq_midi_event
    snd_timer 19067 2 snd_pcm,snd_seq
    uvcvideo 55943 0
    snd_seq_device 5744 3 snd_seq_midi,snd_rawmidi,snd_seq
    mac80211 231959 1 b43
    drm_kms_helper 30200 1 i915
    dell_laptop 5730 0
    dell_wmi 2788 0
    dcdbas 5402 1 dell_laptop
    videodev 43194 1 uvcvideo
    v4l1_compat 13359 2 uvcvideo,videodev
    drm 168124 4 i915,drm_kms_helper
    snd 49102 13 snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_ hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_se q_device
    cfg80211 144758 2 b43,mac80211
    led_class 2633 1 b43
    i2c_algo_bit 5168 1 i915
    psmouse 59027 0
    serio_raw 4022 0
    soundcore 880 1 snd
    video 18712 1 i915
    snd_page_alloc 7120 2 snd_hda_intel,snd_pcm
    output 1883 1 video
    intel_agp 26566 2 i915
    agpgart 32011 2 drm,intel_agp
    lp 7342 0
    parport 31492 3 parport_pc,ppdev,lp
    usb_storage 40492 0
    ahci 19326 2
    libahci 21728 1 ahci
    ssb 39320 1 b43
    sky2 45127 0

    george@george-Satellite-A305:/$ sudo iwlist scan
    [sudo] password for george:
    lo Interface doesn't support scanning.

    eth2 Interface doesn't support scanning.

    wlan1 Interface doesn't support scanning : Network is down

    vmnet1 Interface doesn't support scanning.

    vmnet8 Interface doesn't support scanning.

    george@george-Satellite-A305:/$ dmesg | egrep 'b43|wl'
    [ 1.065552] b43-pci-bridge 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
    [ 1.065570] b43-pci-bridge 0000:0c:00.0: setting latency timer to 64
    [ 21.783462] b43-phy0: Broadcom 4312 WLAN found (core revision 15)
    [ 21.867394] Registered led device: b43-phy0::tx
    [ 21.867412] Registered led device: b43-phy0::rx
    [ 21.867433] Registered led device: b43-phy0::radio
    [ 21.941308] udev[441]: renamed network interface wlan0 to wlan1
    [ 5800.031465] b43-pci-bridge 0000:0c:00.0: PCI INT A disabled
    [ 5800.931126] b43-pci-bridge 0000:0c:00.0: restoring config space at offset 0xf (was 0x100, writing 0x104)
    [ 5800.931186] b43-pci-bridge 0000:0c:00.0: restoring config space at offset 0x4 (was 0x4, writing 0xf69fc004)
    [ 5800.931198] b43-pci-bridge 0000:0c:00.0: restoring config space at offset 0x3 (was 0x0, writing 0x10)
    [ 5800.931216] b43-pci-bridge 0000:0c:00.0: restoring config space at offset 0x1 (was 0x100000, writing 0x100106)
    [ 5800.935083] b43-pci-bridge 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17

    george@george-Satellite-A305:/$ rfkill list
    0: dell-wifi: Wireless LAN
    Soft blocked: yes
    Hard blocked: yes
    1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

    george@george-Satellite-A305:/$

    I see in rfkill list those are soft blocked i'm guessing that's my issue? should i do rfkill unblock all? I'll wait for a reply so i don't break anything but i think that's what i should do next right

  4. #14
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    6,577
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Dell 1545 Wireless Won't Connect

    Try to reset the BIOS.

  5. #15
    Join Date
    Apr 2012
    Beans
    32

    Re: Dell 1545 Wireless Won't Connect

    On my phone at the moment so haven't actually gone into the bios yet but I'm a bit noobish sorry what exactly should I reset there I'll go into my bios when home and see if its obvious but if not could you please give me a bit more detail thanks so much for the help thus far

  6. #16
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    6,577
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Dell 1545 Wireless Won't Connect

    In most BIOSes its F9 to reset and F10 to save&exit.

  7. #17
    Join Date
    Apr 2012
    Beans
    32

    Re: Dell 1545 Wireless Won't Connect

    Well i went into my bios but wasn't sure what i was supposed in there so i booted back up.

    When i booted i hit the wifi icon and it said device not ready firmware missing or whatever so i went into system > administration > additional drivers and selected the b43 one to activate but got the installArchives() failed error again so i went and did the following again

    sudo modprobe -rfv wl
    sudo apt-get remove --purge bcmwl-kernel-source

    right after i did that one i was about to cd to my desktop and download the tar but wifi connected so i came here to say i was up but as soon as i logged in wifi dropped and now i can't get connected again so i'm very confused what's up now and had to go back to ethernet just to post this reply but i did browse back to the thread using wifi so i'd say we're very close but something is still not right

    Anyway wasn't sure what i was supposed to reset still in my bios or what exactly i'm supposed to do when i'm in the bios

    Figured i'd post the outputs as well from what you originally suggested
    george@george-Satellite-A305:/$ sudo modprobe -rfv wl
    FATAL: Module wl not found.
    george@george-Satellite-A305:/$ sudo apt-get remove --purge bcmwl-kernel-source
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package bcmwl-kernel-source is not installed, so not removed
    The following packages were automatically installed and are no longer required:
    emerald-infinity-theme metacity-showtime-theme icon-eco-theme gtk-eco-theme
    icon-tropical-theme gtk-orange-theme gnome-eco-theme icon-bamboo-zen-theme
    emerald-tropical-theme gtk-split-theme metacity-step-into-freedom-theme
    gtk-wild-shine-theme gtk-infinity-theme emerald-wild-shine-theme
    gtk-balanzan-theme metacity-exotic-theme wallpaper-infinity-theme
    wallpaper-balanzan-theme gnome-showtime-theme icon-airlines-theme
    gnome-ellanna-theme encfs icon-step-into-freedom-theme metacity-orange-theme
    wallpaper-exotic-theme wallpaper-step-into-freedom-theme
    metacity-ellanna-theme gnome-bamboo-zen-theme icon-exotic-theme
    wallpaper-orange-theme libgdata1.4-cil icon-ellanna-theme libtext-glob-perl
    gnome-exotic-theme libdate-calc-perl metacity-tropical-theme
    metacity-eco-theme gnome-orange-theme metacity-bamboo-zen-theme
    libcarp-clan-perl wallpaper-split-theme banshee-extensions-common
    emerald-ubuntu-sunrise-theme icon-wild-shine-theme icon-infinity-theme
    icon-balanzan-theme gnome-infinity-theme gnome-split-theme
    metacity-airlines-theme librlog5 wallpaper-eco-theme gnome-tropical-theme
    libalut0 emerald-step-into-freedom-theme wallpaper-showtime-theme
    gnome-wild-shine-theme emerald-exotic-theme gnome-airlines-theme
    gtk-ellanna-theme emerald-orange-theme libnet-ip-perl libnet-dns-perl
    metacity-infinity-theme metacity-balanzan-theme wallpaper-bamboo-zen-theme
    metacity-wild-shine-theme gtk-ubuntu-sunrise-theme
    gtk-step-into-freedom-theme libfile-find-rule-perl
    gnome-ubuntu-sunrise-theme icon-split-theme wallpaper-ubuntu-sunrise-theme
    split-theme gtk-tropical-theme icon-showtime-theme gtk-bamboo-zen-theme
    emerald-showtime-theme emerald-bamboo-zen-theme gnome-balanzan-theme
    wallpaper-tropical-theme icon-ubuntu-sunrise-theme metacity-split-theme
    gtk-showtime-theme gtk-airlines-theme libdigest-hmac-perl
    bisigi-cursor-theme metacity-ubuntu-sunrise-theme wallpaper-airlines-theme
    wallpaper-ellanna-theme step-into-freedom-theme wallpaper-wild-shine-theme
    libnumber-compare-perl gnome-step-into-freedom-theme gtk-exotic-theme
    libbit-vector-perl
    Use 'apt-get autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    1 not fully installed or removed.
    After this operation, 0B of additional disk space will be used.
    Setting up firmware-b43legacy-installer (4.178.10.4-4) ...
    Not supported card here (PCI id 14e4:4315)!
    Use b43 firmware. This is just for the b43legacy driver.
    Aborting.
    dpkg: error processing firmware-b43legacy-installer (--configure):
    subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    firmware-b43legacy-installer
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    george@george-Satellite-A305:/$ cd ~/Desktop/
    george@george-Satellite-A305:~/Desktop$ wget http://media.cdn.ubuntu-de.org/forum...irmware.tar.gz

    --2012-04-09 12:46:02-- http://media.cdn.ubuntu-de.org/forum...irmware.tar.gz
    Resolving media.cdn.ubuntu-de.org... 213.95.41.13
    Connecting to media.cdn.ubuntu-de.org|213.95.41.13|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 99011 (97K) [application/octet-stream]
    Saving to: `2480236-Broadcom_Firmware.tar.gz'

    100%[======================================>] 99,011 194K/s in 0.5s

    2012-04-09 12:46:03 (194 KB/s) - `2480236-Broadcom_Firmware.tar.gz' saved [99011/99011]

    george@george-Satellite-A305:~/Desktop$ sudo tar xvf ./2480236-Broadcom_Firmware.tar.gz -C /lib/firmware/
    b43/
    b43legacy/
    b43/b0g0initvals5.fw
    b43/b0g0bsinitvals5.fw
    b43/a0g0initvals5.fw
    b43/a0g1initvals5.fw
    b43/a0g0bsinitvals5.fw
    b43/a0g1bsinitvals5.fw
    b43/b0g0initvals9.fw
    b43/b0g0bsinitvals9.fw
    b43/a0g0initvals9.fw
    b43/a0g1initvals9.fw
    b43/a0g0bsinitvals9.fw
    b43/a0g1bsinitvals9.fw
    b43/n0initvals11.fw
    b43/n0bsinitvals11.fw
    b43/n0absinitvals11.fw
    b43/lp0initvals13.fw
    b43/lp0bsinitvals13.fw
    b43/b0g0initvals13.fw
    b43/b0g0bsinitvals13.fw
    b43/a0g1initvals13.fw
    b43/a0g1bsinitvals13.fw
    b43/lp0initvals14.fw
    b43/lp0bsinitvals14.fw
    b43/lp0initvals15.fw
    b43/lp0bsinitvals15.fw
    b43/ucode5.fw
    b43/ucode9.fw
    b43/ucode11.fw
    b43/ucode13.fw
    b43/ucode14.fw
    b43/ucode15.fw
    b43/pcm5.fw
    b43legacy/a0g0bsinitvals5.fw
    b43legacy/b0g0initvals2.fw
    b43legacy/b0g0initvals5.fw
    b43legacy/b0g0bsinitvals2.fw
    b43legacy/a0g1initvals5.fw
    b43legacy/a0g0initvals2.fw
    b43legacy/a0g1bsinitvals5.fw
    b43legacy/a0g0initvals5.fw
    b43legacy/b0g0bsinitvals5.fw
    b43legacy/a0g0bsinitvals2.fw
    b43legacy/pcm5.fw
    b43legacy/pcm4.fw
    b43legacy/ucode11.fw
    b43legacy/ucode5.fw
    b43legacy/ucode4.fw
    b43legacy/ucode2.fw
    george@george-Satellite-A305:~/Desktop$ sudo modprobe b43
    george@george-Satellite-A305:~/Desktop$
    Last edited by gflam; April 9th, 2012 at 05:48 PM.

  8. #18
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    6,577
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Dell 1545 Wireless Won't Connect

    Reboot?

  9. #19
    Join Date
    Apr 2012
    Beans
    32

    Re: Dell 1545 Wireless Won't Connect

    well going to my bios required a reboot so i have rebooted numerous times but i'll do another just for kicks

    Edit
    After the reboot same thing it tries to connect but never connects to my wireless i just get the upwards wifi animation where it looks like it's going to connect and then it disconnects

    Edit 2
    Tried a few more things and then ran those commands you asked for last time so here's my updated info now

    george@george-Satellite-A305:/$ iwconfig
    lo no wireless extensions.

    eth2 no wireless extensions.

    wlan1 IEEE 802.11bg ESSID:"UDel"
    Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
    Tx-Power=20 dBm
    Retry long limit:7 RTS thrff Fragment thrff
    Power Managementff

    vmnet1 no wireless extensions.

    vmnet8 no wireless extensions.

    george@george-Satellite-A305:/$ lsmod
    Module Size Used by
    binfmt_misc 6599 1
    vmnet 42813 13
    vsock 39716 0
    vmci 67840 1 vsock
    vmmon 61066 0
    parport_pc 26058 0
    ppdev 5556 0
    snd_hda_codec_idt 54951 1
    arc4 1165 2
    b43 168681 0
    uvcvideo 55943 0
    joydev 8767 0
    snd_hda_intel 22235 2
    snd_hda_codec 87552 2 snd_hda_codec_idt,snd_hda_intel
    snd_hwdep 5040 1 snd_hda_codec
    snd_pcm 71475 2 snd_hda_intel,snd_hda_codec
    dell_wmi 2788 0
    videodev 43194 1 uvcvideo
    snd_seq_midi 4588 0
    v4l1_compat 13359 2 uvcvideo,videodev
    snd_rawmidi 17783 1 snd_seq_midi
    snd_seq_midi_event 6047 1 snd_seq_midi
    i915 296139 4
    snd_seq 47174 2 snd_seq_midi,snd_seq_midi_event
    mac80211 231959 1 b43
    drm_kms_helper 30200 1 i915
    snd_timer 19067 2 snd_pcm,snd_seq
    snd_seq_device 5744 3 snd_seq_midi,snd_rawmidi,snd_seq
    dell_laptop 5730 0
    drm 168124 4 i915,drm_kms_helper
    cfg80211 144758 2 b43,mac80211
    led_class 2633 1 b43
    dcdbas 5402 1 dell_laptop
    intel_agp 26566 2 i915
    i2c_algo_bit 5168 1 i915
    psmouse 59027 0
    snd 49102 13 snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_ hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_se q_device
    video 18712 1 i915
    serio_raw 4022 0
    output 1883 1 video
    agpgart 32011 2 drm,intel_agp
    soundcore 880 1 snd
    snd_page_alloc 7120 2 snd_hda_intel,snd_pcm
    lp 7342 0
    parport 31492 3 parport_pc,ppdev,lp
    usb_storage 40492 0
    ahci 19326 2
    ssb 39320 1 b43
    libahci 21728 1 ahci
    sky2 45127 0
    george@george-Satellite-A305:/$ sudo iwlist scan
    [sudo] password for george:
    lo Interface doesn't support scanning.

    eth2 Interface doesn't support scanning.

    wlan1 Interface doesn't support scanning : Device or resource busy

    vmnet1 Interface doesn't support scanning.

    vmnet8 Interface doesn't support scanning.

    george@george-Satellite-A305:/$ dmesg | egrep 'b43|wl'
    [ 1.097851] b43-pci-bridge 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
    [ 1.097864] b43-pci-bridge 0000:0c:00.0: setting latency timer to 64
    [ 22.086117] b43-phy0: Broadcom 4312 WLAN found (core revision 15)
    [ 22.162537] Registered led device: b43-phy0::tx
    [ 22.162557] Registered led device: b43-phy0::rx
    [ 22.162578] Registered led device: b43-phy0::radio
    [ 22.181574] udev[521]: renamed network interface wlan0 to wlan1
    [ 60.817255] b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
    [ 66.369354] b43-phy0 ERROR: Fatal DMA error: 0x00000400, 0x00000000, 0x00000000, 0x00000000, 0x00000000, 0x00000000
    [ 66.369361] b43-phy0 ERROR: This device does not support DMA on your system. Please use PIO instead.
    [ 66.369365] b43-phy0: Controller RESET (DMA error) ...
    [ 66.369373] b43-phy0 ERROR: Fatal DMA error: 0x00000400, 0x00000000, 0x00000000, 0x00000000, 0x00000000, 0x00000000
    [ 66.369377] b43-phy0 ERROR: This device does not support DMA on your system. Please use PIO instead.
    [ 66.369380] b43-phy0: Controller RESET (DMA error) ...
    [ 66.592449] b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
    [ 72.133297] b43-phy0: Controller restarted
    [ 72.142258] ADDRCONF(NETDEV_UP): wlan1: link is not ready
    [ 72.147477] bridge-wlan1: device is wireless, enabling SMAC
    [ 72.147481] bridge-wlan1: up
    [ 72.147483] bridge-wlan1: attached
    [ 72.157515] bridge-wlan1: disabling the bridge
    [ 72.168042] bridge-wlan1: down
    [ 72.168050] bridge-wlan1: detached
    [ 79.942255] wlan1: authenticate with 00:24:6c:0f:ef:e0 (try 1)
    [ 79.956036] wlan1: authenticated
    [ 79.956279] wlan1: associate with 00:24:6c:0f:ef:e0 (try 1)
    [ 80.153044] wlan1: associate with 00:24:6c:0f:ef:e0 (try 2)
    [ 80.193544] wlan1: RX AssocResp from 00:24:6c:0f:ef:e0 (capab=0x421 status=0 aid=8)
    [ 80.193548] wlan1: associated
    [ 80.194298] ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
    [ 86.786161] wlan1: authenticate with 00:24:6c:0f:ef:e0 (try 1)
    [ 86.984036] wlan1: authenticate with 00:24:6c:0f:ef:e0 (try 2)
    [ 87.184047] wlan1: authenticate with 00:24:6c:0f:ef:e0 (try 3)
    [ 87.388032] wlan1: authentication with 00:24:6c:0f:ef:e0 timed out
    [ 90.657014] wlan1: no IPv6 routers present
    george@george-Satellite-A305:/$ rfkill list
    0: dell-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    george@george-Satellite-A305:/$
    Last edited by gflam; April 9th, 2012 at 07:22 PM.

  10. #20
    Join Date
    Apr 2012
    Beans
    32

    Re: Dell 1545 Wireless Won't Connect

    Any other ideas praseodym or am i basically screwed? lol

    Would updating from 10.10 be a chance? i know support just ended for it but would that help my issue do you think?

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •