Results 1 to 4 of 4

Thread: Nvidia GeForce 740M driver installed but not in use

  1. #1
    Join Date
    Dec 2013
    Beans
    15

    Nvidia GeForce 740M driver installed but not in use

    I'm on an HP Envy 15 laptop that has two graphics cards. One is the standard Intel card, and the other is my Nividia GeForce 740M. I recently got the nvidia-current drivers for my laptop, and that worked, but when I launch my Nividia X Server settings program I get the following:

    Code:
    You do not appear to be using the NVIDIA X driver.  Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.
    So, naturally, I ran the: sudo nvidia-xconfig

    Well that hasn't helped me so far. Any help would be greatly appreciated.

  2. #2
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    11,965
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Nvidia GeForce 740M driver installed but not in use

    awhb87; Hi !

    an Intel/Nvidia hybrid card, and it is not officially supported by Nvidia. See this link here for installing the drivers: Switchable laptop graphics issues on Ubuntu 12.04?
    http://askubuntu.com/questions/16024...u-12-04/160310

    Ubuntu version 13.10 does have increased support for the switchable drivers> Else also look at:
    https://wiki.ubuntu.com/X/Config/HybridGraphics
    http://rudrageek.com/linux-now-suppo...s-ubuntu-13-10

    Older releses benefit from BumbleBee :
    https://wiki.ubuntu.com/Bumblebee
    http://www.webupd8.org/2013/04/bumbl...untu-1304.html

    Just try'n to help
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

  3. #3
    Join Date
    Dec 2013
    Beans
    15

    Re: Nvidia GeForce 740M driver installed but not in use

    I appreciate the advice Bashing-om, but I ran into some problems with bumblebee. I can run optirun glxspheres, but as soon as I try primusrun glxspheres, i get the following:

    Code:
    andrew@Hennessy-Linux:~$ primusrun glxspheres 
    Polygons in scene: 62464
    Visual ID of window: 0xfc
    Segmentation fault (core dumped)
    Just some extra info in case it's helpful; I'm running my grub in nomodeset, and I'm running the nvidia-331 open drivers.

    Any help would be appreciated.

  4. #4
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    11,965
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Nvidia GeForce 740M driver installed but not in use

    awhb87; Hey,

    Regret to say "primusrun" is out of my sphere of knowledge. Others will have to advise further.

    What I do not know fills a very large partition
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •