Quote Originally Posted by AgelessDrifter View Post
Here's the output of that command, idoit.

Partition table scan:
  MBR: MBR only
  BSD: not present
  APM: not present
  GPT: not present

Found invalid GPT and valid MBR; converting MBR to GPT format.

Disk /dev/sdb: 976773167 sectors, 465.8 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): F6B73A21-23A3-4C0E-BF70-A168B6BFD7ED
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 976773133
Partitions will be aligned on 2048-sector boundaries
Total free space is 2028 sectors (1014.0 KiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048          514047   250.0 MiB   0700  Linux/Windows data
   2          514048       976773119   465.5 GiB   0700  Linux/Windows data
"found invalid GPT and valid MBR makes me nervous. Any ideas what that's about?

I tried the drive on Windows 7. Windows found it. I tried installing gparted live on the drive through tuxboot on Windows, and that went off without a hitch, but when I rebooted, the Toshiba screen with "press F12 for boot menu" froze before I pressed anything.

I wiped the drive with gparted on linux, then reinstalled gparted live with tuxboot through windows again. Same result -- boot screen freezes immediately if the drive is plugged in.
no its fine. It either gpt or mbr. It says that it is a mbr partition table. So, I'm stump, however, why does it have 2 partitions? Does your harddrive have special hidden programs that is preventing linux tools to read it?