Page 1 of 6 123 ... LastLast
Results 1 to 10 of 52

Thread: rfkill unblock all, not working

  1. #1
    Join Date
    Feb 2012
    Beans
    139

    Exclamation rfkill unblock all, not working

    hey,
    so my wifi wont turn on, here is some rfkill outputs:
    Code:
    jake@jake-Compaq-Presario-CQ60-Notebook-PC:~$ rfkill list all
    0: hp-wifi: Wireless LAN
        Soft blocked: yes
        Hard blocked: yes
    1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    jake@jake-Compaq-Presario-CQ60-Notebook-PC:~$ rfkill unblock all
    jake@jake-Compaq-Presario-CQ60-Notebook-PC:~$ rfkill list all
    0: hp-wifi: Wireless LAN
        Soft blocked: yes
        Hard blocked: yes
    1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    jake@jake-Compaq-Presario-CQ60-Notebook-PC:~$ sudo rfkill unblock all
    [sudo] password for jake: 
    jake@jake-Compaq-Presario-CQ60-Notebook-PC:~$ rfkill list all
    0: hp-wifi: Wireless LAN
        Soft blocked: yes
        Hard blocked: yes
    1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    I can use a wired connection, but im trying to set up remote desktop sharing and i just want to do it over wifi, so i can sit on my couch and help my folks... anyways any help greatly appreciated, if i cant figure it out ill just have to make another ethernet cable, no big deal.
    1f u c4n r34d th1s u r34lly n33d t0 g37 l41d

  2. #2
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    21,062
    Distro
    Ubuntu Gnome Development Release

    Re: rfkill unblock all, not working

    Hi, these can be hard to fix but not all ways please try this:
    Code:
    echo "blacklist hp-wmi" | sudo tee -a /etc/modprobe.d/blacklist.conf
    Then disconnect your wired connection and reboot.
    Thanks

  3. #3
    Join Date
    Feb 2012
    Beans
    139

    Re: rfkill unblock all, not working

    So that kind of worked, I have Wireless enabled now, however I cannot connect to my network, I tried connecting to it as a hidden network and every few seconds now its asking me for my password but will not connect.
    1f u c4n r34d th1s u r34lly n33d t0 g37 l41d

  4. #4
    Join Date
    Feb 2012
    Beans
    139

    Re: rfkill unblock all, not working

    that is to say, it won't recognize any wireless networks, there are about ten that should "pop up" for selection.
    1f u c4n r34d th1s u r34lly n33d t0 g37 l41d

  5. #5
    Join Date
    Feb 2012
    Beans
    139

    Re: rfkill unblock all, not working

    Code:
    jake@jake-Compaq-Presario-CQ60-Notebook-PC:~$ iwlist wlan0 scan
    wlan0     No scan results
    any thoughts?
    1f u c4n r34d th1s u r34lly n33d t0 g37 l41d

  6. #6
    anewguy is offline I Ubuntu, Therefore, I Am
    Join Date
    Jun 2007
    Location
    Sometimes I visit earth
    Beans
    5,438
    Distro
    Ubuntu 12.04 Precise Pangolin

    Wink Re: rfkill unblock all, not working

    Post back the output of ifconfig and iwconfig inside the code tags (# on the menu bar) and we'll hopefully see a little more.

    A couple of things I'm curious about - is there a hardware switch/keyboard combo that is supposed to enable/disable the wireless radio? If so, be sure it is switched "on". Also, are you set for roaming mode so it will actually scan for network?

    I'm off for a little supper - be back on later.

    Dave

  7. #7
    Join Date
    Feb 2012
    Beans
    139

    Smile Re: rfkill unblock all, not working

    Ill get to the commands in a second, but for now, There is a hardware switch, however since i installed ubuntu, the switch hasn't worked, ive been using
    Code:
    ifconfig wlan0 up
    to turn the switch on, have had no problems before today.

    outputs:
    Code:
    jake@jake-Compaq-Presario-CQ60-Notebook-PC:~$ ifconfig
    eth0      Link encap:Ethernet  HWaddr 00:1f:16:6e:5f:5a  
              inet addr:192.168.1.18  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::21f:16ff:fe6e:5f5a/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:2558 errors:0 dropped:0 overruns:0 frame:0
              TX packets:2252 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:2714310 (2.7 MB)  TX bytes:393583 (393.5 KB)
              Interrupt:42 Base address:0x2000 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:8 errors:0 dropped:0 overruns:0 frame:0
              TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:480 (480.0 B)  TX bytes:480 (480.0 B)
    
    wlan0     Link encap:Ethernet  HWaddr 00:24:2b:a7:d2:9a  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    
    jake@jake-Compaq-Presario-CQ60-Notebook-PC:~$ iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    wlan0     IEEE 802.11bg  ESSID:off/any  
              Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
              
    jake@jake-Compaq-Presario-CQ60-Notebook-PC:~$
    Thanks for your help, again you guys are my hero's.
    1f u c4n r34d th1s u r34lly n33d t0 g37 l41d

  8. #8
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    21,062
    Distro
    Ubuntu Gnome Development Release

    Re: rfkill unblock all, not working

    Hi, please open a terminal ctrl+alt+t copy and paste the following commands into it one line at a time, then paste the results here:

    Also you should change your network so it can be seen, hidden is actually no more secure that is a myth.
    Code:
    cat /etc/lsb-release; uname -a
    lspci -nnk | grep -iA2 net
    nm-tool
    lsusb
    iwconfig
    rfkill list all
    lsmod
    Thanks
    Last edited by wildmanne39; March 25th, 2012 at 02:56 AM.

  9. #9
    anewguy is offline I Ubuntu, Therefore, I Am
    Join Date
    Jun 2007
    Location
    Sometimes I visit earth
    Beans
    5,438
    Distro
    Ubuntu 12.04 Precise Pangolin

    Wink Re: rfkill unblock all, not working

    Hey Jake5, I'm going to leave you with wildmanne39 - he really knows his stuff with this, and I'm still suffering from something dumb this week that aggravated a back injury. Laying in bed with a netbook, and to be honest pain, just isn't very conducive to me being helpful right now.

    I know they'll have you straightened around in no time!

    Dave

  10. #10
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    21,062
    Distro
    Ubuntu Gnome Development Release

    Re: rfkill unblock all, not working

    Hi anewguy, I know what you mean I have walking pnemonia so I am resting in between helping, I hope your back heals soon.

Page 1 of 6 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •