Results 1 to 7 of 7

Thread: "E: Unable to locate package" error

  1. #1
    Join Date
    Mar 2012
    Beans
    3

    "E: Unable to locate package" error

    I am trying to install some packages and using this command:
    Code:
    sudo apt-get install libkadm5clnt-mit7 libkadm5srv-mit7 libkdb5-4
    And here is the output I get:

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package libkadm5clnt-mit7
    E: Unable to locate package libkadm5srv-mit7
    E: Unable to locate package libkdb5-4

    I searched for these packages and found them on this page:

    http://packages.debian.org/source/squeeze/krb5

    How can I get them now?

  2. #2
    Join Date
    Dec 2009
    Beans
    13

    Re: "E: Unable to locate package" error

    Maybe those packages are only available in the Debian repos. I may be wrong though.

  3. #3
    Join Date
    Dec 2009
    Location
    Norway
    Beans
    24
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: "E: Unable to locate package" error


  4. #4
    Join Date
    May 2009
    Location
    Courtenay, BC, Canada
    Beans
    1,661

    Re: "E: Unable to locate package" error

    the packages in the Ubuntu repos are newer versions
    Code:
    tye@T:~$ aptitude search kadm
    p   libheimdal-kadm5-perl                                                                             - Perl module to administer a Heimdal Kerberos KDC                                                           
    p   libkadm5clnt-mit8                                                                                 - MIT Kerberos runtime libraries - Administration Clients                                                    
    p   libkadm5clnt7-heimdal                                                                             - Heimdal Kerberos - kadmin client library                                                                   
    p   libkadm5srv-mit8                                                                                  - MIT Kerberos runtime libraries - KDC and Admin Server                                                      
    p   libkadm5srv8-heimdal                                                                              - Libraries for Heimdal Kerberos                                                                             
    tye@T:~$ aptitude search kdb
    p   kdbg                                                                                              - graphical debugger interface                                                                               
    p   libdevel-ptkdb-perl                                                                               - Perl debugger using a Tk GUI                                                                               
    p   libkdb5-5                                                                                         - MIT Kerberos runtime libraries - Kerberos database                                                         
    tye@T:~$

  5. #5
    Join Date
    Jul 2011
    Beans
    3,037
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: "E: Unable to locate package" error

    It may be easier to tell us what you intend to achieve. Additionally, what mirrors are you using? I assume that you got the package names from a tutorial, but was this a tutorial based on Ubuntu? Package names can differ between Linux distributions.

  6. #6
    Join Date
    Mar 2012
    Beans
    3

    Re: "E: Unable to locate package" error

    Hi. I am following a tutorial and I have to install a lot of packages but only these three make a problem.

  7. #7
    Join Date
    Mar 2012
    Beans
    3

    Re: "E: Unable to locate package" error

    Quote Originally Posted by HiImTye View Post
    the packages in the Ubuntu repos are newer versions
    Code:
    tye@T:~$ aptitude search kadm
    p   libheimdal-kadm5-perl                                                                             - Perl module to administer a Heimdal Kerberos KDC                                                           
    p   libkadm5clnt-mit8                                                                                 - MIT Kerberos runtime libraries - Administration Clients                                                    
    p   libkadm5clnt7-heimdal                                                                             - Heimdal Kerberos - kadmin client library                                                                   
    p   libkadm5srv-mit8                                                                                  - MIT Kerberos runtime libraries - KDC and Admin Server                                                      
    p   libkadm5srv8-heimdal                                                                              - Libraries for Heimdal Kerberos                                                                             
    tye@T:~$ aptitude search kdb
    p   kdbg                                                                                              - graphical debugger interface                                                                               
    p   libdevel-ptkdb-perl                                                                               - Perl debugger using a Tk GUI                                                                               
    p   libkdb5-5                                                                                         - MIT Kerberos runtime libraries - Kerberos database                                                         
    tye@T:~$
    i am installing the newer versions as you indicated and will try if things work with them. thanks

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •