Page 1 of 4 123 ... LastLast
Results 1 to 10 of 38

Thread: Zoom 5510 ADSL USB Modem Install (UK)

  1. #1
    Join Date
    Apr 2006
    Location
    New Mills, UK
    Beans
    1,213

    Zoom 5510 ADSL USB Modem Install (UK)

    Zoom 5510A ADSL USB Modem Install
    (This is for the slim dark grey one issued in the UK by alot of providers [pictured below]. 5510-72 Mine says.
    May work with other Connexant Chip Modems, just compile and run cxacru-fw
    [see post #23 page 3] and put extracted file in the cxacru folder).

    If you have this model below you want the other howto at the link provided.


    https://wiki.ubuntu.com/UsbAdslModem/EagleUsb?highlight=%28eagle-usb%29
    This has been tested by zxc and works fine for this one.

    Please Note:
    youruserlogin
    is what you use to login to the actual connection, it can be in the form of your full e-mail address not just the username

    This was done on a Fresh Install of Ubuntu 6.06 "Dapper" and Ubuntu 6.10 "Edgy".
    Okay to start

    On an Internet Enabled OS or Machine

    Get the following file from the internet.
    CXACRU Extraction Utility
    http://homepage.ntlworld.com/malacandra/cxacru.zip
    I can't remember where I got this one from so I have put a copy here.
    This is the one with a pre-extracted (Windows) Zoom 5510A firmware file.
    If you have a Mac you will have to run the cxacru-fw program on the Mac driver file.
    I do not know if this will work as I do not own a Mac.
    If someone wants to attach the Mac file to this post I will include it in the zip file.

    Put it in a folder called "adslusb"(without the quotes) in the root of your machine.
    Also save this page to that folder as a ".complete" file

    If you are not dual booting you will have to burn the folder onto a CD-R or floppy.
    If you are dual booting with (I assume) Windows, when Back in Ubuntu mount your Windows Drive using "mount" in the root Terminal(described later).
    Get the DNS numbers for your ISP.
    These can be found in windows by typing
    Code:
    ipconfig /all
    in a Dos Box and scrolling to the section for the connected modem or phone ISP and ask them.

    Back in Ubuntu
    Login as normal user.
    I found this made life easier, saving having to type sudo in the terminal all the time.
    Run nautilus as root and gnome-terminal as root.
    Choose [Applications->Accessories->Alacarte Menu Editor], scroll down to [System Tools] and activate [Root Terminal] and [Run as Different User], Close.
    Choose [Applications->System Tools->Root Terminal], then Enter Password.
    Choose [Applications->System Tools->Run as different user], type "nautilus"(without the quotes) in the box.
    DO NOT CLOSE THESE UNTIL THE END.

    ------ Dual-Boot Hard Disk Section, if folder is on a CD-R or floppy miss this section out -----
    In Nautilus
    Go to Filesystem:/mnt/, right-click on space, choose "Create Folder" and call it "win".
    In Terminal
    If Windows drive is the first partition (1) on C: (hda) then this should be sufficient:
    Code:
    mount /dev/hda1 /mnt/win
    ----- End Section -----

    In Nautilus
    Go to FileSystem:/mnt/win/ or to the CD or to floppy.
    Right-click the folder "adslusb" and choose copy.
    Go to Filesystem:/usr/src/, right-click on space, choose "Paste".
    Choose "Bookmarks" in the top menu and "Add to Bookmarks", (This will aid with navigation later).
    Go to Filesystem: /usr/src/adslusb folder.
    Open cxacru-fw.zip
    Extract "cxacru-fw" folder to Filesystem: /usr/src
    (Using [Extract] choose "Other" in "Extract in Folder" pulldown
    Browse to Filesystem:/usr/src, Click [Open] then [Extract])


    In Terminal

    Code:
     cd /usr/src/cxacru-fw
     cp /usr/src/cxacru-fw/cxacru-fw.bin /lib/firmware/2.6.15-23-386/cxacru-fw.bin
    In Nautilus
    Go to folder Filesystem: /etc/network.
    Open file "interfaces".
    And insert the following at the bottom:
    Code:
    # The ADSL connection iface ppp0 inet ppp provider yourprovidername # enables ip forwarding (this is a gateway) pre-up echo 1 > /proc/sys/net/ipv4/ip_forward pre-up iptables-restore < /etc/iptables.up.rules auto ppp0
    -----------------------------------------------------------------------------------------------------------------------------------
    At this stage Reboot and when the boot messages get to "Configuring Network Interfaces......" start watching the green link light.
    It should flash repeatedly then eventually stay on.(This can take what seems like forever but persevere.)

    -----------------------------------------------------------------------------------------------------------------------------------
    Okay congratulations, you've gotten this far, hurrah. =D>

    Run nautilus as root and gnome-terminal as root.
    Choose [Applications->System Tools->Root Terminal], then Enter Password.
    Choose [Applications->System Tools->Run as different user], type "nautilus"(without the quotes) in the box.
    DO NOT CLOSE THESE UNTIL THE END.

    In Nautilus
    Go to Filesystem: /etc/ppp/peers folder.
    Create file yourprovidername (Right-Click: Create Document->Empty File).
    The only things in this file should be.
    Code:
     user "youruserlogin" (with the quotes this time)
     plugin pppoatm.so
    
    noipdefault usepeerdns defaultroute persist noauth nopcomp noccp novj

    Save and Exit
    Go to Filesystem: /etc/ppp folder
    Open the file "chap-secrets"
    Add a line
    Code:
     "youruserlogin * yourpassword"(without the quotes)
    Open the file "pap-secrets"
    And do the same.
    Rename the file "options" to "options.orig"(right-click choose "Rename").
    Create new file "options" and enter these values:
    Code:
     asyncmap 0
    
    auth crtscts lock hide-password modem proxyarp lcp-echo-interval 60 lcp-echo-failure 4 noipx replacedefaultroute noipdefault #noauth persist lcp-max-configure 50 -pap name any user "youruserlogin" (with the quotes this time) defaultroute plugin /usr/lib/pppd/2.4.4b1/pppoatm.so 0.38

    Create file "resolv.conf"(right-click on space, choose "Create Document"--->"Empty File")
    Open this file and add this:
    Code:
     nameserver xxx.xxx.xxx.xxx
     nameserver xxx.xxx.xxx.xxx
    Where xxx.xxx.xxx.xxx is replaced by your ISP DNS Servers.
    Go to /etc folder.
    Open the file "modules"
    Add a line:
    Code:
     "pppoatm"(without the quotes).
    Save and Exit.
    Create file "cxacru"(right-click on space, choose "Create Document"--->"Empty File")
    Open "/etc/cxacru" file and cut/paste this in to read like this.
    Code:
    #
    
    # Config file for Conexant AccessRunner # # Driver mode DRIVER_MODE=1 # 1 = normal, 2 = debug, 3 = normal+max speed (without ask adsl status), 4 = debug+max speed (without ask adsl status) # Protocol PROTOCOL_MODE=2 # 1 = RFC1483/2684 routed, 2 = PPP over ATM (pppoa), 3 = RFC1483/2684 bridged, 4 = PPP over Ethernet (pppoe) # Paths BINARY_PATH="/usr/sbin" ATM_PATH="" # ADSL # if OPEN_MODE is blank then cxload uses default mode acoording VID & PID # Values for OPEN_MODE are: # 0 = auto selection, G.Handshake # 1 = auto selection, T1.413 # 2 = G.Handshake # 3 = ANSI T1.413 # 4 = ITU-T G.992.1 (G.DMT) # 5 = ITU-T G.992.2 (G.LITE) OPEN_MODE= # ATM VPI=0 VCI=38 # Specific for RFC1483/2684 routed/bridged # if IP_ADDRESS is blank in bridged mode then it uses DHCP to get IP IP_ADDRESS= NETMASK=255.255.255.0 GATEWAY=

    Save and Exit.

    I would also get rid of the ntpdate check on boot as you aren't connected anyway.
    To do this choose System->Administration->Services and uncheck (ntpdate)

    REBOOT (Do not try dialing yet.)

    When you reboot and login type:
    In Terminal
    Code:
    pppd call yourprovidername
    And I hope it works for you as it did for me. Good Luck.

    ------------------------------------------------------------------------------------------------------------------------------------------
    Slight Addendum:
    Don't use kppp, gnome-ppp or System->Administration->Networking to change the PPP settings as it screws up the files for this connection.


    This is adapted from my original 5.10 "Breezy" HowTo and the process is much easier for "Dapper". One reason to upgrade.
    I re-did my entire install from scratch several times during doing this walkthrough to make sure it worked. Hopefully I didn't forget anything.

    It should work on a fresh install of "Dapper" and "Edgy", I can't vouch for anything else or if you have already altered your system from the default.

    This is for a UK broadband ISP so I don't know if it will work in other countries.

    Have Fun.

    P.S. If you want to let me know here if this worked for you or not it would be much appreciated
    Last edited by Malac; November 2nd, 2006 at 10:40 AM.
    Malac - "Time Is Precious, Waste It Wisely"
    Registered Linux User 416897
    Registered Ubuntu User 7567

  2. #2
    Join Date
    May 2005
    Location
    London, UK
    Beans
    28

    Re: Zoom 5510 ADSL USB Modem Install (UK)

    I wasn't sure what you meant by "yourusernamename"

    For example my username comes in the form:

    Myusername@tiscali.co.uk

    Do I include the whole thing or just myusername?...I included the whole thing throughout and it didn't seem to effect it (or turn up any errors).

    ---

    Anyway to my problem, I followed the tutorial and everything seemed fine except when the run:
    Code:
    sudo pppd call yourprovidername
    Plugin /usr/lib/pppd/2.4.4bl/pppoatk.so
    Plugin pppoatm.so loaded.
    pppd: In file /etc/ppp/peers/yourprovidername : unrecognised option '8.35'
    That option comes from the following line within yourprovidername:

    (Hash - I can't find it on this stupid Mac) VP.VC pair used by your ISP.
    8.35

    I tried changing it to 0.38 (which I think is the UK's VP/VC but I just got the same error except with 0.38. I also tried commenting this line out and I just got:

    Code:
    Plugin /usr/lib/pppd/2.4.4bl/pppoatk.so
    Plugin pppoatm.so loaded.
    Any my internet didn't work.

    After issuing the pppd call command should my internet work as my modem doesn't have the "Link" L.E.D shining?

    Thanks for all your hard work, it's greatly appreciated (and by the way this was done on a fresh Dapper Install).

  3. #3
    Join Date
    Apr 2006
    Location
    New Mills, UK
    Beans
    1,213

    Re: Zoom 5510 ADSL USB Modem Install (UK)

    Firstly:
    My Bad, I put the wrong folder in the copy command to load the firmware.
    I'm Really, Really Sorry.
    The section should read;(corrected section in bold).
    Code:
    cd /usr/src/cxacru-fw cp /usr/src/cxacru-fw/cxacru-fw.bin /lib/firmware/2.6.15-23-386/cxacru-fw.bin
    If you do not have the green link light shining constantly at any point then the modem is not loading the firmware.
    If the firmware isn't loaded then with the corrected steps then try the following as your machine is a Mac.
    --------
    I am running a PC so I used the cnxetu.sys file for windows to create the cxacru-fw.bin file so it will probably be a different driver file for a Mac.
    In which case you will have to run the cxacru-fw program with the Mac version driver file for the modem and use that created file.
    Get the file from the modem installation CD and put it in the cxacru-fw folder in /usr/src.
    Go to the cxacru-fw folder in terminal:
    Code:
    cd /usr/src/cxacru-fw
    And type in:
    Code:
    ./cxacru-fw [NameofMacDriverFile] cxacru-fw.bin
    This will create a new cxacru-fw.bin file.
    Then put the created file in /lib/firmware/2.6.15-23-386 and /lib/hotplug/firmware.
    Then Reboot.
    Until you get the green light constantly lit there is no point doing any of the other steps.
    I have altered the howto to reflect this.

    Secondly:

    Note This section from the howto:
    Go to Filesystem: /etc/ppp/peers folder.
    Open the file yourprovidername by double clicking on it.
    Change the "user=you@yourrealm" field to:


    Code:
    "user=yourusername@yourprovidername"(without the quotes)

    The only other things in this file should be.

    Code:
    plugin pppoatm.so noipdefault usepeerdns defaultroute persist noauth nopcomp noccp novj

    Save and Exit

    Delete anything else or put a # infront of it to comment it out.
    The 8.35 should be 0.38 for the UK but you don't need this either so delete or # it out.

    If a line
    Code:
    connect "/usr/sbin/chat -v -f /etc/chatscripts/yourprovidername"
    or
    Code:
    /dev/modem
    115200
    is at the bottom, delete or # those as well.

    Sorry should have made this clearer in the howto.

    Once again do not use kppp, gnome-ppp or [System->Administration->Networking ]
    or you will get these sorts of errors as they change the /etc/ppp/peers/yourprovidername file.

    If still not working; double check all files listed in the howto are the same on your system, if that does not throw up any mistakes post the files here (minus sensitive info i.e. password/username) and I will give them a scan.

    Hope this helps and all is working with these changes.
    Last edited by Malac; June 14th, 2006 at 09:52 AM.
    Malac - "Time Is Precious, Waste It Wisely"
    Registered Linux User 416897
    Registered Ubuntu User 7567

  4. #4
    Join Date
    May 2005
    Location
    London, UK
    Beans
    28

    Re: Zoom 5510 ADSL USB Modem Install (UK)

    I'm only using a borrowed Mac laptop to access the internet while my Ubuntus internet isn't set up (Ubuntu is running on a PC).

    I'm doing a fresh install and trying this tonight. Thanks again for your patience.

    Edit:Failed again, modem wouldn't initialise (the Link L.E.D doesn't light up at all). I'm assuming this is driver side and not much can be done to rectify it.

    Thanks for all your help but I think I'm going to surrender to Windows.
    Last edited by zxc; June 14th, 2006 at 01:25 AM.

  5. #5
    Join Date
    Apr 2006
    Location
    New Mills, UK
    Beans
    1,213

    Re: Zoom 5510 ADSL USB Modem Install (UK)

    Okay I am going to do a full install again from scratch just to get the green link light on.
    Then post a "walkthrough" of just that process to see if that helps.
    If the modem is actually working then there should be no reason this howto shouldn't work. If you can try it in windows to check that would be cool.

    Is the modem detected in Ubuntu, [System->Administration->Device Manager], if not then I would suspect a dodgy USB cable even if the power light is on.

    I've attached a screenshot of how my device manager looks, in case you don't know what to look for.

    If not, try plugging it into a different USB port.
    Or if it is plugged into a USB add-in PCI Card try the ones usually built on to the motherboard.
    It could be the PCI card is the problem.

    If you type
    Code:
    dmesg
    into terminal after unplugging and re-plugging the modem you should see something similar to this:
    Code:
    [4295553.943000] usb 2-2: USB disconnect, address 3
    [4295555.399000] usb 2-2: new full speed USB device using uhci_hcd and address 4
    [4295557.769000] cxacru 2-2:1.0: found firmware cxacru-fw.bin
    Stick with it don't surrender to the lure of Windows.
    The feeling of triumph when it finally works is worth it.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Device Manager.png 
Views:	94 
Size:	133.0 KB 
ID:	11196  
    Last edited by Malac; June 14th, 2006 at 10:16 AM.
    Malac - "Time Is Precious, Waste It Wisely"
    Registered Linux User 416897
    Registered Ubuntu User 7567

  6. #6
    Join Date
    Apr 2006
    Location
    New Mills, UK
    Beans
    1,213

    Re: Zoom 5510 ADSL USB Modem Install (UK)

    Okay just changed the howto order so you aren't doing extra stuff before checking the link light is working.

    I did a fresh install and followed these steps and the link light worked first time.
    Give this a try then resume howto after the Reboot Section if all is well.
    Before commencing check the Red "Pwr" light is on if not then modem not working, check your USB connection, otherwise, carry on.

    --------------------------------------------------------------------------------------------------
    Login as normal user.
    Run nautilus as root and gnome-terminal as root.
    Choose [Applications->Accessories->Alacarte Menu Editor], scroll down to [System Tools] and activate [Root Terminal] and [Run as Different User], Close.
    Choose [Applications->System Tools->Root Terminal], then Enter Password.
    Choose [Applications->System Tools->Run as different user], type "nautilus"(without the quotes) in the box.
    DO NOT CLOSE THESE UNTIL THE END.

    ------ Dual-Boot Hard Disk Section, if folder is on a CD-R or floppy miss this section out -----
    In Nautilus
    Go to Filesystem:/mnt/, right-click on space, choose "Create Folder" and call it "win".
    In Terminal
    If Windows drive is the first partition (1) on C: (hda) then this should be sufficient:
    Code:
    mount /dev/hda1 /mnt/win
    ----- End Section -----

    In Nautilus
    Go to FileSystem:/mnt/win/ or to the CD or to floppy.
    Right-click the folder "adslusb" and choose copy.
    Go to Filesystem:/usr/src/, right-click on space, choose "Paste".
    Go to Filesystem: /usr/src/adslusb folder.
    Open cxacru-fw.zip
    Extract "cxacru-fw" folder to Filesystem: /usr/src
    (Using [Extract] choose "Other" in "Extract in Folder" pulldown
    Browse to Filesystem:/usr/src, Click [Open] then [Extract])


    In Terminal
    Code:
     cd /usr/src/cxacru-fw
     cp /usr/src/cxacru-fw/cxacru-fw.bin /lib/firmware/2.6.15-23-386/cxacru-fw.bin
    In Nautilus
    Go to folder Filesystem: /etc/network.
    Open file "interfaces".
    And insert the following at the bottom:
    Code:
    # The ADSL connection iface ppp0 inet ppp provider yourprovidername # enables ip forwarding (this is a gateway) pre-up echo 1 > /proc/sys/net/ipv4/ip_forward pre-up iptables-restore < /etc/iptables.up.rules auto ppp0


    Reboot
    -----------------------------------------------------------------------------------------------------------------------------------

    Let me know what happens.
    Last edited by Malac; June 14th, 2006 at 10:45 AM.
    Malac - "Time Is Precious, Waste It Wisely"
    Registered Linux User 416897
    Registered Ubuntu User 7567

  7. #7
    Join Date
    May 2005
    Location
    London, UK
    Beans
    28

    Re: Zoom 5510 ADSL USB Modem Install (UK)

    Ok still not working (the link light) but before and after your latest process I did dmesg and instead of showing info about cxacru it seemed to mention lots about eagle-usb (both before and after) and I think it was loading eagle-usb firmware :S.

  8. #8
    Join Date
    Apr 2006
    Location
    New Mills, UK
    Beans
    1,213

    Re: Zoom 5510 ADSL USB Modem Install (UK)

    That's weird as eagle-usb stuff isn't installed by default when I do a fresh install.
    The eagle stuff definitely does not work with this modem that is one of the ones I tried with no success.
    Check in Synaptic and uninstall, it if it is listed.
    Did you note the corrected location for the cxacru-fw.bin file in folder /lib/firmware/2.6.15-23-386 not just /lib/firmware ?

    I can't see why this would not be working from a fresh install for you but it does for me every time.
    It is only two steps after the fresh install when all you get is the red "PWR" light.
    1/. Put 'cxacru-fw.bin' in folder.
    2/. Change 'interfaces' file and the green light comes on after rebooting.

    I can only assume something else is interfering with the process on your system which is not on mine.
    Either another usb device or I have read on one of the forums a sound module, "dabusb", can interfer with some usb modems.
    Perhaps your system uses this.

    Just to double check this is the slim dark grey Zoom 5510 you have not the white squarish one. For that one you need the eciadsl package.
    Last edited by Malac; June 14th, 2006 at 08:40 PM.
    Malac - "Time Is Precious, Waste It Wisely"
    Registered Linux User 416897
    Registered Ubuntu User 7567

  9. #9
    Join Date
    May 2005
    Location
    London, UK
    Beans
    28

    Re: Zoom 5510 ADSL USB Modem Install (UK)

    Yup, it's the dark *cursed* grey 5510. (looks like http://images.amazon.com/images/P/B0...T.LZZZZZZZ.jpg)

    And in Synaptic Eagle-usb isn't even installed.

    And I've copied and pasted the commands so I don't think there's going to be an error there (I did the corrected one for sure).

    I pulled out all my Printers USBs so it's just my modem and my Flash Memory stick.

    I'm not giving up quite yet...I'll probably try the reinstall a couple of times and hope for a miracle .

  10. #10
    Join Date
    Apr 2006
    Location
    New Mills, UK
    Beans
    1,213

    Re: Zoom 5510 ADSL USB Modem Install (UK)

    Okay the picture you linked to is not the same as my modem.
    My modem is modem1.png
    I think yours may be a moderner version of the modem2.png
    in which case the eciadsl drivers may work for you here is the URL
    http://eciadsl.flashtux.org/

    Give that a try.
    If not you will almost definitely have to run the cxacru-fw program on the driver file from your install CD that came with that modem.

    If it is trying to install the eagle drivers by default it may be that they are the right drivers for your modem.
    The latest version is available through sourceforge.net or try the synaptic ones.
    Keep at it.

    Please let me know when, not if, you succeed.
    And good luck any help I can offer, I will.


    For others reading this:
    modem3.png should work with latest eagle drivers from sourceforge.net
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	modem1.png 
Views:	551 
Size:	19.4 KB 
ID:	11219   Click image for larger version. 

Name:	modem2.png 
Views:	67 
Size:	11.9 KB 
ID:	11220   Click image for larger version. 

Name:	modem3.png 
Views:	62 
Size:	35.8 KB 
ID:	11257  
    Last edited by Malac; June 15th, 2006 at 11:12 AM.
    Malac - "Time Is Precious, Waste It Wisely"
    Registered Linux User 416897
    Registered Ubuntu User 7567

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •