Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Installing Epiphany

  1. #1
    Join Date
    Mar 2011
    Location
    Texas
    Beans
    30
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Installing Epiphany

    Okay. So for the past three hours I've been trying to install Epiphany 3.3.90.. With no success I'd decided to go to the awesome community Now I'm running Ubuntu 11.10 x64 with Gnome 3.2.

    Now I've tried the whole "sudo ./configure" then "make" then "make install" but it doesn't work. I get
    make: *** No rule to make target `install'. Stop.
    Here is where I got it from, the .tar.xz
    http://ftp.acc.umu.se/pub/GNOME/sources/epiphany/3.3/

    Anyhow if anyone could assist me and guide me through the install, that'd be really great!

  2. #2
    Join Date
    Mar 2007
    Location
    Portsmouth, UK
    Beans
    Hidden!
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Installing Epiphany

    It looks like it has an installation script included:

    Code:
    chmod +x install-sh
    ./install-sh

  3. #3
    Join Date
    Mar 2011
    Location
    Texas
    Beans
    30
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Installing Epiphany

    hmm after I tried the './install-sh' and it gave me this
    ./install-sh: no input file specified.

  4. #4
    Join Date
    Mar 2007
    Location
    Portsmouth, UK
    Beans
    Hidden!
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Installing Epiphany

    My bad then!

    What happens when you don't use sudo with configure? Generally you only need root rights for make install, so perhaps it's got nothing to make because the output of configure was root-rights-only.
    Last edited by Grenage; March 13th, 2012 at 10:02 AM. Reason: Additional.

  5. #5
    Join Date
    Mar 2011
    Location
    Texas
    Beans
    30
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Installing Epiphany

    Well, './configure' works but it errors at the end with:
    checking for intltool >= 0.40.0... ./configure: line 13221: intltool-update: command not found
    found
    configure: error: Your intltool is too old. You need intltool 0.40.0 or later.
    but I don't know how to update it.

  6. #6
    Join Date
    Mar 2007
    Location
    Portsmouth, UK
    Beans
    Hidden!
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Installing Epiphany

    Google is your friend.

    http://ubuntuforums.org/showpost.php...30&postcount=3

    Have you checked to see if there is a repository you could use? It would probably make installation somewhat easier if you could just 'apt-get install epiphany'.

  7. #7
    Join Date
    Mar 2011
    Location
    Texas
    Beans
    30
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Installing Epiphany

    Yeah, but it installs some old version. I think 3.2 :'(

  8. #8
    Join Date
    Mar 2007
    Location
    Portsmouth, UK
    Beans
    Hidden!
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Installing Epiphany

    Add the repository:

    Code:
    sudo add-apt-repository ppa:webkit-team/ppa
    sudo add-apt-repository ppa:webkit-team/epiphany
    If epiphany is installed:

    Code:
    sudo apt-get update && sudo apt-get upgrade
    If it is not installed:

    Code:
    sudo apt-get install epiphany-browser epiphany-browser-dataepiphany-extensions
    Last edited by Grenage; March 13th, 2012 at 10:25 AM. Reason: Oops

  9. #9
    Join Date
    Mar 2011
    Location
    Texas
    Beans
    30
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Installing Epiphany

    lol, that's empathy, I need epiphany, the web browser..

  10. #10
    Join Date
    Mar 2007
    Location
    Portsmouth, UK
    Beans
    Hidden!
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Installing Epiphany

    Quote Originally Posted by TexasRussian View Post
    lol, that's empathy, I need epiphany, the web browser..
    *cough*

    I changed the post.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •