Results 1 to 3 of 3

Thread: Virtualbox

  1. #1
    Join Date
    Feb 2012
    Beans
    3

    Virtualbox

    I installed Oracle VM VirtualBox in my computer pc having Win 7 Ultimate OS and connected to a LAN. I then installed Ubuntu 11.04 desktop inside VirtualBox to allow file sharing using Samba. I followed steps/tutorial below from Ubuntu website to configure Samba, however I cannot view this Ubuntu pc when I browse the nework .

    What could be possibly went wrong ? I really need help on this.

    This is the whole tutorial I tried to follow with no luck
    Setup Samba Server In Ubuntu
    This tutorial will I will be teaching you how to setup Samba Server on Ubuntu. Using a Samba Server to share files between your Ubuntu and Windows computers, this is one of the best and easiest ways to accomplish this. So lets get started and install the required packages by running the following command.
    sudo apt-get install samba
    This should install the required packages however we still need to configure Samba Server so lets open up smb.conf in gedit.
    sudo gedit /etc/samba/smb.conf
    Now lets change the following two values in the Samba Server config.
    workgroup = WORKGROUP
    At the bottom of the Samba Server config add this and modify it to your needs.
    [share]
    comment = Ubuntu File Server Share
    path = /srv/samba/share
    browsable = yes
    guest ok = yes
    read only = no
    create mask = 0755

    Now all thats left is to create the Samba Server directory and restart the Samba Services, simply go into an open Terminal and run the following commands.
    sudo mkdir -p /srv/samba/share
    sudo chown nobody.nogroup /srv/samba/share/
    sudo restart smbd
    sudo restart nmbd

    Congrats! You now have a fully functional Ubuntu Samba Server!

  2. #2
    Join Date
    Apr 2008
    Location
    LOCATION=/dev/random
    Beans
    5,767
    Distro
    Ubuntu Development Release

    Re: Virtualbox

    I think you need to set up the network settings in VirtualBox to give your VM a Bridged network connection instead of NAT (which is the default).
    Cheesemill

  3. #3
    Join Date
    Jun 2011
    Location
    The Shadow Gallery
    Beans
    6,807

    Re: Virtualbox

    Quote Originally Posted by Cheesemill View Post
    I think you need to set up the network settings in VirtualBox to give your VM a Bridged network connection instead of NAT (which is the default).
    +1

    You need to configure bridged networking so your VM is on your actual network either via DHCP or preferably a static IP valid for your LAN.

    cheers
    Feel Free to Bitcoin Tip: 135Rp4pwwYTHEJ4u8bxKaDQiC91N9LUoV2

    Backtrack - Giving machine guns to monkeys since 2006
    Kali-Linux - Adding a grenade launcher to the machine guns since 2013

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •