Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 44

Thread: Trying to optimize resolution

  1. #31
    Join Date
    Nov 2008
    Location
    Omicron Persei 8
    Beans
    Hidden!

    Re: Trying to optimize resolution

    Should it not be

    Code:
    cvt 1920 1080
    Which has generated the following for you

    "1920x1080_60.00" 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync

    Then,

    Code:
    xrandr --newmode "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsyn
    Then, (note the quotes, which you didn't have)

    Code:
    xrandr --addmode CRT1 "1920x1080_60.00"
    Then

    Code:
    xrandr --output CRT1 --mode "1920x1080_60.0"
    Last edited by chamber; May 10th, 2012 at 04:08 PM. Reason: fixed typo
    "All right amatuer hour's over. Let me show you why they call me the Velour Fog...."
    .:GitHub:.|.:Dropbox:.

  2. #32
    Join Date
    Dec 2010
    Beans
    Hidden!

    Re: Trying to optimize resolution

    Quote Originally Posted by chamber View Post
    Should it not be

    Code:
    cvt 1920 1080
    Which has generated the following for you

    "1920x1080_60.00" 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync

    Then,

    Code:
    xrandr --newmode "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsyn
    Then, (note the quotes, which you didn't have)

    Code:
    xrandr --addmode CRT1 "1920x1080_60.00"
    Then

    Code:
    xrandr --output CRT1 --mode "1920x1080_60.0"
    Hi,

    See the opening post


    404

  3. #33
    Join Date
    Nov 2008
    Location
    Omicron Persei 8
    Beans
    Hidden!

    Re: Trying to optimize resolution

    Quote Originally Posted by not found View Post
    Hi,

    See the opening post


    404
    I did indeed see the opening post.

    You had

    xrandr --addmode CRT1 1920x1080_60.00

    I suggested

    xrandr --addmode CRT1 "1920x1080_60.00"

    notice the quotations in red.
    "All right amatuer hour's over. Let me show you why they call me the Velour Fog...."
    .:GitHub:.|.:Dropbox:.

  4. #34
    Join Date
    Dec 2010
    Beans
    Hidden!

    Re: Trying to optimize resolution

    Quote Originally Posted by chamber View Post
    I did indeed see the opening post.

    You had

    xrandr --addmode CRT1 1920x1080_60.00

    I suggested

    xrandr --addmode CRT1 "1920x1080_60.00"

    notice the quotations in red.
    Code:
    nlsthzn@circle:~$ xrandr --newmode "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsyn
    nlsthzn@circle:~$ xrandr --addmode CRT1 "1920x1080_60.00"
    X Error of failed request:  BadMatch (invalid parameter attributes)
      Major opcode of failed request:  157 (RANDR)
      Minor opcode of failed request:  18 (RRAddOutputMode)
      Serial number of failed request:  49
      Current serial number in output stream:  50
    nlsthzn@circle:~$
    Getting the same error still... thanks for the assistance.


    404

  5. #35
    Join Date
    Nov 2008
    Location
    Omicron Persei 8
    Beans
    Hidden!

    Re: Trying to optimize resolution

    Have you tried modifying your /etc/X11/xorg.conf so that it displays the following, you had previously mentioned about just changing the preferred mode but what about adding the Modeline to it?

    Code:
    Section "Monitor"
    	Identifier "aticonfig-Screen[0]-0"
        Modeline        "1920x1080_60.00" 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync
        Option          "PreferredMode" "1920x1080_60.00"
    EndSection
    "All right amatuer hour's over. Let me show you why they call me the Velour Fog...."
    .:GitHub:.|.:Dropbox:.

  6. #36
    Join Date
    Dec 2010
    Beans
    Hidden!

    Re: Trying to optimize resolution

    Quote Originally Posted by chamber View Post
    Have you tried modifying your /etc/X11/xorg.conf so that it displays the following, you had previously mentioned about just changing the preferred mode but what about adding the Modeline to it?

    Code:
    Section "Monitor"
    	Identifier "aticonfig-Screen[0]-0"
        Modeline        "1920x1080_60.00" 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync
        Option          "PreferredMode" "1920x1080_60.00"
    EndSection
    I have not tried that... will do once I am home again, thanks.


    404

  7. #37
    Join Date
    Apr 2012
    Beans
    6

    Angry Re: Trying to optimize resolution

    I'm having the exact same problem with the same monitor brand
    still using windows only because of this... And I've tried almost everything.. (Thinking about buying a new monitor just to use linux?)
    Please help, my card is the 6950
    Last edited by lukax; May 15th, 2012 at 05:13 PM.

  8. #38
    Join Date
    May 2010
    Location
    uk
    Beans
    9,324
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Trying to optimize resolution

    Hi

    Interesting thread. It seems fglrx is a right pain to use a custom EDID with.

    Radeon is not so much of a problem. Any reason you cannot use the radeon driver ?

    Anyway, take a read of this.

    http://ati.cchtml.com/show_bug.cgi?id=415

    Comment 2 may suggest a way to use a binary custom EDID for fglrx. I cannot comment on it though.

    Kind regards
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

    Thinking about becoming an Ubuntu Member?

  9. #39
    Join Date
    Apr 2012
    Beans
    6

    Re: Trying to optimize resolution

    Thank you for your reply, I'm going to try that right now

  10. #40
    Join Date
    Apr 2012
    Beans
    6

    Wink Re: Trying to optimize resolution

    OMG!!1 I can`t believe it worked!!?
    this is what I did:

    1: Extract the edid with the Phoenix tool in Windows
    2: boot ubuntu with the option "nomodeset" right after "splash quiet" without this option your screen is gonna go out of range
    3: Install ubuntu
    4: boot ubuntu again with the option "nomodeset"
    5: Download and install ATI's driver
    6: Before reboot, Open up terminal and type "aticonfig --initial"
    7: reboot with the option "text" right after "splash quiet"
    8: copy the edid extracted from Windows to /etc/ati/
    9: rename edid.raw to "your output".edid, mine was crt1 therefore crt1.edid
    10: be happy enjoying this great OS with your awesome resolution

    EDIT:
    Attached my monitor's edid, it works for 1920x1080@60Hz
    Attached Files Attached Files
    Last edited by lukax; May 15th, 2012 at 10:54 PM.

Page 4 of 5 FirstFirst ... 2345 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •