Results 1 to 8 of 8

Thread: Problems with USB since update

  1. #1
    Join Date
    Mar 2012
    Beans
    2

    Problems with USB since update

    Hi,
    i recently did an update (march 9th 2012) and after rebooting the system all USB devices aren't working anymore.

    I get the following message in /var/log/syslog when i plug in my mouse or keyboard

    PHP Code:
    Mar  9 10:19:37 steib kernel: [ 1129.756345usb 3-1: new full speed USB device number 10 using xhci_hcd
    Mar  9 10
    :19:37 steib kernel: [ 1129.756441usb 3-1Device not responding to set address.
    Mar  9 10:19:37 steib kernel: [ 1129.960151usb 3-1Device not responding to set address.
    Mar  9 10:19:38 steib kernel: [ 1130.163803usb 3-1device not accepting address 10error -71 
    I'm using Ubuntu 11.10 on a Dell Vostro V131

    I hope someone can help me.

    best regards and thanks,
    Timo

  2. #2
    Join Date
    Dec 2010
    Location
    Bangalore
    Beans
    118
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Problems with USB since update

    Install xorg
    sudo apt-get install xserver-xorg
    sudo apt-get install xserver-xorg-core
    if it is already installed
    Reconfigure xorg
    sudo dpkg-reconfigure xserver-xorg

    if it does not help,
    try to "fix broken packages" in Recovery mode.

  3. #3
    Join Date
    May 2010
    Location
    uk
    Beans
    9,374
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Problems with USB since update

    Hi

    Do the devices start working if you boot into an older kernel ? Do they work from a LiveCD/USB. Just trying to eliminate hardware.

    Kind regards
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

    Thinking about becoming an Ubuntu Member?

  4. #4
    Join Date
    Sep 2008
    Beans
    7

    Re: Problems with USB since update

    This is not a hardware issue, as the same thing happened to me after updating this morning. My USB wireless connection suddenly gave out, and after rebooting, I lost my USB mouse and keyboard as well.

    After running "sudo dpkg-reconfigure xserver-xorg" and waiting a couple minutes, the mouse and keyboard show up again under "lsusb". However, it takes another minute or two before they begin to work, and I still have not figured out how to regain connection through my USB wireless dongle.

    In other words, since the update this morning, my Ubuntu desktop is pretty useless. I'm running an eMachines EL1358G desktop.

    EDIT/UPDATE: I unplugged and re-plugged in my USB wireless dongle and I am connected to the internet again. Not sure what's going on here.
    Last edited by tmeitner; March 9th, 2012 at 05:43 PM. Reason: Updated information.

  5. #5
    Join Date
    May 2010
    Location
    uk
    Beans
    9,374
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Problems with USB since update

    Hi

    Are these USB 3 controllers ?

    Kind regards
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

    Thinking about becoming an Ubuntu Member?

  6. #6
    Join Date
    Sep 2008
    Beans
    7

    Re: Problems with USB since update

    Quote Originally Posted by matt_symes View Post
    Hi

    Are these USB 3 controllers ?

    Kind regards
    Nope - these are all USB 2. They all worked out-of-the-box (and actually, with several Ubuntu versions) before this morning's update.

  7. #7
    Join Date
    May 2010
    Location
    uk
    Beans
    9,374
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Problems with USB since update

    Hi

    Are the USB drivers being bound correctly to the kernel ?

    http://lwn.net/Articles/143397/

    Kind regards
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

    Thinking about becoming an Ubuntu Member?

  8. #8
    Join Date
    Mar 2012
    Beans
    2

    Re: Problems with USB since update

    yeah "sudo dpkg-reconfigure xserver-xorg" worked for me as well. Thanks!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •