Results 1 to 4 of 4

Thread: Screen Not Dimming?

  1. #1
    Join Date
    Jan 2012

    Screen Not Dimming?

    Okay, so i hope i dont get alot of flak for this, but here it goes;

    I'm on Linux Mint 12, and all the sudden, my screen cant dim or be brightened via the dedicated buttons or the settings manager.

    My setup: Lenovo ThinkPad T420, Nvidia NVS 4200M

    I think maybe the Nvidia drivers i installed may have messed up the brightness somehow? My best guess is that i need to edit either the xorg.conf or the xorg.conf.nvidia

    Once again, sorry for posting here, as i know it's Ubuntu forums, but I didnt get any support from the Mint forums, and i said, "Hey, we're all family! We all come from debian! Ubuntu is like Mints brother!"

    So thanks for any support!

  2. #2
    Join Date
    Jan 2012

    Re: Screen Not Dimming?

    Solved my own n00b question!

    So you just need to insert a small line of code under the Devices section of either the xorg.conf or the xorg.conf.nvidia. I didnt know which one to edit, so i edited both, and all works good now! Credit

    A bug cropped up for some with recent nvidia driver causing brightness controls not to work (For example, on my W520 using the nvidia binary driver). The solution seems to be adding a flag to enable brightness control by the nvidia driver
    # Add to your "Device" section in /etc/X11/xorg.conf and restart X
     Option "RegistryDwords" "EnableBrightnessControl=1"

  3. #3
    Join Date
    Oct 2004
    Denmark - Scandinavia
    Ubuntu 18.04 Bionic Beaver

    Re: Screen Not Dimming?

    Moved to Other OS/Distro Talk.
    | AMD Ryzen 1700x 3.4 GHz | ASUS PRIME X370-A | 32 GB 2400 Mhz DDR4 |
    | ASUS Nvidia 1070 8 GB | SSD 250 GB | HDD 1 TB |

    My Blog:

    Try elementary OS -

  4. #4
    Join Date
    Dec 2012

    Re: Screen Not Dimming?

    Never mind
    Last edited by loomes8; December 16th, 2012 at 10:21 AM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts