Page 89 of 89 FirstFirst ... 3979878889
Results 881 to 882 of 882

Thread: AMD/Intel Hybrid Graphics works

  1. #881
    Join Date
    Apr 2015

    Re: AMD/Intel Hybrid Graphics works

    excellent post

  2. #882
    Join Date
    Jul 2015

    Re: AMD/Intel Hybrid Graphics works

    For the life of me I cannot seem to make the integrated Intel card work properly.
    I own an HP Pavillion DV7 with and AMD Radeon HD 6730M/6770M/7690M XT (according to lspci) and integrated Intel graphics card running an Ubuntu 14.04 installation.

    I don't care for discreet graphics card: I just want the Intel card working so the cooling fan shuts de f*** up.

    The thing is I had this system working properly before but since last fglrx-updates installation Intel card won't work properly (AMD works fine but raises the temp).

    glxinfo says "Error: couldn't find RGB GLX visual or fbconfig" when switching to Intel through AMD control panel.

    Anyone knows what can I do? Is there a way to disable the AMD card without installing fglrx?

    Thanks in advance.
    Ps: What a mess is this AMD/Intel/Ubuntu thing...

    UPDATE with more info:
    grep EE /var/log/Xorg.0.log shows this (when starting with Intel card enabled):
    (II) LoadModule: "glx"
    [ 3.803] (II) Loading /usr/lib/xorg/modules/extensions/
    [ 3.805] (II) Module glx: vendor="X.Org Foundation"
    [ 3.805] compiled for 1.14.3, module version = 1.0.0
    [ 3.805] ABI class: X.Org Server Extension, version 7.0
    [ 3.805] (EE) module ABI major version (7) doesn't match the server's version (8)
    [ 3.805] (II) UnloadModule: "glx"
    [ 3.805] (II) Unloading glx
    [ 3.805] (EE) Failed to load module "glx" (module requirement mismatch, 0)

    Any clues? Can't seem to find the exact problem when I google it...

    UPDATE. This solved my problem:
    Purge fglrx. Then (and this was the important part for me):
    sudo apt-get install --reinstall xserver-xorg-core
    Then installing fglrx again.

    Why reinstall xserver-xorg-core? Because this is the package that contains the file /usr/lib/xorg/modules/extensions/

    Don't know what happened on the first place but this is what worked for me.
    Last edited by marcsabat; March 5th, 2016 at 06:01 PM.

Page 89 of 89 FirstFirst ... 3979878889

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts