Page 85 of 89 FirstFirst ... 35758384858687 ... LastLast
Results 841 to 850 of 882

Thread: AMD/Intel Hybrid Graphics works

  1. #841
    Join Date
    Nov 2013

    Re: AMD/Intel Hybrid Graphics works

    I was delighted to hear that support was finally here for hybrid graphics cards. My Dell 7520 (15r SE) has been useless to me without being able to run linux adequately.

    I'm having some troubles though. Here's what I've done so far:

    Fresh install of 13.10 + installed all updates
    Installed fglrx and fglrx-pxpress and was notified that my AMD card was activated.
    Switched to my integrated Intel card (as I have very little need for the extra graphical power) in AMD Control Center
    Rebooted, everything works fine and I'm a happy boy.
    Rebooted again after some updates (nothing graphics related) and boom - the dreaded low graphics screen... I revert to default settings and reboot

    Now I'm back in business though with some issues.

    Running any aticonfig option presents me with the following error:
    $ aticonfig --pxl
    No layout section was found in the file: '/etc/X11/xorg.conf'.
    Please run 'aticonfig --initial' first or modify your configuration file manually and run aticonfig again.
    aticonfig: parsing the command-line failed
    Running aticonfig --initial gives me this:

    Uninitialised file found, configuring.
    PowerXpress error: Cannot stat '/usr/lib64/fglrx': No such file or directory
    Failed to initialize libglx for discrete GPU
    Using /etc/X11/xorg.conf
    Saving back-up to /etc/X11/xorg.conf.original-0

    So now aticonfig will at least tell me which card is active (the integrated card, as expected). However, AMD control center refuses to open and gives me another error message:

    "No AMD graphics driver is installed, or the AMD driver is not functioning properly.Please install the AMD driver appropriate for you AMD hardware, or configure using aticonfig."

    Rebooting again and I'm faced with the low graphics screen

    Any thoughts?
    Last edited by milleyj; November 27th, 2013 at 11:29 PM.

  2. #842
    Join Date
    May 2013

    Re: AMD/Intel Hybrid Graphics works

    You need to reinstall the fglrx driver (I guess). I think you could do it this way also: Download FGLRX driver package run it to generate .DEB packages, run it again to install everything, reboot - if fglrx not present - install the .DEB packages with sudo dpkg -i fglrx_driver_name......DEB.
    But first, try to create new initial configuration (as root) with sudo aticonfig --initial. You need to use sudo or log in as root user for hardware configuration tasks.
    Last edited by AngelGenchev; November 29th, 2013 at 09:33 PM.

  3. #843
    Join Date
    Feb 2013

    Re: AMD/Intel Hybrid Graphics works

    Does is works with AMD-AMD hybrid cards? I have one Radeon 4200 (onboard) and one Radeon 6370 (off-board) on my notebook, but it's almost impossible to make them work right.


  4. #844
    Join Date
    Dec 2013

    Re: AMD/Intel Hybrid Graphics works

    I'm sorry to get this thread dirty with a probably useless question, but there are 85 pages and I honestly doubt that the answer will be yes, so hunting down more info would only be tedious with an almost certain zero payoff.

    I've read the instructions provided, and some of the pages. I was just wondering...

    Is there support for Mobility Radeon HD 5xxx series now? My laptop is a HP G62-b21SL, if more in details specs are required.

  5. #845
    Join Date
    Dec 2013

    Re: AMD/Intel Hybrid Graphics works

    my laptop is HP 440G1 with haswell corei7 processor and AMD HD graphics (Mars, I think the Radeon HD 8xxxM version). using ubuntu 13.10. The drivers for AMD graphics are not installed by default. The performance is good on the Intel HD graphics. but, no matter what I do to install AMD graphics, I got a broken unity. Now I will try Nikola's method with stable driver. (13.4) working with 13.11 beta and opensource fglrx gave me broken unity. But, I'm not sure if I had installed fglrx-pxpress. Will do that and report back.
    I would also like to try to install just amdccle and amdxdg-su and logout and try again as mentioned in one of the post for Sony Vaio.

  6. #846
    Join Date
    Dec 2013

    Re: AMD/Intel Hybrid Graphics works

    Delighted! It was working all along, and I couldn't figure out! The reason being after rebooting and logging in, there was this black screen for some good length of time, which I thought was a crash of the unity desktop. I followed Nikola's post step by step and there was this reboot STEP after installing essentials and the same black screen with cursor came up..I waited and I get the desktop! Then I knew, that the driver would work after all, and this 'delay' in getting to the unity desktop was not because of the driver. So then here are my specs with success flag 'set' :-
    Laptop : HP Probook 440G1, OS: Ubuntu 13.10, Kernel: 3.11.0-14-generic, Processor :i7-4702MQ CPU @ 2.20GHz Discrete: [AMD/ATI] Mars [Radeon HD 8670A/8670M/8750M] Driver: AMD x64 for Linux Beta version 13.11. The open source driver fglrx could not detect the 8750M hardware.
    I tried switching from AMD graphics to the Haswell one using Catalyst control centre (gksudo amdcccle) and reboot got me smoothly into the Intel HD graphics. I found power consumption and CPU utilization reasonable in idle mode of AMD graphics.
    HDMI works for AMD graphics, but no audio on TV (that would be my next troubleshoot) , The audio from laptop speaker only.
    During a random test, laptop froze on waking from sleep, that may be a random issue, not sure have to test more.
    Nikola..much thanks to you! I was seeing this old movie "An affair to remember" your name reminded me of cary grant in the movie..may you get as much love in life as him!
    Thanks and Regards,

  7. #847
    Join Date
    Nov 2013

    Re: AMD/Intel Hybrid Graphics works - Intel won't work

    I run Debian Wheezy and I followed the instructions on, however, I did not build the driver, I just got the package from the repository. Before, my system worked fine with the intel gpu, but I can't set up the configuration for switching to the igpu... my xorg.conf looks like this:

    Section "ServerLayout"
        Identifier     " Configured"
        Screen      0  "aticonfig-Screen[0]-0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
    Section "Files"
        ModulePath   "/usr/lib/xorg/modules"
        FontPath     "/usr/share/fonts/X11/misc"
        FontPath     "/usr/share/fonts/X11/cyrillic"
        FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
        FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
        FontPath     "/usr/share/fonts/X11/Type1"
        FontPath     "/usr/share/fonts/X11/100dpi"
        FontPath     "/usr/share/fonts/X11/75dpi"
        FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
        FontPath     "built-ins"
    Section "Module"
        Load  "dri2"
        Load  "dbe"
        Load  "record"
        Load  "dri"
        Load  "glx"
        Load  "extmod"
    Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
    Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option        "Protocol" "auto"
        Option        "Device" "/dev/input/mice"
        Option        "ZAxisMapping" "4 5 6 7"
    Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-0"
        Option        "VendorName" "ATI Proprietary Driver"
        Option        "ModelName" "Generic Autodetecting Monitor"
        Option        "DPMS" "true"
    Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID       "PCI:2:0:0"
    Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device     "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth     24
        SubSection "Display"
            Viewport   0 0
            Depth     24
    Obviously, xorg.conf doesn't point to the igpu, but I just can't get it set up. It's also important to note that the /etc/X11/Xsession.d/10fglrx did not exist and there's no directory /usr/lib/fglrx/dri aticonfig clearly isn't able to point to the propper intel driver. I use a Dell inspiron 14z 5423 amd hd7570m and intel graphics HD 4000. Any help?

  8. #848
    Join Date
    Dec 2013

    Re: AMD/Intel Hybrid Graphics works

    Does anyone know what this means?

    mswh@G62LU:~/catalyst$ sudo sh ./ --buildpkg Ubuntu/precise
    : not 1: ./ 
    ./ 2: ./ Syntax error: redirection unexpected
    I tried multiple ubuntu based distros, kubuntu, ubuntu 12.4 LTS, even the last one, nothings seems to help me with this. I tried to understand, it seems like a problem related to bash but I'm a newbie and I really can't wrap my head around this. I tried googling and searching the forums, but to no avail. I tried asking people I know, but they have no idea. This forum is my last hope :/

  9. #849
    Join Date
    Aug 2007
    Ubuntu 14.04 Trusty Tahr

    Re: AMD/Intel Hybrid Graphics works

    This is how I fixed my problem with a Radeon 3000.

    1) sudo dpkg --configure -a
    2) sudo reboot
    3) sudo apt-get install -f
    4) sudo apt-get install --reinstall xserver-xorg-core xserver-xorg
    5) sudo reboot
    6) working fine now
    Best, Gnusci

    "Never make a calculation until you know the answer." -- Wheeler, Spacetime Physics, pg 60.

  10. #850
    Join Date
    Dec 2013

    Re: AMD/Intel Hybrid Graphics works

    I havent followed the developpement since years, but some years ago, xorg wasnt made, & not able to handle 2 differents brands graphic cards at the same time for DE, now maybe there are hacks to do this with xorg, while we are waiting for Weston/Wayland.

    But i thing this is the same problem as Nvidia/Intel Optimus technology.

    Xorg is realy a old technology, improved over decades, but at the begining, no one have started this project with multi brand graphic cards support in mind at the same time. (cannot swap form one gpu driver to another, etc, in live).

    Actualy i dunno, but everyone are working on Weston/Wayland (or MIR )
    Last edited by caymus; December 26th, 2013 at 05:48 PM.

Page 85 of 89 FirstFirst ... 35758384858687 ... LastLast

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts