Page 1 of 4 123 ... LastLast
Results 1 to 10 of 34

Thread: Massive Frustration with Cam4/Ubuntu flash drive

  1. #1

    Massive Frustration with Cam4/Ubuntu flash drive

    SIGHBALLS.

    okay, I have been trying to figure this out for two days. I am kind of a noob, so bear with me. I'm on Ubuntu trying to get my cam set up and working with Cam4 temporarly(yes, I am a cam girl, I know, I know lol). I can get my webcam to work with Cameroid.com, with stickam for streaming, youtube works etc....but with cam4 all i get is the main flash window with a grey screen where the camera should be and a spinning hourglass forever.

    What is the dealie-o?

    my pc is an Acer Aspire 5742, Acer Crystal Eye Webcam(aka Suyin Webcam). I'm using firefox and have installed the latest flash and tried to allow cam4 in flash(hate the new settings manager btw.) The problem I am running into that I can tell is that I have to allow a second site acess, but it is not listed in the list of sites i have visited(it is like codel.cam4.com or something like that, I can verify if you think it is necessary).

    I am booted off of a flash drive, is this why? Seems unusually i would just have an issue with one site like that(though i DID have issues with everything at first).

    HELP! I'm losing moneyyyyy

    also, I think i posted this incorrectly in multimedia, but I dont know how to delete from there.

  2. #2
    Join Date
    Dec 2011
    Location
    Florida
    Beans
    Hidden!
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: Massive Frustration with Cam4/Ubuntu flash drive

    Start your troubleshooting here:

    https://help.ubuntu.com/community/We...since_Intrepid

    P.S. Pics or we don't believe you... (Only kidding! Don't make the mods ban us both. )

  3. #3
    Join Date
    Mar 2010
    Beans
    Hidden!

    Re: Massive Frustration with Cam4/Ubuntu flash drive

    Quote Originally Posted by FrustratedRainbowzz View Post
    ...also, I think i posted this incorrectly in multimedia, but I dont know how to delete from there.
    You can't delete a thread, a moderator needs to do the changes.
    If you need to bring a post of yours to the attention of the moderators, use the "report abuse" button on the post. The button is not only for abuse, but for any issue the moderators need to be aware of.

    I have done the report for you, just in case nobody else did. Cheers, yetiman64

  4. #4
    Join Date
    Dec 2010
    Beans
    Hidden!

    Re: Massive Frustration with Cam4/Ubuntu flash drive

    Duplicate removed.


    404

  5. #5

    Re: Massive Frustration with Cam4/Ubuntu flash drive

    My heros!

    *swoons*

    Okay, if we are being honest, I never swoon. Anyways I am on this right now. IF you guys can help me figure this out, I will actually maybe stick with linux permanently. I mean, two days in I have learned quite a bit already haha.

    Watch this space for further info.

  6. #6

    Re: Massive Frustration with Cam4/Ubuntu flash drive

    Okay, I'm running across something!


    The library: /usr/lib/libv4l/v4l1compat.so does not exist.

    and this:

    LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so firefox
    results in

    ERROR: ld.so: object '/usr/lib/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded: ignored.
    ERROR: ld.so: object '/usr/lib/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded: ignored.
    ERROR: ld.so: object '/usr/lib/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded: ignored.

    No change so far. Also as a side note, I hated flash years ago in school too.


  7. #7
    Join Date
    Dec 2007
    Beans
    504

    Re: Massive Frustration with Cam4/Ubuntu flash drive

    Sounds like you might want to install Video For Linux:-
    http://packages.ubuntu.com/oneiric/libv4l-0

    Code:
    sudo apt-get install libv4l-0

  8. #8

    Re: Massive Frustration with Cam4/Ubuntu flash drive

    Okay, not sure whats up here but that .so file is not in that directory on my machine. It does exist, but at:

    /rofs/usr/lib/i386-linux-gnu/libv4l

    When i changed the directory, I was able to load it into the preload manager

  9. #9

    Re: Massive Frustration with Cam4/Ubuntu flash drive

    also in gstreamer-properties, I don't have a drop down option for V4l1. Just V4l2 and test and custom. I can successfully test the webcam from there when it is on V4l2.

    In before someone tells me to stop using a crappy internal camera and get a real one

  10. #10
    Join Date
    Dec 2011
    Location
    Florida
    Beans
    Hidden!
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: Massive Frustration with Cam4/Ubuntu flash drive

    Try this command in terminal

    Code:
    LD_PRELOAD=/rofs/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so firefox
    If that works add it to your "etc/environment" file.

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •