Results 1 to 4 of 4

Thread: 11.10 VNC "Screen" Resolution (Headless)

  1. #1
    Join Date
    Feb 2012
    Beans
    3

    Question 11.10 VNC "Screen" Resolution (Headless)

    Hi,

    I'm struggling to get enough useful screen resolution when using VNC to connect to Ubuntu in a headless setup.

    Description of my setup / steps to reproduce:

    1) Ubuntu 11.10 desktop edition set up as a server (file, print, JIRA, etc)
    2) I've got everything running well, and it starts up without a problem as a headless server. I specifically would like to get away without having a screen, mouse and keyboard.
    3) When I VNC into the machine with a screen attached, I get a great resolution over the connection.
    4) When I VNC in with the headless configuration, the screen resolution is horrible, and I can often not even resize application windows to be able to see tabs, etc. It's basically unusable.

    I've tried to use the "System Settings"> "Displays" options to change the resolution, but can't access any parameters as it recognizes screens as "OFF".

    Any suggestions? Very grateful if you can help.

    Kind regards,
    Brian

  2. #2
    Join Date
    Jul 2011
    Beans
    2

    Re: 11.10 VNC "Screen" Resolution (Headless)

    Here is what has worked for me. Thanks to ... http://ubuntuforums.org/showpost.php...5&postcount=21

    The answer is actually a combination of two separate solutions, each of which did not work separately.
    I have 11.10 now working headless.


    Step 1. Create a file called xorg.conf in /etc/X11 with the following text in it. (the X is case sensitive)

    Code:
    Section "Device"
    Identifier "VNC Device"
    Driver "vesa"
    EndSection
    
    Section "Screen"
    Identifier "VNC Screen"
    Device "VNC Device"
    Monitor "VNC Monitor"
    SubSection "Display"
    Modes "1024x768"
    EndSubSection
    EndSection
    
    Section "Monitor"
    Identifier "VNC Monitor"
    HorizSync 30-70
    VertRefresh 50-75
    EndSection
    Step 2. Disable KMS for your video card.

    I didn't know what make mine was so I created three files:-



    /etc/modprobe.d/radeon-kms.conf containing the line:-
    Code:
    options radeon modeset=0

    /etc/modprobe.d/i915-kms.conf containing the line:-
    Code:
    options i915 modeset=0

    /etc/modprobe.d/nouveau-kms.conf containing the line:-
    Code:
    options nouveau modeset=0
    Step 3. Reboot!


    If that works you might want to try for a higher resolution by adding to the modes line in the xorg.conf file so that it looks like this:-

    Code:
    Section "Device"
    Identifier "VNC Device"
    Driver "vesa"
    EndSection
    
    Section "Screen"
    Identifier "VNC Screen"
    Device "VNC Device"
    Monitor "VNC Monitor"
    SubSection "Display"
    Modes "1024x768"  "1280x1024"
    EndSubSection
    EndSection
    
    Section "Monitor"
    Identifier "VNC Monitor"
    HorizSync 30-70
    VertRefresh 50-75
    EndSection
    If any of this fails you might have to access recovery mode by rebooting and pressing the shift key just after bios has finished or by following this https://wiki.ubuntu.com/RecoveryMode
    Last edited by Cancelor; March 16th, 2012 at 02:16 PM.

  3. #3
    Join Date
    Feb 2012
    Beans
    3

    Re: 11.10 VNC "Screen" Resolution (Headless)

    Hi there,

    Thank you so much for the reply - it worked! I'm really grateful.

    Again - many thanks!

  4. #4
    Join Date
    Nov 2005
    Location
    Canada
    Beans
    81
    Distro
    Ubuntu 12.04 Precise Pangolin

    Thumbs up Re: 11.10 VNC "Screen" Resolution (Headless)

    +1
    Many thanx for this, to you Cancelor, and to the fellow in the link you provided (and all those who went before).

    thanx

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •