Results 1 to 2 of 2

Thread: iPhone Mounted but not recognized by programs

  1. #1
    Join Date
    Feb 2012

    Angry iPhone Mounted but not recognized by programs

    After a lot of work, I've managed to get my iPhone 4S running iOS 5.1 Beta 3 (fully supported by libimobiledevice) mounted and recognized by the OS. There are two items showing now, iPhone and Documents on iPhone - they are both listed under Devices in the file browser right under File System and on my desktop. I'm able to browse through the entire iPhone disk including system files, music, pictures, apps, ect. So, I think it's good to go but it's not recognized by any program to sync music. I've tried Banshee, Rhythmbox, and gtkpod. They simply do not show up at all and I tried adding the iPhone manually in gtkpod but when browsing for the mount point, my iPhone doesn't show up on the left where File System, CD drives, Home folders, etc is and I'm unable to locate it elsewhere within the File System. I can provide screen shots if that helps. In Shotwell however, it shows 'Documents on iPhone' as my camera and will load all photos on the camera roll, not in other albums however. That required no setup either - just worked. I'm not sure what to do at this point to get this thing recognized completely. I'm not new to Linux but I'm definitely the average user, not a pro with this stuff.

    Note: Jailbreak is not an option for the version of iOS I am using - nor do I want to go back to a jailbroken phone.
    Last edited by n52b30; February 19th, 2012 at 12:32 AM. Reason: Additional Information

  2. #2
    Join Date
    May 2005
    Windsor, Ontario, Canada
    Ubuntu 17.10 Artful Aardvark

    Re: iPhone Mounted but not recognized by programs

    I just embarrassed myself in front of my wife and her family trying to get my 12.04 Beta install to get some music onto her iPhone 4S. I am not sure how to proceed: It appears as though it will simply take some time for the libimobiledevice library to "catch up".
    Last edited by uc50_ic4more; April 11th, 2012 at 04:21 AM.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts