Results 1 to 10 of 23

Thread: Nvidia HDMI sound

Threaded View

  1. #1
    Join Date
    Jun 2009
    Location
    0:0:0:0:0:0:0:1
    Beans
    4,697
    Distro
    Xubuntu

    Question Nvidia HDMI sound

    Work around solution on next page as well as a hdmi audio solution (solution varies with kernel version and GPU)

    a while back i disabled the sound part of the nvidia driver by blacklisting it in /etc/modprobe.d/blacklist.conf

    this is my disabled hdmi sound code
    Code:
    # nvidia hdmi audio is disabled so apps will use the correct audio output
    blacklist snd_hda_codec_nvhdmi
    this would enable it right?
    Code:
    # nvidia hdmi audio is disabled so apps will use the correct audio output
    # blacklist snd_hda_codec_nvhdmi
    any way i have modprobed it and it still will not load the sound driver
    this is from lspci -vv
    Code:
    01:00.1 Audio device: nVidia Corporation Device 0bea (rev a1)
        Subsystem: nVidia Corporation Device 0000
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin B routed to IRQ 10
        Region 0: Memory at fea7c000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: [60] Power Management version 3
            Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
            Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [68] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
            Address: 0000000000000000  Data: 0000
        Capabilities: [78] Express (v2) Endpoint, MSI 00
            DevCap:    MaxPayload 128 bytes, PhantFunc 0, Latency L0s <4us, L1 <64us
                ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
            DevCtl:    Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
                RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
                MaxPayload 128 bytes, MaxReadReq 512 bytes
            DevSta:    CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr- TransPend-
            LnkCap:    Port #0, Speed 5GT/s, Width x16, ASPM L0s L1, Latency L0 <256ns, L1 <4us
                ClockPM+ Suprise- LLActRep- BwNot-
            LnkCtl:    ASPM Disabled; RCB 128 bytes Disabled- Retrain- CommClk+
                ExtSynch- ClockPM+ AutWidDis- BWInt- AutBWInt-
            LnkSta:    Speed 5GT/s, Width x16, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
    how do i re-enable it?
    Last edited by pqwoerituytrueiwoq; February 25th, 2012 at 03:29 PM.
    Laptop: ASUS A54C-NB91 (Storage: WD3200BEKT + MKNSSDCR60GB-DX); Desktop: Custom Build - Images included; rPi Server
    Putting your Networked Printer's scanner software to shame PHP Scanner Server
    I frequently edit my post when I have the last post

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •