Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: NetGear n300 not installing drivers

  1. #1
    Join Date
    Oct 2010
    Beans
    35

    NetGear n300 not installing drivers

    I am using "Wireless network drivers" to install the drivers for my N300. When i try to install the driver it gives me a black screen and it doesn't return me to the desktop I have the restart the computer. How do i fix this problem If you need anything from me please ask.

  2. #2
    Join Date
    Oct 2010
    Beans
    35

    Re: NetGear n300 not installing drivers

    Is there anyway to fix this?

  3. #3
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,324
    Distro
    Ubuntu 17.04 Zesty Zapus

    Re: NetGear n300 not installing drivers

    Isn't a Netgear N300 a router? I doubt you need any software at all to set it up. What is the software or driver you are trying to install?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  4. #4
    Join Date
    Oct 2010
    Beans
    35

    Re: NetGear n300 not installing drivers

    The USB adapter said "Wireless N-300 USB adapter WNA3100" I tried to install the drives with out the USB I guess it did but as soon as I plugged in the USB it when to a black screen with a bunch of code.

  5. #5
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,324
    Distro
    Ubuntu 17.04 Zesty Zapus

    Re: NetGear n300 not installing drivers

    Did you try to install the Windows drivers from the CD? Linux is not Windows, thank heavens!

    With the device inserted, run and post:
    Code:
    lsusb
    uname -r
    Thanks.

    We may or may not need the attached. Please wait until I tell you to use them.
    Attached Files Attached Files
    Last edited by chili555; February 10th, 2012 at 05:22 PM.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  6. #6
    Join Date
    Oct 2010
    Beans
    35

    Re: NetGear n300 not installing drivers

    martin@martin-OptiPlex-745:~$ lsusb
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 006 Device 002: ID 046d:c52f Logitech, Inc. Wireless Mouse M305
    Bus 007 Device 002: ID 413c:2003 Dell Computer Corp. Keyboard
    Bus 001 Device 003: ID 0846:9020 NetGear, Inc. WNA3100(v1) Wireless-N 300 [Broadcom BCM43231]


    martin@martin-OptiPlex-745:~$ uname -r
    3.0.0-15-generic

  7. #7
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,324
    Distro
    Ubuntu 17.04 Zesty Zapus

    Re: NetGear n300 not installing drivers

    You do, indeed need the drivers I attached. Download them to your desktop. Right click and select Extract Here. Now open a terminal and do:
    Code:
    sudo ndiswrapper -i Desktop/wna3100-drivers/bcmwlhigh5.inf
    sudo ndiswrapper -a 0846:9020 bcmwlhigh5
    sudo modprobe ndiswrapper
    Now let's check:
    Code:
    ndiswrapper -l
    iwconfig
    Is it working now? If not, please post:
    Code:
    dmesg | grep ndis
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  8. #8
    Join Date
    Oct 2010
    Beans
    35

    Re: NetGear n300 not installing drivers

    martin@martin-OptiPlex-745:~$ sudo ndiswrapper -i Desktop/wna3100-drivers/bcmwlhigh5.inf
    driver bcmwlhigh5 is already installed

    martin@martin-OptiPlex-745:~$ sudo ndiswrapper -a 0846:9020 bcmwlhigh5
    Driver 'bcmwlhigh5' is already used for '0846:9020'

    martin@martin-OptiPlex-745:~$ sudo modprobe ndiswrapper

    martin@martin-OptiPlex-745:~$ ndiswrapper -l
    bcmwlhigh5 : invalid driver!

    martin@martin-OptiPlex-745:~$ iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    martin@martin-OptiPlex-745:~$ dmesg | grep ndis
    [ 301.849557] ndiswrapper version 1.56 loaded (smp=yes, preempt=no)
    [ 301.874637] usbcore: registered new interface driver ndiswrapper
    [ 425.175212] ndiswrapper (load_wrap_driver:108): couldn't load driver bcmwlhigh5; check system log for messages from 'loadndisdriver'

  9. #9
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,324
    Distro
    Ubuntu 17.04 Zesty Zapus

    Re: NetGear n300 not installing drivers

    It sounds like you already tried this and installed the Windows 7 or Vista .inf file. ndiswrapper requires the XP driver.
    DESCRIPTION
    ndiswrapper is two parts: user space tool that is used to install Windows XP drivers and kernel module to load the Windows XP drivers. Both are called ndiswrapper.
    Let's do as suggested; check the logs:
    Code:
    sudo cat /var/log/syslog | grep -i ndis | tail -n20
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  10. #10
    Join Date
    Oct 2010
    Beans
    35

    Re: NetGear n300 not installing drivers

    martin@martin-OptiPlex-745:~$ sudo cat /var/log/syslog | grep -i ndis | tail -n20

    [sudo] password for martin:

    Feb 10 11:32:50 martin-OptiPlex-745 kernel: [ 2011.176271] usbcore: deregistering interface driver ndiswrapper
    Feb 10 11:32:50 martin-OptiPlex-745 kernel: [ 2011.187159] ndiswrapper version 1.56 loaded (smp=yes, preempt=no)
    Feb 10 11:32:50 martin-OptiPlex-745 loadndisdriver: loadndisdriver: load_driver(337): coudln't find valid drivers files for driver bcmwlhigh5
    Feb 10 11:32:50 martin-OptiPlex-745 adndisdriver: loadndisdriver: load_driver(358): couldn't load driver bcmwlhigh5
    Feb 10 11:32:50 martin-OptiPlex-745 loadndisdriver: loadndisdriver: load_driver(358): couldn't load driver bcmwlhigh5
    Feb 10 11:32:50 martin-OptiPlex-745 kernel: [ 2011.439207] ndiswrapper (load_wrap_driver:108): couldn't load driver bcmwlhigh5; check system log for messages from 'loadndisdriver'
    Feb 10 11:32:50 martin-OptiPlex-745 kernel: [ 2011.439251] usbcore: registered new interface driver ndiswrapper
    Feb 10 11:56:17 martin-OptiPlex-745 kernel: [ 3418.779801] usbcore: deregistering interface driver ndiswrapper
    Feb 10 11:56:17 martin-OptiPlex-745 kernel: [ 3418.790618] ndiswrapper version 1.56 loaded (smp=yes, preempt=no)
    Feb 10 11:56:18 martin-OptiPlex-745 kernel: [ 3419.048359] ndiswrapper (link_pe_images:565): fixing KI_USER_SHARED_DATA address in the driver
    Feb 10 11:56:18 martin-OptiPlex-745 kernel: [ 3419.050453] ndiswrapper: driver bcmn43xx64 (,08/26/2009, 5.10.79.30) loaded
    Feb 10 11:56:19 martin-OptiPlex-745 kernel: [ 3419.052709] IP: [<ffffffffa02f2e39>] USBD_InterfaceIsDeviceHighSpeed+0x9/0x20 [ndiswrapper]
    Feb 10 11:56:19 martin-OptiPlex-745 kernel: [ 3419.052775] Modules linked in: ndiswrapper(+) nls_utf8 isofs snd_hrtimer bnep rfcomm bluetooth snd_hda_codec_analog snd_hda_intel snd_hda_codec snd_hwdep binfmt_misc snd_pcm snd_seq_midi snd_rawmidi snd_seq_midi_event snd_seq joydev snd_timer snd_seq_device snd nouveau soundcore snd_page_alloc ttm ppdev drm_kms_helper dcdbas psmouse drm serio_raw i2c_algo_bit mxm_wmi wmi video parport_pc lp parport usbhid hid tg3 [last unloaded: ndiswrapper]
    Feb 10 11:56:19 martin-OptiPlex-745 kernel: [ 3419.052928] RIP: 0010:[<ffffffffa02f2e39>] [<ffffffffa02f2e39>] USBD_InterfaceIsDeviceHighSpeed+0x9/0x20 [ndiswrapper]
    Feb 10 12:02:04 martin-OptiPlex-745 kernel: [ 301.849557] ndiswrapper version 1.56 loaded (smp=yes, preempt=no)
    Feb 10 12:02:04 martin-OptiPlex-745 kernel: [ 301.874637] usbcore: registered new interface driver ndiswrapper
    Feb 10 12:04:07 martin-OptiPlex-745 loadndisdriver: loadndisdriver: load_driver(337): coudln't find valid drivers files for driver bcmwlhigh5
    Feb 10 12:04:07 martin-OptiPlex-745 adndisdriver: loadndisdriver: load_driver(358): couldn't load driver bcmwlhigh5
    Feb 10 12:04:07 martin-OptiPlex-745 loadndisdriver: loadndisdriver: load_driver(358): couldn't load driver bcmwlhigh5
    Feb 10 12:04:07 martin-OptiPlex-745 kernel: [ 425.175212] ndiswrapper (load_wrap_driver:108): couldn't load driver bcmwlhigh5; check system log for messages from 'loadndisdriver'

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •