Results 1 to 7 of 7

Thread: DoD CAC with ubuntu 11.10 and Firefox 7.0.1

  1. #1
    Join Date
    Nov 2011
    Beans
    3

    DoD CAC with ubuntu 11.10 and Firefox 7.0.1

    Hi.
    I am trying to get a DoD CAC to work with Ubuntu 11.10 and Firefox 7.0.1. I have the card reader installed and "Pcsc_scan" will show the reader and the card but when I try to open Firefox with the card inserted it will not open. Alternatively, if Firefox is open and I insert the card, Firefox will crash and not restart until the card is removed.
    I have searched google.com and the ubuntu forums far and wide and I cannot find any help. I have also asked this multiple times on #ubuntu irc. If you could offer any help it will be greatly appreciated.

  2. #2
    Join Date
    Nov 2011
    Beans
    3

    Re: DoD CAC with ubuntu 11.10 and Firefox 7.0.1

    mods: you can close this as solved. I figured out that "cackey" is what is needed for 11.10 and ff 7.0.1 to run the reader correctly.

  3. #3
    Join Date
    Aug 2008
    Location
    Brazil
    Beans
    12,497
    Distro
    Ubuntu Studio 12.04 Precise Pangolin

    Re: DoD CAC with ubuntu 11.10 and Firefox 7.0.1

    Quote Originally Posted by bsmith12345 View Post
    mods: you can close this as solved. I figured out that "cackey" is what is needed for 11.10 and ff 7.0.1 to run the reader correctly.
    There is no reason to close it. Marking the thread as solved. For future reference, you can do that through the Thread Tools menu.

  4. #4
    Join Date
    Jun 2007
    Location
    Planet-Untu
    Beans
    156
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: DoD CAC with ubuntu 11.10 and Firefox 7.0.1

    Recommend that you take a look at this site for guide if you are US Government and need CAC for work access.

    http://geekyschmidt.com/2011/01/19/y...-linux-and-you

    NOTE: Posting for the general community.

  5. #5
    Join Date
    Nov 2008
    Beans
    53

    Re: DoD CAC with ubuntu 11.10 and Firefox 7.0.1

    I'm afraid I'm not having as much luck. I've compiled and installed libcackey successfully, however opening firefox with a card in results in an immediate crash. Crashes when I try the card with it open, and comes back up after I remove the card.

    Card is read fine in the pcsc_scan report, and I've loaded the libcackey module in Firefox 8, ubuntu 11.10. I followed instructions from the GeekySchmidt site above to no avail.

    Latest version of libcoolkey yields the same result.

    Any suggestions? My father wishes to completely defenestrate his work at home.

  6. #6
    Join Date
    Aug 2007
    Beans
    4
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: DoD CAC with ubuntu 11.10 and Firefox 7.0.1

    I too am having a terrible time with the installation of cackey. I have downloaded the file on seperate occasions to eliminate the possibility of a corrupt dload, but I keep getting this error string:

    (Reading database ...
    (Reading database ... 5%
    (Reading database ... 10%
    (Reading database ... 15%
    (Reading database ... 20%
    (Reading database ... 25%
    (Reading database ... 30%
    (Reading database ... 35%
    (Reading database ... 40%
    (Reading database ... 45%
    (Reading database ... 50%
    (Reading database ... 55%
    (Reading database ... 60%
    (Reading database ... 65%
    (Reading database ... 70%
    (Reading database ... 75%
    (Reading database ... 80%
    (Reading database ... 85%
    (Reading database ... 90%
    (Reading database ... 95%
    (Reading database ... 100%
    (Reading database ... 171645 files and directories currently installed.)
    Unpacking cackey (from .../cackey_0.6.5-1_amd64.deb) ...
    dpkg: error processing /home/myputer/Downloads/cackey_0.6.5-1_amd64.deb (--install):
    unable to create `/usr/lib64/libcackey.so.dpkg-new' (while processing `./usr/lib64/libcackey.so'): No such file or directory
    dpkg-deb (subprocess): data: internal gzip write error: Broken pipe
    dpkg-deb: error: subprocess <decompress> returned error exit status 2
    dpkg-deb (subprocess): failed in write on buffer copy for failed to write to pipe in copy: Broken pipe

    If anyone can help, I would greatly appreciate it.

    HP dv7-4065; AMD Phenom II N830 x3; 4GB; Ubuntu 11.10
    Last edited by ramirabeau; March 30th, 2012 at 06:46 PM. Reason: update information

  7. #7
    Join Date
    Jul 2006
    Location
    Layton, Utah
    Beans
    42
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: DoD CAC with ubuntu 11.10 and Firefox 7.0.1

    Old post I know; but I think I have the answer to the failed dpkg install. You need to manually create and empty lib64 in the /usr directory:
    sudo mkdir /usr/lib64

    Then run it again.

    MY problem is that the link everyone posts for cackey seems to be GONE, broken or what ever but I really need to get the cackey .deb file so I can get my access to the Air Force Portal back while on leave.

    Any ideas are greatly appreciated,.
    Be nice or I will have you ctrl+alt+deleted!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •