I was trying to eliminate the grub menu by messing with /etc/grub.d/30_os-prober. I experimented on my computer (which has 10.04 netbook edition and 11.10) before trying it for work. Now I can't boot 10.04 at all (11.10 works fine). When I boot 10.04 I get the following prompt:

No init found. Try passing init=bootarg.

BusyBox v1.13.3 (Ubuntu 1=1.13.3-1ubuntu11)built-in shell (ash)

Enter 'help' for a list of built-in commands.


The following are the results I get from trying things I've found on the forums.

root@fixme!:~# resize2fs /dev/sda1
resize2fs 1.41.14 (22-Dec-2010)
Please run 'e2fsck -f /dev/sda1' first.

root@fixme!:~# e2fsck /dev/sda1

fsck from util-linux 2.19.1

e2fsck 1.41.14 (22-Dec-2010)

The filesystem size (according to the superblock) is 37568512 blocks

The physical size of the device is 35014279 blocks

Either the superblock or the partition table is likely to be corrupt!

Abort<y>? no

/dev/sda1 contains a file system with errors, check forced.

Pass 1: Checking inodes, blocks, and sizes

Pass 2: Checking directory structure

Pass 3: Checking directory connectivity

Pass 4: Checking reference counts

Pass 5: Checking group summary information

Error reading block 35127296 (Invalid argument) while reading inode and block bitmaps. Ignore error<y>?

**followed by lots of “error writing/reading block 356....” → yes
forcerewrite” → yes

Block bitmap differences: +(35127296--35135519) +(35651584--35659807) +(36175872--36184095) +(36700160--36708383) +(37224448--37224458) +(37224464--37224474) +(37224480--37230111)


**followed by lots more “ error writing/reading block 357....” → yes
“force rewrite” → yes

/dev/sda1: ***** FILE SYSTEM WAS MODIFIED *****

/dev/sda1: 212641/9396224 files (0.5% non-contiguous), 32916695/37568512 blocks

Error writing block 35127296 (Invalid argument) while writing block and inode bitmaps. Ignore error<y>? yes

**followed by lots more “error writing/reading block 357....” → yes
“force rewrite” → yes

.and it leads to nowhere once it has worked through all the errors.

root@fixme!:~# mount /dev/sda1

mount: can't find /dev/sda1 in /etc/fstab or /etc/mtab

Still won't boot, still can't mount. I've tried resizing the partition, mounting (see Terminal text above , etc. Memtest seemed to come up fine. Is there anything else I can try (or retry) ? I've tried the systemrescuecd to no avail but I get the same messages as above in terminal and errors that don't allow me to do anything when I try gparted.

I just want to recover my files in 10.04! Please help!

Thanks for your time.