Results 1 to 1 of 1

Thread: Getting Switchable Graphics (AMD Radeon) to work with compiz, usp, conky, etc...

  1. #1
    Join Date
    Feb 2008
    Ubuntu 9.04 Jaunty Jackalope

    Getting Switchable Graphics (AMD Radeon) to work with compiz, usp, conky, etc...

    If you have tried to get switchable graphics to work (using among others this site) (i.e. you have an intel graphics card and an AMD one but you can't change them in the BIOS, the software/OS has to change them for you) on your laptop but have had limited success then try the following.

    1. Make sure you install the 32bit support binaries for your 64bit system (that's if you have one and a 64bit OS) by typing the following into a terminal
    sudo apt-get install ia32-libs
    2. downloaded the latest Catalyst driver install for linux.

    3. Install it using it default selections. Example:

    cd Downloads/
    chmod 0777
    4. Reboot

    5. In the terminal run the command
    and see if you have some nice gears in a window

    6. In the terminal run the command
    . If any of the lines you get back from the system have 'AMD' in them then your install of the drivers was successful. For example my system gives me the following.

    dave@dave-computer:~$ fglrxinfo
    display: :0.0  screen: 0
    OpenGL vendor string: Advanced Micro Devices, Inc.
    OpenGL renderer string: AMD Radeon 6600M and 6700M Series
    OpenGL version string: 4.2.11318 Compatibility Profile Context
    7. Then try to enable
    System > Preferences > Appearance > Visual Effects > Extra
    . If it fails with
    Desktop Effect could not be enable

    8. Open a terminal and enter
    compiz --replace ccp
    if this return a line that has the following
    Blacklisted PCI ID XXXX:XXXX detected
    (where XXXX:XXXX is a set of numbers. it was
    Blacklisted PCI ID 8086:0116 detected
    in my case) remember these numbers and then...

    9. Type the following into the console
    sudo gedit /usr/bin/compiz
    . If gedit opens with a BIG RED ERROR saying
    Could not open the file /usr/bin/compiz
    that means that the file in hexadecimal (don't ask!). If this happen then...

    10. Type the following in to the console
    sudo apt-get install ghex
    followed by
    sudo ghex2 /usr/bin/compiz
    (thanks to this post)

    11. in the hex editor that pops up scroll to the bottom of the file and then slowly scroll up looking for those number I told you to remember (I found mine about 1/3 of the way up the file).

    12. When you have found the number replace any number with another number just to make it different (I replaced 8086:0116 to 8086:0117) and then save the file.

    13. Then try to enable compiz effects again
    System > Preferences > Appearance > Visual Effects > Extra

    Hope this helps someone because I have been working on getting this working for weeks.

    Thanks to: << Big Help!!!
    Last edited by sevenearths; May 21st, 2012 at 02:00 PM. Reason: make thing clears for beginers
    There is nothing common about sense - unknown

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts