Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Failed to fetch

  1. #11
    Join Date
    Jan 2006
    Ubuntu 8.10 Intrepid Ibex

    Re: Failed to fetch

    The 360-chars problem is still not completely fixed - occurs intermittently depending on which mirror you get sent to. but switch.dl should be working fine at least. so as mike said, please post your sources.list.

  2. #12
    Join Date
    Jan 2006
    Ubuntu 8.10 Intrepid Ibex

    Re: Failed to fetch

    Sourceforge has fixed the long-header problem, and the repository now works without issues using the server.

  3. #13
    Join Date
    May 2009
    Takoma Park, MD
    Ubuntu 8.04 Hardy Heron

    Re: Failed to fetch

    I followed the 4 term line steps for automating Firefox updates at, but it's not working.

    My sources.list file is (so you'll see I've already added mirror per nanotube):
    deb hardy main universe multiverse restricted
    deb-src hardy main universe multiverse restricted

    deb hardy-updates main universe multiverse restricted
    deb-src hardy-updates main universe multiverse restricted

    deb hardy-security main universe multiverse restricted
    deb-src hardy-security main universe multiverse restricted

    deb hardy-netbook-base main universe multiverse restricted
    deb-src hardy-netbook-base main universe multiverse restricted

    deb hardy-dell-mini main universe multiverse restricted
    deb-src hardy-dell-mini main universe multiverse restricted

    deb all main
    deb all main

    deb all main
    The sudo apt-key step shows:
    susan@susan:~$ sudo apt-key adv --recv-keys --keyserver C1289A29
    Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --recv-keys --keyserver C1289A29
    gpg: requesting key C1289A29 from hkp server
    gpg: key C1289A29: "Daniel Folkinshteyn (Ubuntuzilla signing key) <>" not changed
    gpg: Total number processed: 1
    gpg: unchanged: 1
    The sudo apt-get shows (see blue text in middle):
    susan@susan:~$ sudo apt-get update
    Ign all Release.gpg
    Hit hardy Release.gpg
    Ign hardy/main Translation-en_US
    Hit all Release.gpg
    Ign all/main Translation-en_US
    Ign all/main Translation-en_US
    Ign hardy/universe Translation-en_US
    Ign hardy/multiverse Translation-en_US
    Ign hardy/restricted Translation-en_US
    Hit hardy-updates Release.gpg
    Ign hardy-updates/main Translation-en_US
    Ign hardy-updates/universe Translation-en_US
    Ign hardy-updates/multiverse Translation-en_US
    Ign hardy-updates/restricted Translation-en_US
    Hit hardy-security Release.gpg
    Hit all Release
    Ign all Release
    Ign hardy-security/main Translation-en_US
    Ign hardy-security/universe Translation-en_US
    Ign hardy-security/multiverse Translation-en_US
    Ign hardy-security/restricted Translation-en_US
    Hit hardy-netbook-base Release.gpg
    Ign all/main Packages
    Ign hardy-netbook-base/main Translation-en_US
    Ign hardy-netbook-base/universe Translation-en_US
    Ign hardy-netbook-base/multiverse Translation-en_US
    Ign hardy-netbook-base/restricted Translation-en_US
    Hit hardy-dell-mini Release.gpg
    Err all/main Packages
    404 Not Found

    Ign hardy-dell-mini/main Translation-en_US
    Ign hardy-dell-mini/universe Translation-en_US
    Ign hardy-dell-mini/multiverse Translation-en_US
    Ign hardy-dell-mini/restricted Translation-en_US
    Hit hardy-dell-mini Release.gpg
    Ign hardy-dell-mini/public Translation-en_US
    Hit hardy Release
    Hit hardy-updates Release
    Hit hardy-security Release
    Hit hardy-netbook-base Release
    Hit hardy-dell-mini Release
    Hit hardy-dell-mini Release
    Hit hardy/main Packages
    Hit hardy/universe Packages
    Hit hardy/multiverse Packages
    Hit hardy/restricted Packages
    Hit hardy/main Sources
    Hit hardy/universe Sources
    Hit hardy/multiverse Sources
    Hit hardy/restricted Sources
    Hit hardy-updates/main Packages
    Hit hardy-updates/universe Packages
    Hit hardy-updates/multiverse Packages
    Hit hardy-updates/restricted Packages
    Hit hardy-updates/main Sources
    Hit hardy-updates/universe Sources
    Hit hardy-updates/multiverse Sources
    Hit hardy-updates/restricted Sources
    Hit hardy-security/main Packages
    Hit hardy-security/universe Packages
    Hit hardy-security/multiverse Packages
    Hit hardy-security/restricted Packages
    Hit hardy-security/main Sources
    Hit hardy-security/universe Sources
    Hit hardy-security/multiverse Sources
    Hit hardy-security/restricted Sources
    Ign hardy-netbook-base/main Packages
    Ign hardy-netbook-base/universe Packages
    Ign hardy-netbook-base/multiverse Packages
    Ign hardy-netbook-base/restricted Packages
    Ign hardy-netbook-base/main Sources
    Ign hardy-netbook-base/universe Sources
    Ign hardy-netbook-base/multiverse Sources
    Ign hardy-netbook-base/restricted Sources
    Ign hardy-dell-mini/main Packages
    Ign hardy-dell-mini/universe Packages
    Ign hardy-dell-mini/multiverse Packages
    Ign hardy-dell-mini/restricted Packages
    Ign hardy-dell-mini/main Sources
    Ign hardy-dell-mini/universe Sources
    Ign hardy-dell-mini/multiverse Sources
    Ign hardy-dell-mini/restricted Sources
    Hit hardy-dell-mini/public Packages
    Hit hardy-dell-mini/public Sources
    Hit hardy-netbook-base/main Packages
    Hit hardy-netbook-base/universe Packages
    Hit hardy-netbook-base/multiverse Packages
    Hit hardy-netbook-base/restricted Packages
    Hit hardy-netbook-base/main Sources
    Hit hardy-netbook-base/universe Sources
    Hit hardy-netbook-base/multiverse Sources
    Hit hardy-netbook-base/restricted Sources
    Hit hardy-dell-mini/main Packages
    Hit hardy-dell-mini/universe Packages
    Hit hardy-dell-mini/multiverse Packages
    Hit hardy-dell-mini/restricted Packages
    Hit hardy-dell-mini/main Sources
    Hit hardy-dell-mini/universe Sources
    Hit hardy-dell-mini/multiverse Sources
    Hit hardy-dell-mini/restricted Sources
    W: Failed to fetch Unable to find expected entry main/binary-lpia/Packages in Meta-index file (malformed Release file?)

    W: Failed to fetch 404 Not Found

    E: Some index files failed to download, they have been ignored, or old ones used instead.
    Perhaps it shouldn't be surprising that the sudo apt-get install didn't work:
    susan@susan:~$ sudo apt-get install firefox-mozilla-build
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Couldn't find package firefox-mozilla-build
    I thought I'd try the instructions at: and everything went fine till I asked the Software Sources to reload, at which point I get same error message as in sudo apt-get update step. The Synaptic Package Manager also can't find the mozilla-build.

    Any idea why this isn't working for me? I currently have Firefox for Ubuntu 3.6.17. I think I have Hardy Heron 8.04 for Linux, but don't remember how to figure that out.

  4. #14
    Join Date
    Jan 2006
    Ubuntu 8.10 Intrepid Ibex

    Re: Failed to fetch

    hi hewittkennedy,

    yes you do appear to have an old ubuntu release, hardy 8.04, and further which is the dell flavor of the lpia architecture.

    There are a number of problems here:
    1. lpia is a separate architecture build, and the packages of ubuntuzilla (or really almost anything else out there) don't support it.
    2. hardy is old, and the apt-get system doesn't support http redirects, which the main gateway uses, so you'd have to specific mirror ( is one such mirror - you'll see in your output that that one worked fine - but complained about missing lpia packages)

    my suggestion to you is to do the following:
    1. back up your personal files from this computer
    2. make a fresh install of the latest ubuntu 32bit (or xubuntu - these days i'm a xubuntu fan )
    3. if you wish, follow the steps again to add the ubuntuzilla repository and install the latest mozilla builds, though the latest ubuntu would also come with recent mozilla software.

    all the best!

Page 2 of 2 FirstFirst 12


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts